Vivaldi & Windows 10



  • I'm having trouble getting Vivaldi (252.3) to integrate properly into Windows 10, I have been looking at the other post on this subject but thought I would keep out of there. I have selected to have Vivaldi as default browser in Vivaldi settings and I'm not sure if the following are down to Win 10 or Vivaldi. If I try clicking on a link to a web page in an email, or any other software, nothing happens. These two are not much of a problem: Internet shortcuts have a Vivaldi icon but when I click on them I get a small window showing the URL followed by 'class not registered'. Vivaldi has also set it's self to default handler for 'mail to' links but it obviously can't do anything with them and I can't find any way to change it to my email prog (Opera email).



  • It's a problem that happens more frequently if you have Vivaldi installed for all users (in program files).

    It that's your case try to uninstall Vivaldi reinstalling it as per user (Vivaldi will be installed on your home directory)



  • I normally prefer the stand alone install but have just tried a normal install for my user account and am having even more problems with that. The 'set Vivaldi as default' did not seem to do anything and had to associate htm, html etc., manually but still no links in emails opening. Having to copy/paste them isn't a big deal but it would be nice if it worked.



  • @Fw190:

    The 'set Vivaldi as default' did not seem to do anything

    Do you mean Vivaldi's own setting?

    W10 behavior is changed on that. You have to go on W10's

    settings > system > default apps



  • Yes it was Vivaldi's own setting I had used but just tried the windoze default apps one and there doesn't appear to be any difference from when I did the file associations manually. Still not links in emails opening.
    I have just been going through the 'win 10 - settings - choose default file acclamations by file type' again and noticed the '.url' extension just shows 'internet browser' and no option to change it to Vivaldi, Edge or IE.



  • @The_Solutor:

    @Fw190:

    The 'set Vivaldi as default' did not seem to do anything

    Do you mean Vivaldi's own setting?

    W10 behavior is changed on that. You have to go on W10's

    settings > system > default apps

    The settings app not fully set the browser as default, only partial options. If you like to put a browser really as default, your need to go to Control panel - Default Programs - Establish default programs and change from here.



  • @Pesanur:

    [quote=
    The settings app not fully set the browser as default, only partial options. If you like to put a browser really as default, your need to go to Control panel - Default Programs - Establish default programs and change from here.

    Already tried that, see post #33614

    Am having another problem with Vivaldi now, it has decided to use Spanish or something, it is set to English in settings and I went into my profile on the forum but it says there are zero countries to select, are there any other ways to change the language it uses.



  • @Fw190:

    @Pesanur:

    [quote=
    … it is set to English in settings and I went into my profile on the forum but it says there are zero countries to select, are there any other ways to change the language it uses.

    Just type first letter in the Country field, will show a list of countries



  • Thanks, that fixed it.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.