Bug? "F2" Search-Dialog doesn't repect the standard search-engine



  • Hello, if I press "F2", there is a search-dialog and if I searching something (without shortcut for the search-engines), it doesn't respect standard search-engine! I have test it with the actually snpashot and a fresh profile on Arch-Linux! For example, if I change my standard-search to DuckDuckGo, the results will be searching with Startpage. Or if I change my standard-search to Startpage, the results will be searching with Wolfram|Alpha. Can anyone confirm this? I Thank you.



  • Hi kar82, welcome to the forum!

    Pushing F2 opens in my Vivaldi 1.0.252.3 (Developer Build) dev (64-bit) on Mint 17.1 (Cinnamon desktop) this window:
    [attachment=1592]VivaldiF22015-08-22145107.png[/attachment]
    Scrolling down presents all the different commands but no search field. If I use the address bar as a search field, at once the default search engine is opened.
    Do you only push {F2} or is there something else?
    Attachments:



  • I can see the search field in your sreenshot ("Filter Quick Commands" is the search field)!!!

    You must open it with F2 and then you can enter something:
    [attachment=1593]Vivaldi_F2_search-field.png[/attachment]

    But my standard-search is not StartPage, it's DuckDuckGo!
    Attachments:



  • Thank you for this hint! I didn't know this being a search field.

    Here the picture when using it. It opens the default search engine which is DuckDuckGo:

    [attachment=1594]DefaultSearch2015-08-22151434.png[/attachment]
    Attachments:



  • Strange?!

    Can you please change your standard-search temporary (e.g. to StartPage or Google) and then look to the F2 search-dialog? What about now?

    Thank you.

    [EDIT]

    Are you using the standard-search-engines? Have you delete one (e.g. ebay)? But I have found out that the problem or bug exist only if I delete a standard-search-engine.

    For exmaple, my standard-search is DuckDuckGo. Then I delete ebay and after this, in the F2 search-dialog the standard-search is now StartPage! That's really strange.

    Can anyone confirm this?



  • Sorry, I forgot to mention I didn't add or delete any search engine. Now I deleted ebay and surprise, surprise I get the wrong search:

    [attachment=1595]F2Wrong2015-08-22154333.png[/attachment]

    Here the search preferences:

    [attachment=1596]SearchPreferences2015-08-22154549.png[/attachment]
    Attachments:
    ,



  • Thank you very much for your testing!!!

    So, I will write a bug report!

    [EDIT]

    The issue-number is: VB-8633



  • Thank you for your dedication! Now I added an additional search engine. I got the same wrong search (with startpage). Then I changed the default search engine to this added one. Now the search field doesn't accept any input anymore. Changing the default to Wikipedia results in correct behaviour. Changing back to DuckDuckGo and it's still the same error. Now I have to turn back to such an adjustment that DuckDuckGo is used again. :)



  • Ok, I think the add- or delete-behaviour should be the "same thing".

    In the bug report I have only written the behaviour with delete one. But I hope the Vivaldi devs are attentive to find and resolve the bug for the add- and delete-behaviour.

    [EDIT]

    I Have answer the bug-report-email, because of the same behaviour if we add a new search-angine. I hope the Vivialdi devs will read this answer. We will see!



  • @kar82:

    Thank you very much for your testing!!!

    So, I will write a bug report!

    [EDIT]

    The issue-number is: VB-8633

    I was able to reproduce the bug, your report is marked as confirmed now.

    Thanks for the head-up. ;)



  • Super, so I will flag this topic as "solved" for now.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.