Remove main menu?



  • Hi there, I was wondering how to remove the main menu ("File", "Edit", "View", . . .) from the Vivaldi window? The OS X already shows the main menu outside the Vivaldi window. Vivaldi 1.0.249.12. Also, the red (close) and green (maximize) buttons should go away from the Vivaldi window when it's maximized. Regards, Ryo



  • On os x you shouldn't see the menu in the window. Even if you use native window there should only be a standard grey bar on top. Maybe show a screenshot? In any case, try to uncheck native window.
    And yeah, you can't go to fullscreen from a standard vivaldi window yet. A workaround is to toggle UI (cmd F11 or cmd fn F11) and then go to fullscreen with ctrl cmd F. This gives you "real" fullscreen.



  • Thanks for your prompt response!

    @luetage:

    On os x you shouldn't see the menu in the window. Even if you use native window there should only be a standard grey bar on top. Maybe show a screenshot? In any case, try to uncheck native window.

    I've never turned on the "Use Native Window" switch; I've just checked and confirmed that it remains unchecked in the "Appearance" category of the Preferences.

    As you can see in the attached screenshot, there are main-menu items at the top of the Vivaldi window. This problem has just started since I upgraded to the latest snapshot: 1.0.249.12 (Developer Build) (64-bit).

    @luetage:

    And yeah, you can't go to fullscreen from a standard vivaldi window yet. A workaround is to toggle UI (cmd F11 or cmd fn F11) and then go to fullscreen with ctrl cmd F. This gives you "real" fullscreen.

    Right. I guess this is an old problem.

    [attachment=1584]vivaldi-window-sample.png[/attachment]
    Attachments:



  • As said, fullscreen is not a problem if you toggle UI beforehand.

    And the menu I really don't get. I'm on os x 10.10.5, also latest snapshot and I never had a menu on my application window – with any setting or any program. Is this maybe an os x specific setting? On what version of os x are you? If all fails try reinstalling, you really shouldn't have this displayed, it's completely superfluous.



  • Can you toggle the horizontal menu? View > Horizontal Main Menu (ctrl + M) If not, you can remove it with some custom css (I don't know where the relevant files are located on OS X, so just adjust the paths for your installation).

    1. Windows: Open directory %localappdata%\Vivaldi\Application\1.0.249.12\resources\vivaldi\style
      –- Linux: Open directory /opt/vivaldi-snapshot/resources/vivaldi/style/
    2. Open "common.css"
    3. At the very top of the file, add:```
      @import "custom.css";
    5) Paste this code into the file:
    
    

    .topmenu {
    display: none !important;
    }

    Vivaldi will need to be restarted after changes are made to these files.


  • @Tiamarth:

    Can you toggle the horizontal menu? View > Horizontal Main Menu (ctrl + M) . . .

    Argh! Thanks! I've successfully turned it off! I didn't even know that there is such an option.

    But, that is strange, because the proper main menu at the top of the Mac screen doesn't include the switch; only the spurious menu which I've just turned off seems to include the "View > Horizontal Main Menu" item. So, I can no longer turn it back on. (Not that I want to.)

    So, my conjecture is: the Vivaldi snapshot was released with the spurious menu accidentally turned on, because otherwise it wouldn't have ever been turned on (unless I actively looked for the hidden option to switch it on).

    Edit: Either that, or I had accidentally hit some shortcut keys that enable the menubar.

    Cheers,

    Ryo


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.