How do I enable Adobe Flash?



  • How do I enable Adobe Flash? I have Adobe Flash Player already installed. I already use it in Firefox. I looked for it in vivaldi://plugins but couldn't find Flash. How do I enable and use it? Thanks



  • Did you take already a look into this thread? The Flash version apparently was the decisive question.



  • ^^^^^^ What RJules said.

    Vivaldi is built on Chromium, so it uses the same kind of Flash. Firefox and Chrome(ium) use different versions of Flash. Chromium uses PPAPI or Pepper Flash, and Adobe discontinued development of any other kind of Flash for Linux. You can download Flash here.

    Or, if the correct package type for your distro isn't listed there, try looking into installing the package pepperflashplugin-nonfree from the terminal.

    Assuming you're on a Debian-based distro (most likely one of the many Ubuntu children), just open the terminal and type```
    $ sudo apt-get install pepperflashplugin-nonfree

    **Edit:** Oh, and don't forget to restart Vivaldi after installing Flash.


  • That worked– thanks for your help! I needed your command line install since I couldn't use the Adobe Download (doesn't work on Ubuntu 14.04 for some reason) and I don't know how to open tar.gz files yet... so thanks for your help!



  • You're welcome :)



  • I tried this and facebook still doesn't recognize it :(



  • @ktaherig:

    … facebook still doesn't recognize it ...

    According to this post a system restart was helpful.



  • I'm using Ubuntu Mate 16.04 and Vivaldi 1.0.435.42 (64-bit). I have Google Chrome 51.0.2700.0 dev (64-bit) installed as well as pepperflashplugin-nonfree installed. Vivaldi just won't see flash for me. Is it because I have both Google Chrome and pepperflash-nonfree installed?

    I have pepperflashplugin-nonfree and browser-plugin-freshplayer-pepperflash installed so that I can use pepper flash in Firefox; which does work by the way. And pepperflash is working in Opera 36.0.2130.46 also.

    I tried uninstalling the snapshot version of Vivaldi and deleting the config folder in ~/user/.config/ and restarting Vivaldi and that didn't help.

    The only plugins that Vivaldi can see on my computer are Chromium PDF Viewer and Widevine Content Decryption Module.

    Any ideas for what I should try to get this working? As much as I hate flash, I need it for when I help homeschool my nephew on this pc. His online classes use flash quite a bit. Opera, Firefox, and Google Chrome work okay, but I prefer Vivaldi.



  • @Tiamarth:

    ^^^^^^ What RJules said.

    Vivaldi is built on Chromium, so it uses the same kind of Flash. Firefox and Chrome(ium) use different versions of Flash. Chromium uses PPAPI or Pepper Flash, and Adobe discontinued development of any other kind of Flash for Linux. You can download Flash here.

    Or, if the correct package type for your distro isn't listed there, try looking into installing the package pepperflashplugin-nonfree from the terminal.

    Assuming you're on a Debian-based distro (most likely one of the many Ubuntu children), just open the terminal and type```
    $ sudo apt-get install pepperflashplugin-nonfree

    **Edit:** Oh, and don't forget to restart Vivaldi after installing Flash.
    

    When I enter the adobe flash download page, it only shows Chrome 64 bit option. I installed the RPM version (because I use Fedora instead of Ubuntu) that installation made flash work on Firefox, but does not work on Vivaldi. When you select Windows or Mac, you can select the PAPPI version of flash but that's not an option for Linux Download.

    Now your installation command works only on Debian based distributions, do you know by chance the Red Hat based equivalent? I haven't found any at the moment.

    On fedora I used to follow this Gist which made it to work on beta and snapshots Enable h264 in Vivaldi for Linux but this seems to be enabled by default on the stable release since there's a libffmpeg.so included on Vivaldi installation, but on a different location though (snapshots it was located at /opt/vivaldi-snapshot/libffmpeg.so, now it's located under /opt/vivaldi/lib/libffmpeg.so)



  • Seriusly people is just a single file (libpepflashplayer.so) that has to be copied in a single place.

    No matter how you get it, no matter what distro are you using.

    If your distro doesn't provide a prepackaged version, just downolad a suitable x86 or x86_64 (depending on your linux flavour), unpack it and copy or link it inside**
    /usr/lib/chromium-browser/plugins/**

    or
    /usr/lib32/chromium-browser/plugins/
    or

    /usr/lib64/chromium-browser/plugins/ (depending on your linux flavour), and restart Vivaldi.


  • Moderator

    Where resides your libpepflashplayer.so?

    Vivaldi's start script uses these paths to file:
    "/opt/google/chrome/PepperFlash/libpepflashplayer.so" # google
    "/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so" # debian/ubuntu
    "/usr/lib/PepperFlash/libpepflashplayer.so" # arch/slack
    "/usr/lib/chromium/PepperFlash/libpepflashplayer.so" # openSuse 32-bit
    "/usr/lib64/chromium/PepperFlash/libpepflashplayer.so" # openSuse 64-bit
    "/usr/lib/pepflashplugin-installer/libpepflashplayer.so" # ppa:skunk/pepper-flash
    "/usr/lib/chromium-browser/PepperFlash/libpepflashplayer.so" # rosa/mandriva 32-bit
    "/usr/lib64/chromium-browser/PepperFlash/libpepflashplayer.so" # rosa/mandriva 64-bit


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.