Panel Toggling



  • I have only used Vivaldi in 32 bit Linux(Mint) Ive noticed when I check the box in settings to show toggle panel(Under Panel Settings) it takes a second for the browser to readjust. Not sure if its only linux but wanted you to be aware of it. I have a feeling it might not be exactly how you would like it tpo be either. other than that Ive been having fun playing around with this browser.... KUDOS!



  • Hi there, welcome to the forums.

    I am also on Linux Mint, but I'm using the 64-bit version of Vivaldi. Is this what you're talking about? (That's a dropbox link that points to a preview of a gif I captured of what I think you're describing.)

    Also, it looks like Vivaldi can't load gifs? Or at least not this one? If it doesn't load for you, try viewing it in a different browser if you can.

    Edit: Vivaldi forums doesn't support gifs, so added a link to the attachment hosted elsewhere.
    Attachments:



  • @CoolBreeze:

    … when I check the box in settings to show toggle panel(Under Panel Settings) it takes a second for the browser to readjust. ...

    On Debian 'Jessie' with XFCE desktop environment and Vivaldi 1.0.249.12 (Entwickler-Build) (64-Bit) I tried to reproduce this but I don't see any difference to the behaviour on Windows 10. The response of the window is immediately without any noticeable delay. Now I tried it with Mint 17.1 Cinnamon desktop environment and it's also the same like on Debian or Windows.
    From my point of view it's not a Linux issue.



  • Youre half way there. Close out of the settings window and on the left side of the browser screen, click the bar that opens and closes the panel. you will know it when you see it



  • So this? If so, I don't know if that's really something Vivaldi will ever be able to work around. The website contents are just shifting out of the way so that the browser can display the UI element you called by clicking on the toggle.

    On the other hand, I've just tried to toggle some menu bars in Opera 12.16, Firefox, and Maxthon. In Opera 12, the website snaps instantly with the interface, and in Firefox and Maxthon there's a smooth transition. It's interesting how I've literally never given this any thought before. Now that you've pointed it out and I've seen it, it's just a tad annoying.

    Edit: I have an idea that might provide an easy workaround to this. Will edit this post again if it works.

    Edit2:* Well, it's still not perfect, but it's got a much smoother transition to it now.

    To do what I've done:

    1. Open directory /opt/vivaldi-snapshot/resources/vivaldi/style/
    2. Open "common.css"
    3. At the very top of the file, add:```
      @import "custom.css";
    5) Paste this code into the file:
    
    

    #panels-container {
    -webkit-transition: all 0.2s linear !important;
    }

    6) Open directory /opt/vivaldi-snapshot/resources/vivaldi/user_files
    7) Create and open a new file, name it Smooth_Toggle.css
    8| Paste this code into the file:
    
    

    html {
    -webkit-transition: all 0.5s linear !important;
    }

    Vivaldi will need to be restarted after changes are made to these files.
    You can adjust the delays to your liking, but more than 1s is too long for me, personally.

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.