Crunchyroll's video player not working



  • Hello can anyone please help me to fix this problem?
    Whenever i try playing the episode this happens for a second http://prntscr.com/p533o5 and then i get this error http://prntscr.com/p534wf
    So the only way to play the video for me is to pause it immediately then skip to anywhere on the video then start it from the beginning again that way i don't get that weird issue.
    Also i don't get that error if i use hardware acceleration, but then the video either has tearing or stutters a bit.
    I tried other browsers, they all work without any issue.


  • Moderator

    Welcome to our Forum. 🙂

    Here are a few links for your bookmarks that you may find useful:

    Do not hesitate to ask, we are a community to help users.

    Enjoy browsing.


  • Moderator

    @Megumin97 ⁉ Sorry, we can not use a Magic Crystal Ball 🔮 to get more knowledge on your issue. ⁉

    ℹ More Information on your issue may help us:

    1. What is your Mac/Linux/Windows version and build?
    2. What is your Vivaldi version? (via Vivaldi menu
      Help → About and first line)
    3. Which CPU and RAM do you have?
    4. Which GPU and graphics hardware do you have?
      Are the drivers from chipset/card manufacturer up-to-date?
    5. Which is the output of vivaldi://gpu – any red or orange warnings?
      Copy the red and orange and paste here.
    6. Which audio output devices or special audio hardware do you use (f.ex. 5.1 surround or others)?
    7. Which extensions do you have installed? (via page chrome://system, row extensions and button Show...)
    8. Which security software do you have running (Firewall, antivirus, malwarekiller, etc)
    9. Which URL causes this issue?


  • @Gwen-Dragon

    1. Windows 10 Pro 18362.356
    2. 2.7.1628.33 (Stable channel) (64-bit)
    3. I9-9900k, Corsair VENGEANCE LPX 4x16GB RAM
    4. GTX 1080ti SLI

    Metal: Disabled
    Out-of-process Rasterization: Disabled
    Hardware Protected Video Decode: Disabled
    Skia Renderer: Disabled
    Surface Control: Disabled
    Viz Hit-test Surface Layer: Disabled
    Metal is only available on macOS.
    Disabled Features: metal
    Viz hit-test surface layer version is not enabled by default.
    Disabled Features: viz_hit_test_surface_layer
    Skia renderer is not used by default.
    Disabled Features: skia_renderer
    6. Samsung tv and Focusrite scarlett 2i2, i don't use any surround.
    7. I disable all of the extensions the problem was still there
    8. Bitdefender total security
    9. most of the Crunchyroll videos



  • Try this test page and see if you can play the videos: https://tekeye.uk/html/html5-video-test-page

    Another test page: https://www.w3.org/2010/05/video/mediaevents.html

    Also check this page under the Video section:
    https://html5test.com/

    For me the result is:

    Video
    29/33
    video element
    Yes ✔
    Subtitles
    Yes ✔
    Audio track selection
    No ✘
    Video track selection
    No ✘
    Poster images
    Yes ✔
    Codec detection
    Yes ✔
    Video codecs
    MPEG-4 ASP support
    No ✘
    H.264 support
    Yes ✔
    H.265 support
    No ✘
    Ogg Theora support
    Yes ✔
    WebM with VP8 support
    Yes ✔
    WebM with VP9 support
    Yes ✔
    

  • Moderator

    @Megumin97 Did you installe latest NVidia driver from NVidia web page?

    I guess some videos need Hardware Acceleration.
    Is in Vivaldi Settings → Webpages the 'USe of Hardware of Acceleration' activated?

    If all is yes, pleas give us a URL of video which does not play.

    And try this override:

    • Open internal setting page
      chrome://flags/#ignore-gpu-blacklist
    • Set to Enabled
    • Restart Vivaldi


  • @Gwen-Dragon Thanks a lot, this fixed it. Turning Override software rendering list to Enable and Use of Hardware of Acceleration on.
    Turning Override software rendering list to Enable fixed the tearing and stuttering when using Hardware Acceleration.
    Thanks a lot again.



  • @Gwen-Dragon Damn it i spoke to soon youtube only doesn't stutter if its in fullscreen, but this did fixed the issue of tearing on Crunchyroll when using Hardware Acceleration



  • Well after some closer inspection i noticed that the tearing is still there while using hardware acceleration.



  • @Pathduck I didn't use hardware acceleration while doing test, but everything works fine.

    https://html5test.com/
    Results:

    Video
    29/33
    video element
    Yes ✔
    Subtitles
    Yes ✔
    Audio track selection
    No ✘
    Video track selection
    No ✘
    Poster images
    Yes ✔
    Codec detection
    Yes ✔
    Video codecs
    MPEG-4 ASP support
    No ✘
    H.264 support
    Yes ✔
    H.265 support
    No ✘
    Ogg Theora support
    Yes ✔
    WebM with VP8 support
    Yes ✔
    WebM with VP9 support
    Yes ✔


  • Moderator

    @Megumin97 Yes, sometimes in Chromium builds some GPU's features are considered as unstable and are disabled. A GPU blacklist override can solve this.

    Fine. All works now.
    Now enjoy browsing 🙂


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.