Sync Issues

  • I'm having a little trouble getting sync to work for me. The behavior has been a little confusing, so stick with me while I describe what's happened so far.

    My phone is a Samsung Galaxy S9+ running Android version 9, kernel 4.9.112, security patch level August 1, 2019.

    When I first installed Vivaldi and went to the sync settings I was able to login successfully, and then it asked for the encryption password. I entered the password, and then after a brief moment green checkmarks appeared next to both upload & download and they reported success. However, none of my bookmarks or notes from my desktop browser are available.

    I noticed in another thread someone mentioned that it takes some time to download all the data, and that is understandable especially considering the size of my bookmark library. Before reading that, I had tried turning off the passwords & autofill options for sync, and again after a brief moment both up & download had green checkmarks and reported success.

    If it really is that it is still downloading, and it doesn't display any bookmarks or notes until the download is complete, then the sync settings page shouldn't report download success with a green checkmark; there should be some indication that the download is ongoing.

    After about 1.5-2 hours, I went into the sync settings again, I logged out and back in. Upon providing my encryption password I was getting an error stating "Download: Server refused your credentials, Upload: Not Synced". I came to the forum to look and see if anyone else was having syncing issues, and after a few minutes went back to my settings page and both upload and download were back to green checkmarks & reporting success.

    So this is the current state of my browser. I am logged in, encryption password provided, both upload and download are reporting success with green checks, but I have none of my bookmarks or notes from my desktop. My bookmarks library is quite large, but the file is only ~50MB and I'm connected to Wi-Fi over a very fast cable ISP. The data should have had enough time to download at this point.

    One possibility might be that since the mobile app is brand new, there are so many people installing and syncing that the servers are a bit overloaded right now. Is there anyone that can confirm or deny this to be the case?

    If that isn't the problem, does anyone have any ideas of how to resolve the issue or what to investigate to diagnose it further?


    ↬ BoneTone

  • Community Manager

    @bonetone thanks for reaching out and sorry for the trouble. Would you please file a bug report so that the developers can look into it asap?
    Please submit a bug report with the following info:

    • username of the account you tried to sync,
    • error message shown (if any),
    • a screenshot of vivaldi://sync-internals and the Sync settings page on vivaldi://settings/sync/ can help or
      click on Dump Status on vivaldi://sync-internals and send us the content that appears in a small box below the button,
    • time when it happened,
    • detailed steps to reproduce the issue.

    Please share the VB number you receive via email here so we can quickly follow it up internally.

    Thanks in advance for your help 🙏

  • Thank you gaelle,

    The data eventually synchronized and all is working well now. But I will file a bug about the inaccurate/incorrect "success" status. Perhaps the logs can shed some light on what was happening. Taking 3-4 hours seems a excessive to download my data. At most it was half a gig, maybe there is a ton of processing that needed to be done before it was displayed, or server issues, perhaps we'll see in the dump. Thanks for the guidance.

    I'll hold off on filing a bug about the "server refused your credentials" as I cannot reproduce it at this time. It is a weird issue though, in that I didn't relog in, I just went back to the settings ~20 minutes later and it had logged in.

  • I'm just gonna leave this here.

    I'm not able to see tabs from desktop snapshot on mobile, but it works the other way around, mobile tabs appear on desktop. Tried logging in and out of sync occasionally over the last few days, but no luck so far.

  • @luetage said in Sync Issues:

    I'm just gonna leave this here.

    I'm not able to see tabs from desktop snapshot on mobile, but it works the other way around, mobile tabs appear on desktop. Tried logging in and out of sync occasionally over the last few days, but no luck so far.

    So, I think there is an issue with sync at the moment... From the desktop (I'm running stable, not snapshot), I saw the 85 tabs I had open on mobile, a couple days ago. Now, and for the past several hours, I have noticed the same thing as you. Desktop is not receiving the full list of tabs from mobile when clicking the cloud icon. I see 8 tabs there, yet I've currently got 83 tabs open. On mobile, I clicked the cloud icon, I saw the tabs I had open ~2 minutes ago and literally watched as it updated to current.

    So yeah, Android is able to view the tabs that desktop is sync'ing to the cloud, while desktop is seeing some stale, partial, incorrect list of tabs that are open on Android. Whether the error is in Android sync'ing to the cloud, desktop sync'ing tabs from the cloud, or the servers are just having problems, I don't know. But, a few days ago, things were working well for me.

    Note, I am seeing a few other sync related issues: some notes are desktop are duplicating themselves repeatedly, some bookmarks on desktop duplicated one time but not since I deduped that, and (perhaps not sync related) Android is not creating notes when I click "copy to note" on highlighted text. I'm trying to diagnose these issues a bit further before filing any bugs.

  • So yeah, it seems that there was an issue with sync. None of those old tabs would show up on the desktop. But, all new tabs are. After having closed all those old tabs now all my mobile tabs are displayed on the desktop.

    @luetage so, take a look and see if new tabs are appearing... it may be that the old ones are ust being missed for some reason, but once you close them out your devices will once again all be in sync.

  • @bonetone said in Sync Issues:

    I have noticed the same thing as you. Desktop is not receiving the full list of tabs from mobile when clicking the cloud icon

    I never said that. My problem is I can't see desktop tabs on mobile. Anyway, might still be the same issue. Clearing tabs however or restarting sync won't do anything.

  • @luetage ah, yeah, sorry, a little bit of dyslexia got me there... that sucks though. Is the desktop uploading? Make sure the timestamp in the Sync settings is recent enough to have picked up the tabs, then make sure the mobile syncs to pick it up. Your mobile has picked up your notes & bookmarks? If you've got a large set user profile, it can take hours for that to happen, at least initially.

    I think with the release of the Android app, a lot of people are syncing their entire profile the past week and the servers just have never handled this kind of load before. So the datacenter folks are trying to deal with the spike in traffic and make sure they are able to hand this better going forward... at least that's one reasonable guess.

  • @gaelle

    Since I had to reinstall Vivaldi Android, I was able to reproduce this issue and have filed a bug: VB-57971

    Unlike the first time I installed Vivaldi Android however, now my data will never download to the phone. Even though it will sometimes report success, and sometimes display one of the two errors described in the bug, I'm stuck with a browser that isn't ever in sync - no bookmarks, no history, no notes, no tabs.

    My data is quite large, the bookmarks library is so big that whenever I change the folder of a bookmark it takes 10 seconds or so before the UI responds to list my folders. Chrome behaves exactly the same, so this isn't unique to Vivaldi, just a result of the size of my bookmark library. Perhaps I can work with the Chromium team to optimize that at some point, but I need to resolve this sync issue before I try to find the time for that.

    I figure this problem may be related to the amount of data that needs to sync - my History file on the desktop is even larger than the Bookmarks file (at least last time I checked, but I've been updating the thumbnails of my bookmarks lately). Both are well over 50 MB. Still, over my internet connection, even a few hundred MB shouldn't take that long.

    Please email me at the address included in the bug report if y'all need any more information or would like me to do anything to try to fix the sync.


    PS - The reinstall was unrelated to this issue, I was playing around with a bunch of flags and got the browser into a state that caused it to crash whenever I launched it. So I uninstalled & did a fresh install from the Play Store twice, and haven't been able to sync since the first install. I didn't file a bug for that because I'm sure whatever I did is unsupported.

    @luetage I'm not sure your problem is the same as mine, but were you able to resolve it?

  • Community Manager

    @luetage sorry for the trouble and thanks for reaching out.
    Have you reported it on already? if so what's the VB-number please? 🙂

  • Community Manager

    @bonetone thanks for reporting in such great detail your issue. I'm passing it on internally so they can look into it. Regarding sharing files, in the future simply reply to the automatic email you receive after submitting your issue. They'll get attached to the issue. 🙂

  • @gaelle Sure, yeah, I did that before receiving the email and seeing the note about attachments. I can still do that if y'all would prefer it. It was just during filing when I got to the bottom of the page and saw no button for uploading a file that I pulled up Solid Explorer and FTP'd it to the website. If you want me to go ahead and send the files attached to an email reply still I will do so, but if someone has already downloaded the files and attached them to the ticket in the bug tracker then I'll just make sure to do it correctly in the future.

    I know that I kind of put all the information into one field, and then duplicated it in the others once I realized they existed... I didn't scroll down to see the entire page before writing it up and was doing it on my phone so I just let it go as is. Next time I'll put the relevant info into each field separately. I used to be a software QA Manager in a previous career, so I was just quickly writing up everything that I would normally expect in a bug report into the text field not realizing the site had separate fields for things like steps, results, expected. I keep a text file on my phone with a bug framework that is pretty much a mirror of that page: Title, Problem, Repro Steps, Results, Expected, Notes. So I can just cut & paste into the various fields in the future.

  • @gaelle I installed the snapshot and it works there, have uninstalled beta and can't tell. The only sync issue remaining is the one concerning notes, which should have been resolved with the last 2 updates to snapshot desktop and mobile, but which didn't fix it for me. Waiting for another round of updates.

  • @luetage I got same situation as You
    It works on Snapshot but not on Beta...

  • @gaelle I wanted to give y'all an update. I upgraded to the new build of Android Vivaldi released today (219) but still having issues with sync. Currently my settings are that I only have Bookmarks set to sync on Android, all the other sync options are disabled. It is displaying green checks next to both upload & download with a timestamp of about 2 hours ago. When I first upgraded after about 2 hours I checked and it was reporting the same Network error described in the bug, and the retry timer ran past 0 into the negative. After a little bit of watching the timer continue to go negative without apparently retrying, I changed the settings from Synchronize All to just syncing the bookmarks and applied the new settings.

    As long as no error is displayed when I check, I'm going to let it be for at least another 2 hours. I think that they're are at least 2 issues underlying this bug. There are the errors of course, but also displaying success when the data hasn't actually been downloaded and applied. As mentioned in the report, the app reported success nearly immediately, but only about 4 hours later did my bookmarks and other content become available in the app.

    Hopefully that's what is happening right now: incorrectly showing success while still processing and Vivaldi Android will eventually complete the sync. If I get the time, I'll try sniffing the network to look for the sync traffic, but I can't promise I'll get to that today.

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.