Deleting all passwords doesn't work



  • When I use Tools -> Delete Browsing Data and select "Passwords" with "All Time", the passwords are still present under "Privacy" in Settings. Even after restarting Vivaldi, the passwords are still present.



  • As a workaround, you can hold down "Enter" with the mouse cursor over the first password's "X" until all the passwords are removed.


  • Moderator

    @keeganwitt I tested on 2.6.1566.49 on Windows 10 x64 and can not reproduce your issue.
    If i delete the passwords by Clear Browser Data and select All Time they are all gone.
    I checked in Vivaldi Settings → Privacy and on internal page chrome://settings/passwords .

    Do you use a extension to manage passwords?
    Have you imported any passwords from other browsers or from a file?



  • My version is 2.7.1609.4 64 bit, also Windows 10. The passwords were originally imported from another browser, yes. But I don't have any password-related extensions, though I do have some other extensions installed.
    Since this was a snapshot version, is there somewhere else I should have reported this?

    It works when I have just 1 password saved, but fails when I import passwords from Chrome then try to remove all. I don't think it's a matter of how many passwords are saved. When deleted all but 1 password that was imported, the remove all didn't remove the one remaining password. It seems to be some kind of issue related to import.



  • Ah, I just noticed when I did the delete all, it deleted the 1 password I saved directly in Vivaldi, but didn't delete the 1 remaining password that was imported. It appears this never deletes imported passwords.


  • Moderator

    @keeganwitt said in Deleting all passwords doesn't work:

    The passwords were originally imported from another browser

    Ah. Then report this issue as a bug! And describe from where and how you imported the passwords.


    Please read how to Report a bug for Vivaldi carefully and then report the bug to Vivaldi bugtracker.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.