Netflix not working - Possible Fix Windows 10, but wierd - just weird

  • I've had the dreaded WOOPS! on Netflix for a couple days. My version of WidevineCdm is up to date (Version 4.10.1146.0 - installed and enabled in settings and in use -watching Netflix as I type after doing the below steps). Tried user agent switcher and that didn't work.

    What did work.

    Uninstall user agent switcher
    close Vivaldi
    navigate here: C:\Users\yourusername\AppData\Local\Vivaldi\User Data\WidevineCdm
    rename whatever folder is in there to originalname_old.

    example - folder name is "4.10.1196.0" rename to "4.10.1196.0_old" - this is the folder I had

    re-open Vivladi and go to vivaldi://components

    scroll to bottom and view "Widevine Content Decryption Module - Version:"

    use the "check for update" button and the most recent version SHOULD be downloaded and used (here is the weird)

    When I did the above steps it reported that version 4.10.1196.0 had been downloaded and status changed to updated

    I opened new tab and started streaming Netflix with no issues (its still streaming just fine as I type).

    The weird is I went back to close the windows explorer window that had the WidevineCdm directory open and saw 3 folders. one was the one I had renamed (the original one which I renamed to 4.10.1196.0_old). One was another folder named 4.10.1196.0, which I assumed was the most updated version that I had re-downloaded by the check update button. And the last one is a mystery. I have no cue where it came from. It is named 4.10.1146.0.

    I tried deleting it because I thought who needs an old version that's not in use? It is in use when I try to delete it. So I tried deleting the other 2 and had no issues. So even though the reported version of WideVineCdm in vivaldi://components is 4.10.1196.0, it seems vivaldi IS using the older version for netflix.

    I closed Netflix and Vivaldi to test this theory and had no issues detling the older version folder once vivaldi was closed.

    Of course I restored all the folders from my recycle bin and netflix is still streaming fine using the older version of WidevineCdn.

    Is what it si but weird.

  • Moderator

    I saw three versions of Widevine were downloaded.
    4.10.1146.0 4.10.1196.0] 4.10.1440.18
    And in components page it shows now 4.10.1440.18

    But i can not test Netflix if DRM works.

    @yodamin I added your post to my bug report

  • Moderator

    I can confirm that Vivaldi Stable and Snapshot loads the 4.10.1440.18 😞

    My related bug report VB-54716 "Widevine DRM not active after install on a fresh system"

  • Moderator

    The issue with the 3 versions of Widevine was confirmed by a Vivaldi developer. 🙂

  • Hi,

    After more experimentation I realized there were 3 versions involved.

    The only one that works for me is 4.10.1146.0

    for now I've removed modify/write permission from the wide-vine directory and when it messes up I click the Quick Access link I've made for the wide-vine directory, delete the updated version(s -4.10.1196.0 or 4.10.1440.18) , leaving the 4.10.1146.0 in place, then re-open vivladi and it works-sometimes i have to click update once more in components but either/or gets it working again.

    It's a pita but at least I have a work around for it until a permanent fix comes out.

    In Linux I am currently frustrated by the fact that Chrome/Chromium and Vivaldi opened side by side and only the first two will successfully play Netflix -Vivaldi is elusively refusing to do it. Sigh. I've tried with Ubuntu, Xubuntu, Kubuntu,Linux Mint and Manjaro so far and it is the same in all Linux's - leaving me to deduce this is with Vivaldi on Linux in general. It seems to be much more buggy/less stable on Linux overall -with graphical glitches and hangs being way more common. Not judging here, just stating my own admittedly limited experience. I actually love Vivaldi and want to see it improve more and do well on both OS's.

    I have also noticed a lot of sound issues with tab muting/hibernating when "suspending/while suspended/unsuspending" - when refocusing a hibernated tab there is no sound -frustrating if you have multiple tabs open in youtube or some such media website. If I copy the URL and open new tab and paste/go sound works just fine. video works throughout the whole thing. Something for another day.



  • A temporary option to NOT updated wide-vine when restarting the browser would be a temporary solution for others. If they get a version that works for them they can always enable the DO NOT UPDATE WIDE-VINE option?

    As I type this I look in the widevine directory that I have open on another monitor and realize there is now 2 folders in the directory. The 4.10.1146.0 one that works and has all modify/write permission disabled and the 4.10.1196.0 one that Vivaldi updates to automatically - the one that doesn't work. So when I close the browser now it will attempt to remove the 4.10.1146.0 directory but won't be able to, even if I delete the 4.10.1196.0 directory before closing or reopening Vivaldi it will still attempt to use the 4.10.1196.0 version (and fail of curse) until I click the update button once more in components (thank goodness for bookmark bars:-) and it updates "back" to 4.10.1146.0 - by the tie I close the browser I'll have to go through the motions again every-time i want to watch Netflix.

    I can see how this would frustrate non-=technical users and even a lot of technical ones.

  • My first post was confusing as I mixed up the working versions ( I was tired, as I am now) the only version that ever worked for me is the 4.10.1146.0 version.

    The other two appear when Vivaldi updates to them but they do not work.

    Oddly enough, I deleted the 4.10.1196.0 version folder mentioned in my last post and closed/reopened Vivaldi and Netflix just worked with the 4.10.1146.0 still being reported in components. Previous attempts at this have revealed and update wide-vine version after rebooting Vivaldi - it updates to version 4.10.1196.0 after rebooting , only this time it didn't update at all but remains at 4.10.1146.0, which is good from my perspective.

    I will test over the next few days and see if Vivaldi updates to a non-working version once more.

  • Nope - it updates shortly after re-opening - there is now 2x version folders in the directory once more.

    I will delete the 4.10.1196.0 because it cannot work and if I do this before closing and reopening Vivaldi Netflix will work with no further fuss, but I have to remember to do this before closing Vivaldi every time or I will need to delete the 4.10.1196.0 folder, open Vivaldi and click the update wide vine button to get 4.10.1146.0 - or at least this is whats happening so far.

    I can probably fix this for me by simply finding whatever file(s) is writing the updated version to the directory and taking away it's permissions to write - thereby causing the update to fail...I wonder if Vivaldi will just keep using the existing widevine version if an update fails or if it will react badly.

    Something for another day:-)

    Cheers all and Good night!

  • Does anyone know how Vivaldi updates it's components?

    I mean I have all notifications off and I know that if I check the file menu->help I can then click check for updates and I do that once in a while.

    However, I have NOT seen a way to turn off updating components completely. For example the widevinecmd issue I am having..why is Vivaldi trying to update this constantly? I do not see a way to turn it off at all? I've looked in all the directories I can find and do not see a clearly named UPDATE file... if I could figure out whats updating widevinecmd in other words I could block it in some way and maybe that would keep my version of widevinecmd to a version that actually works for me instead of all this messing around.

    So, once again - where are the updates coming from, I can rename files to old, change security permissions to prevent a file from executing and/or block urls / IP's in my firewall.

    However, without knowing what to block it's kinda useless. Anyone?

  • Removing write/modify access of the logged on user to the widevinecdm has seemed to stop the update of 4.10.1146.0 to any higher non-working version. I've had the browser open for over 2 hours playing Netflix and it usually updates by now to a higher version but has not done so since the permissions changes.

    In case anyone cares to follow suit.

    Not sure how this is going to affect overall functionality, however, since I've noticed nothing out of the ordinary and I've only change permissions on the wide-vine directory and not the whole profile directory I think I'm good.

  • This post is deleted!

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.