Win7/64: Vivaldi friert sofort nach dem Start ein



  • Hallo Leute, nach dem Wechsel von TP3 auf TP4 habe ich ein ernstes Problem mit Vivaldi: Das Programm startet, friert aber innerhalb der nächsten Sekunden ein. Zunächst läuft der Fortschrittsbalken im Adressfeld an, wird aber immer langsamer bis er ganz steht. Danach geht nichts mehr. Eine Seite wird nicht geladen, es erscheint nichts. Anschließend reagiert gar nichts mehr. Selbst das Fenster kann ich nicht mehr schließen. Ich kann versuchen, seine Größe zu ändern, dabei wird der Cursor zum Doppelpfeil, etliche Sekunden geht gar nichts und dann endlich meldet Windows, dass das Programm nicht mehr reagiert und über diesen Dialog läßt es sich dann beenden. Wenn ich den Seiten-Ladevorgang schnell genug abbreche, kann ich mit Klick auf "v" gerade noch das Menü öffnen. Aber schon nach dem Aufruf von "Einstellungen" friert das Programm bereits wieder komplett ein. Was ich schon erfolglos ausprobiert habe: - Umbennen des kompletten User Data-Ordners, um das Profil zu löschen - Deinstallation und Neuinstallation - Deinstallation und Neuinstallation der 32-Bit-Version - Deinstallation und komplette Entfernung aller Registry-Einträge, in denen irgendwas mit "Vivaldi" auftritt - Deinstallation und Installation der alten, früher lauffähigen Version. Dabei kommt unmittelbar nach dem Start der Hinweis auf das neue TP4. Klicke ich auf "Später erinnern", schließt sich das Fenster und Vivaldi friert wie gehabt ein. Klicke ich aber auf den Download für das Update, wird das erfolgreich heruntergeladen und durchgeführt. DasTP4 startet - und friert ein. - Installation des aktuellen Build 1.0.231.3. Das entfernt die TPs im Installationsverzeichnis und friert ein. - Nach der mühsamen Reinigung der Registry habe ich alle Installationen nur noch als Standallone Installationen durchgeführt, aber auch das hat nicht geholfen. Jetzt bin ich mit meinem Latein am Ende. Was kann ich denn wohl noch versuchen, um Vivaldi auf diesem Rechner (Windows 7, 64 Bit, Home Premium) wieder ans Laufen zu bekommen. Er lief nämlich für Wochen super und ich hatte mich schon fast von meinem alten Opera 12 verabschiedet. Zum Glück noch nicht! Hat jemand eine Idee? Vielen Dank, Michael



  • Seltsame Effekte. Hatte ich auf Win 7x64 Ultimate nie.

    Kann sein:
    1. Grafikkarte (alte Treiber, defektes RAM, Hardwarebeschleunigung, andere Defekte)
    2. Defektes/zu wenig RAM
    3. Festplattenfehler
    4. Virenscanner blockiert
    5. Temporäres Verzeichnis voll
    6. Browser-Erweiterungen, die hängen



  • Hi Gwen-Dragon,
    ja, wirklich merkwürdig. Zu Deinen Vermutungen:
    1. Grafikkarte (alte Treiber, defektes RAM, Hardwarebeschleunigung, andere Defekte)
    Ist auszuschließen, alles ziemlich neu, die anderen Applikationen laufen gut.
    2. Defektes/zu wenig RAM
    Reichlich vorhanden und ok
    3. Festplattenfehler
    Habe ich mal geprüft. Nichts gefunden. Ich habe das System auf einer SSD (C:), alle Programme auf einer normalen HD (D:). Ist zunächst ja auch gut gelaufen.
    4. Virenscanner blockiert
    Da ist nur Microsoft Security Essentials aktiv. Ich hab's mal abgestellt und gestartet. Kein Effekt :-(
    5. Temporäres Verzeichnis voll
    Is nich…
    6. Browser-Erweiterungen, die hängen
    Ja möglich, aber welche. Und wenn ja, wie werde ich die los? Vivaldi fährt nicht hoch und ich hatte es ja komplett deinstalliert. Bleiben die Erweiterungen dabei bestehen?

    Hier noch ein paar weitere Beobachtungen:

    1. Während Vivaldi einfriert, steigt die Systemauslastung NICHT an.
    2. Zurzeit erscheint nicht mal mehr das Fenster, aber sehr wohl noch der Button in der Taskleiste. Gehe ich mit der Maus da drauf, zeigt Windows sogar noch die Vorschau für das Vivaldi-Fenster. Ich kann es aber nicht maximieren. Klicke ich drauf 'rum, ändert sich die Vorschau in "Vivaldi" (Keine Rückmeldung). Warte ich eine Weile und schaue mir dann wieder die Vorschau an, ist die Miniatur der Startseite wieder zu sehen.
    3. Ein Rechtsklick auf den Button in der Taskleiste listet wie erwartet die Einträge "Speed Dials", "Meistbesucht" etc. auf. Anklicken z.B. auf Speed Dial "Google" öffnet aber nicht das fenster. Stattdessen ändert sich nach einer Weile die Vorschau-Miniatur, und darin ist die Google-Seite zu sehen!
      Ich kann Vivaldi also nur noch im Taskbar-Vorschaufenster als Browser benutzen ;-)
    4. Im Vivaldi-Verzeichnis gibt es eine Datei "debug.log". Darin steht zweimal der Eintrag "[0724/012921:ERROR:client_util.cc(272)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded " - Hääää???

    Irgendwie sieht das gerade nach einem Problem im Zusammenspiel mit dem Windows-Explorer und Vivaldi aus. Auch im Task-Manager hilft ein Klick auf "Wechseln zum Task" bei Vivaldi nicht. Das Programm kommt zurzeit überhaupt nicht mehr zu einem eigenen Fenster. Witzigerweise aber eben schon noch in der Taskbar-Vorschau.
    Sowas habe ich echt noch nie gesehen. :-? Wenn wenigstens eine Neuinstallation helfen würde!



  • Lösche doch mal in den Anwendungsdaten im local Ordner den vivaldi ordner oder kopier den irgendwo in "Sicherheit".
    AFAIK bleibt der beim deinstallieren erhalten. Vivaldi musst du dafür nur schliessen, keine Neuinstallation nötig.

    Ich weiss das das mal wieder die "Vorschlaghammer" Variante ist ;)



  • Hallo RocknRolf,
    das war so ziemlich das erste, was ich ausprobiert habe. Die eigenen Einstellungen bleiben nach der Deinstallation erhalten, was in der Regel sinnvoll ist. Wenn ich den Ordner "wegkopiere", hilft das auch nichts. Es wird ein neuer angelegt und Vivaldi startet mit den Default-Einstellungen. Aber er startet eben nicht - ich sehe das nur in dem kleinen Vorschaufenster in der Taskleiste. Ich bekomme das Programm jetzt schon seit Tagen überhaupt nicht mehr dazu, überhaupt sein Fenster zu öffnen! Irgendwas funktioniert da zwischen Windows und Vivaldi nicht mehr, was sich weder durch Neuinstallation noch durch Entfernen des Benutzerprofils beseitigen lässt.
    Noch eine Beobachtung:
    Schließe ich Vivaldi durch Klick auf das X-Symbol in der Vorschau der Taskleiste, verschwindet zwar der Vivaldi-Programmbutton, aber der Taskmanager zeigt mir, dass noch 'zig vivaldi-Prozesse weiterlaufen, und zwar praktisch im Leerlauf. Unter "Anwendungen" wird er aber nicht mehr aufgeführt.
    Nur zur Info: ich bin ein ziemlich konservativer Windows-Anwender und seehr vorsichtig mit irgendwelchen Installationen. Das benutzte Windows zeigt bisher keinerlei Probleme. Alles andere läuft hier völlig normal.



  • Ok.
    Das einzige was mir dann noch einfällt ist auch nur der Grafiktreiber, "ziemlich neu" ist halt nicht aktuell.
    Gerade konservative User sind da manchmal, ich will nix unterstellen, zurückhaltend (zb ich zocke ja nicht)

    Gruss Rolf



  • Goodbye Vivaldi :-(

    Ich geb's auf. Selbst nach dem Rücksetzen von Windows via Systemwiederherstellungspunkt auf einen Zeitpunkt vor den Problemen mit Vivaldi läßt sich das Programm nicht mehr erfolgreich installieren. Dabei habe ich auch alle drei Installationsarten ausprobiert, zwischenzeitlich jeweils deinstalliert und von Hand alle Vivaldi-Ordner entfernt sowie noch laufende vivaldi-Prozesse gestoppt.

    Trotzdem immer der gleiche Effekt: Nach der Installation bekomme ich noch das Default-Programmfenster zu sehen, darin wird aber schon keine Webseite mehr angezeigt. Lediglich bei der Installation für alle Benutzer (natürlich mit Adminrechten im Standardverzeichnis) erschien im Adress-Eingabefeld noch die Vivaldi-Webadresse und der Lade-Fortschrittsbalken startete. Wurde immer langsamer, blieb stehen und - ebenfalls alles komplett eingefroren.

    Vivaldi ist auf diesem Rechner wohl nicht mehr zu installieren. Da alle anderen Browser problemlos laufen und ich auch sonst keine Merkwürdigkeiten beobachte, liegt der Schluss nahe, dass das Programm igendwo irgendwelche Einstellungen speichert, die nicht mehr einfach zu entdecken und beseitigen sind, die es auch nicht selbst initialisiert, die aber fatal falsch sein können.

    Goodbye Vivaldi, hello (again) Opera 12.16



  • @UserMicha:

    Goodbye Vivaldi :-(
    …, dass das Programm igendwo irgendwelche Einstellungen speichert, die nicht mehr einfach zu entdecken und beseitigen sind, die es auch nicht selbst initialisiert, die aber fatal falsch sein können.

    Goodbye Vivaldi, hello (again) Opera 12.16

    Ich frag mich immer wie man zu so einem Schluss kommt?
    Die mögliche Fehlerquelle Grafiktreiber probierst du also nicht aus?

    RnR

    Ps: Glaubst du nicht das so ein "fatales" Problem mehr User betreffen müsste?



  • Hallo RnR,
    Gegenfrage: was spricht gegen diesen Schluss? Dass ich die Treiber meiner Grafikkarte nicht erneuert habe? Diese Treiber liefen vorher mit Vivaldi, ich habe sie zwischenzeitlich nicht geändert und ein unbemerktes automatisches Update durften sie auch nicht ausführen. Warum sie dann nicht trotzdem einfach mal updaten? Never touch a running system! Meinen PC benutze ich ja nicht nur zum Browsen im Internet. Alle anderen Applikationen laufen, selbst wenn Vivaldi gerade steht. Weiterhin deutet mir der beobachtete Fehler (siehe Beschreibungen; inbesondere dass Vivaldi nicht schlagartig stehen bleiben muss sondern noch ein paar Sekunden immer langsamer laufen kann, bis alles steht) kaum auf die Grafikkarte. Obwohl man sich natürlich immer etwas zusammenreimen könnte.

    Ja, ich glaube auch, dass solch ein fatales Problem auch andere Benutzer treffen kann. Aber es müssen offensichtlich mehrere, einzeln sehr unwahrscheinliche Bedingungen zusammen kommen, wie sie jetzt gerade auf meinem PC herrschen. Das wird selten sein. Und es gibt noch nicht viele Vivaldi-Benutzer.

    Grundsätzlich erwarte (nicht nur) ich von einem Programm, dass es nach einem Update auf einer Maschine, auf der es vorher noch lief, weiterhin funktioniert. Beim Übergang von TP3 auf TP4 hat Vivaldi das bei mir nicht geschafft. Weiterhin erwarte ich, dass nach einer Deinstallation von einem Programm nichts mehr übrig bleibt. Auch das leistet Vivaldi bisher leider noch nicht. Dabei meine ich nicht etwa den Ordner mit den eigenen Einstellungen. Das Profil von Hand löschen zu müssen ist ja ok. Aber bei mir reicht das ja nicht. Und weißt Du, wieviele "vivaldi"-Einträge in der Registry nach(!) der Deinstallation übrig bleiben (und ich bin kein Musiker)? Grauenhaft. Wenn dann selbst die Windows-Systemwiederherstellung nicht mehr hilft, bleibt nur noch der Griff zum Backup-Image der kompletten System-Partition. So einen Eingriff ist mir Vivaldi aber nicht wert.
    Deshalb Goodbye :-(



  • Natürlich verstehe ich Deine Erwartungen an ein Programm. Vielleicht solltest du in Zukunft halt nur finale Versionen eines Produkts installieren.



  • @UserMicha:

    »…« So einen Eingriff ist mir Vivaldi aber nicht wert.
    Deshalb Goodbye :-(

    Auch auf die Gefahr, dass deine Entscheidung schon feststeht - hast Du es mal mit der 32Bit-Version versucht?



  • Ich hatte ähnliche Probleme als ich von TP 3 auf 4 aktualisiert hatte, allerdings konnte ich diese mit einer simplen De- und Neuinstallation wieder beheben.

    Möglicherweise sind nach deiner Deinstallation Daten verblieben, von denen man gar nicht erwartet, dass sie Vivaldi zuzuordnen sind, sondern Chrome…keine Ahnung. Sucht man nach deinem Fehlercode im Netz, dann scheinst du nicht der einzige zu sein, der das Problem hat. Guckst du z.B. hier:

    https://code.google.com/p/chromium/issues/detail?id=47211


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.