Passwörter doch speichern



  • Moin!

    Ich hatte für eine Webseite das Speichern der Passwörter erst abgelehnt, möchte es jetzt aber doch.

    In den Settings ist das Speichern nicht mehr für diese Seite blockiert.

    Nach dieser Anleitung funktioniert es leider nicht. Ich habe die login-Datei gelöscht. Doch nach dem Neustart waren die Passwörter ganz normal vorhanden. Sync war deaktiviert.

    Vivaldi-Snapshot: 2.5.1511.4 (Offizieller Build) snapshot (64-Bit)
    System: Manjaro KDE-Plasma

    Schönen Ostermontag
    DAS Feuerchen



  • Rufe mal chrome://settings/passwords auf und dann ganz nach unten scrollen.
    Dort steht: "Nie speichern für...."

    Vielleicht hilft's ja.

    Linu74



  • @Linu74 Das meinte ich mit Settings 😉



  • Es gibt ja noch die normalen Settings, die man über die normalen Einstellungen aufrufen kann.

    Linu74



  • @Feuerchen
    Moin moin, öffne chrome://settings/passwords , scrolle ganz nach unten.
    Da müssten die Adressen stehen bei denen du speichern abgelehnt hast.
    Einfach entsprechende Adresse löschen, dann bietet Vivaldi das speichern wieder an.

    Gruß, mib



  • @mib2berlin eben nicht... Es wird mir nicht angeboten.



  • Speichern von Passwörtern ist aber aktiviert auf der Seite die @mib2berlin und ich dir gegeben haben?

    Linu74



  • @Linu74 ja, ist aktiviert. Ich kriege es bei anderen Seiten auch angeboten.



  • Cache & Cookies löschen? Ansonsten fällt mir im moment auf die Schnelle nichts ein.

    Linu74



  • @Linu74 die Kekse für die Seite hab ich schon komplett gelöscht und die Einstellungen zurück gesetzt


  • Moderator

    Dann starte mal Vivaldi mit einem frischen Test-Profil in der Shell.
    vivaldi-snapshot --user-data-dir="/tmp/VIVTEST/"
    Wenn es dann geht, ist irgendwas in deinem normalen Profil kaputt.
    Wenn dem so ist, benenne ~/.config/vivaldi-snapshot/Default/Preferences in ~/.config/vivaldi-snapshot/Default/Preferences-BACKUP um, starte Vivaldi, probiere es ohne Erweiterungen und Einstellungen zu ändern.



  • @Gwen-Dragon Danke für den Tip. Leider funktioniert das auf diesem Weg auch nicht.

    Ich habe aber mal weiter probiert..... Das Problem tritt bei meiner DiskStation auf. Allerdings habe ich gerade mal den externen Zugriff versucht. Da wird das Speichern angeboten, nur bei der internen IP nicht.


  • Moderator

    @Feuerchen said in Passwörter doch speichern:

    Das Problem tritt bei meiner DiskStation auf. Allerdings habe ich gerade mal den externen Zugriff versucht. Da wird das Speichern angeboten, nur bei der internen IP nicht.

    Ist das über SSL (https)?
    Wieso IP? Hat deine Diskstation denn keine Hostnamen und kein Zertifikat?

    Soweit ich weiß, speichert Vivaldi keine Passwörter mehr, wenn es unsichere Verbindungen sind.

    Oder die Loginseite deines NAS ist so gestaltet, dass dort das Speichern von Passwörtern nicht erlaubt ist.



  • Der Zugriff von Ausserhalb erfolgt über DynDNS und SSL mit Zertifikat. Nur im Netzwerk gehe ich über die IP. Und beim Zugriff über die IP wird das Speichern des Passwortes nicht angeboten.


  • Moderator

    @Feuerchen Ohne SSL kein Speichern des Passworts, das ist aber schon lange so aus Sicherheitsgründen.

    In solchen Fällen benutze ich KeepassXC als Passwortmanager.



    Vielleicht hilft dir ein Lesezeichen mit folgender URL (Auf eigenes Risiko!)

    • Erstelle ein Lesezeichen Autocomplete aktivieren
    • Kopiere diese Zeile
      javascript:(function(){var%20ac,c,f,fa,fe,fea,x,y,z;ac="autocomplete";c=0;f=document.forms;for(x=0;x<f.length;x++){fa=f[x].attributes;for(y=0;y<fa.length;y++){if(fa[y].name.toLowerCase()==ac){fa[y].value="on";c++;}}fe=f[x].elements;for(y=0;y<fe.length;y++){fea=fe[y].attributes;for(z=0;z<fea.length;z++){if(fea[z].name.toLowerCase()==ac){fea[z].value="on";c++;}}}}alert("Enabled%20'"+ac+"'%20on%20"+c+"%20objects.");})();
    • Füge sie als URL im Lesezeichen ein
    • Rufe das Lesezeichen dann auf wenn das Speichern nicht klappt


  • @Gwen-Dragon Das ist an mir vorbei gegangen... Lange ist allerdings relativ.Die DS habe ich erst seit etwa einem Jahr. Und ich habe das Speichern schon angeboten bekommen, unter der IP. Da bin ich doch leicht irritiert.


  • Moderator

    @Feuerchen

    @Feuerchen said in Passwörter doch speichern:

    Lange ist allerdings relativ.Die DS habe ich erst seit etwa einem Jahr. Und ich habe das Speichern schon angeboten bekommen, unter der IP. Da bin ich doch leicht irritiert.

    Kann ja sein, dass sich deine Diskstation-Software geändert hat bzw. das neuere Vivaldi kein Speichern mehr zulässt.



    Warum bitte nimmst du eine IP?

    Ist das ne Synology? Bei meiner DS216+ geht das Speichern, wenn ich im DSM Systemsteuerung → Sicherheit → Zertifikat das Zertifikat exportiere, es in Windows Start bei Benutzerzertifikate verwalten zu Vertrauenswürdige Stammzertifikatstellen hinzufüge, und die lokale Domain ds216plus.fritz.box zur Administration nehme.


    Um welche Vivaldi-Version geht es?
    Und wobei speichert deine Diskstation nicht? Auf der Loginseite?



  • @Gwen-Dragon said in Passwörter doch speichern:

    @Feuerchen

    @Feuerchen said in Passwörter doch speichern:
    Kann ja sein, dass sich deine Diskstation-Software geändert hat bzw. das neuere Vivaldi kein Speichern mehr zulässt.

    Der SeaMonkey speichert das Passwort. An der DS liegt es wohl nicht

    Warum bitte nimmst du eine IP?

    Wenn ich im Zuhause im eigenen Netzwerk unterwegs bin, muss ich ja nicht den Umweg um die Welt nehmen. Außerhalb habe ich natürlich einen Hostnamen.

    Ist das ne Synology? Bei meiner DS216+ geht das Speichern, wenn ich im DSM Systemsteuerung → Sicherheit → Zertifikat das Zertifikat exportiere, es in Windows Start bei Benutzerzertifikate verwalten zu Vertrauenswürdige Stammzertifikatstellen hinzufüge, und die lokale Domain ds216plus.fritz.box zur Administration nehme.

    Ich habe eine 218j.
    Das Zertifikat gilt nur für den Hostnamen, nicht für die IP im Heimnetz. Es wird von Vivaldi angezeigt, dass die Seite nicht vertrauenswürdig ist, wenn ich die IP nutze. Über den Hostnamen ist alles gut.

    Mit dem importieren des Zertifikats muss ich mich mal beschäftigen, wenn mein Laptop wieder hier ist. Der macht gerade Urlaub bei meinen Eltern.
    Das mit der lokalen Domain kannte ich jetzt so nicht... Kommt aber auf die too-Liste.

    Und wobei speichert deine Diskstation nicht? Auf der Loginseite?

    Ja


  • Moderator

    @Feuerchen Wie ich schon sagte, Chrome, Chromiums und auch Vivaldi speichern von unsicheren Seiten (kein SSL, nur IP) keine Passwörter.

    Du solltest den Hostnamen der Diskstation verwenden. Ich nehme an der wird sowieso über DHCP verteilt. Wenn du dir den nicht merken kannst, dann mach dir halt ein Lesezeichen 😉


  • Moderator

    @Feuerchen Und ich kann mich gar nicht dran erinnern, dass die IP der Diskstation per Default in dem Zertifikat mit drin ist, obwohl technisch möglich. Aber eigentlich kommen in Zertifikate Hostnamen/Domains rein, IPs sind sehr selten, da IPs wechseln können und per DNS auflösbare Hostnamen da sinnvoller sind.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.