Adjust the Speed Dial size – Vivaldi Browser snapshot 1511.4

  • Moderator

    @nutcracker Yes, i can see this with f.ex. Stylus:
    Click on extension button → works.
    Open its Options
    Close Options page with Ctrl+W
    Click on extension button → fails.

    But such issue do not always happen.

  • @espen: yes, I have sync enabled. When I said "a while" I've meant like minute or so. It appeared automatically. But probably I just switched to first window in the meantime - I can see my bookmarks only in first window. Other two windows still has bookmarks empty (I kept my Vivaldi open after upgrading yestartday). Now restarting Vivaldi...

    After a restart all windows has bookmarks, but I've still seen empty speed dial on 3rd window, but after switching windows back and forth they appeared.

    So there is something not right there, but at least no data is lost.

    It's kidna hard to observe when they show up, as I have 3 windows, with a lot of tabs (most pinned) and first minute everything is unresponsive (can't open new speed dial tab to see if the bookmarks are there) until it loads most of the tabs. Sigh..., few years later and UI slowness is still why I can't convince others to use Vivaldi 😞

  • @gwen-dragon: Unfortunately it happens the second time I use an extension. Strangely I found out that by pressing one or two times on one of my extensions icon (named: reading list), the drop-down menu works again for all extensions all the time! Sadly it stops again after the second time I use them, but then I press the same extension icon and ... everything goes back to normal - I don't know if that helps to solve the problem. It is almost the same bug as in a few versions back.

  • Yay a snapshot including a major Chromium bump without any serious regressions! At least so far for me - nice work guys!

  • [BUG?] "delete browsing data" takes ages, doesn't it?

    1. press CTRL+SHIFT+DEL
    2. tick everything in the pop-up window, expect the first two options
    3. select "All Time"
    4. press DELETE

    You'll see that the deletion will require minutes and will appear to be stuck, while the round arrow will continue turning leftwards.

    Can anybody confirm, it?


  • Worst snapshot in a long while... Randomly can't click or use extensions, it crashes and closes out of nothing... Had to downgrade 😢

  • I have problem with extensions bar. I can't open uBlock by a left click.

  • @duzers too bad seems a regression in this snapshot, but restarting vivaldi seems to cure the extensions popup, until it happens again. I can't repro exactly what causes it to fail opening.

  • Moderator

    @iAN-CooG @duzers

    I haven't yet seen this bug happen. If it does happen again, something you could try is this:

    • Open vivaldi://inspect
    • Open the apps section
    • Click the inspect button under vivaldi

    If something is causing an error, a little red bar will show up in the "Console" tab each time the error happens. If one shows up when you click an extension button, that could be a good indicator of what the problem is.

  • Vivaldi Team

    @jacekn: Ok. So all the windows belong to the same session right? This build had a bookmark upgrade in it and I have seen one case where that failed and broke loading of bookmarks. Happened because the upgrade had one entry for slashdot with a nickname "/." which conflicted with an already installed bookmark (duplicate nicknames are not allowed) on that particular setup. This is fixed with VB-51758. In your case I guess it was sync that kicked in after some time and triggered proper loading after loading on startup failed. Why it failed I can not say for sure unless you can reproduce going from pref. snapshot to current in a clean profile (created by the prev snapshot) where you place a copy of the regular bookmark file before upgrading to current snapshot. If you can make that fail repeatedly I would like a copy of that bookmark file if you feel giving it away. In any case, the next snapshot will have code that make startup loading more robust. Note that the bookmark upgrade code only triggers if there is something to upgrade and that does not happen every snapshot/release.

  • @iAN-CooG I had this a few times now, toggling UI fixes it, no need to restart. At least on my system.

  • Vivaldi Team

    @folgore101 said:

    @PardusPars After the update, all the default folders reappeared and the Speed Dial folder was double. Has it already been reported?

    They way it is supposed to work now (we have added an id to every default bookmark) is that if those are deleted by a user the id is saved to prefs. On next bookmark upgrade (that does not have to happen on every snapshot or regular release) for each bookmark in the default bookmark collection we provide we will test if its id is a registered deleted id and if so we will not reinstall it.

    One way to break this is to copy a bookmark file from one profile to another where the deleted information is missing.

    The id support was added with 2.4. If you have deleted before that it could very well be that this is the first time bookmarks have been upgraded. In that scenario there will be no saved deleted ids to test for and duplication can not be avoided. That should only happen the first time upgrading occurs though.

  • Tiny thumbs. ❤

  • @mrmeireles said:

    @derday: Try closing the tab and opening a new one.

    Nothing change

  • This snapshot seems to have fixed a strange long-term issue that I've had with Ubuntu Forum's SSO login and Vivaldi. I've mentioned it before on Vivaldi's forum a while ago where there were some "works for me" and also others who suffered the same. It was one of those frustrating bugs (if it was one).

    The login worked fine with Firefox and other browsers, but for a few years it was no-go with Vivaldi on Linux or Windows. It'd start the login process, but when it refreshed to the forum, I'd still be logged out. I tried with a fresh profile, yet it still didn't work. It's one of the things I try with most snapshot updates, and at last it's working as expected.

    It might be something they changed on Ubuntu's forum, or it might be the new Chromium version or it might be a change in Vivaldi, but it's now working for me.

  • Everything seems to be working well with this SS.

    Resizing the the speed dial tiles has been something I've been hoping for for a good while. I liked the way @den_po had implemented it, but this works. Thanks

  • @mrmeireles too bad, after restart of the browser today, whatsapp doesn't work any longer 😞
    I give it a try with the UA changer

  • @sjudenim said in Adjust the Speed Dial size – Vivaldi Browser snapshot 1511.4:

    Resizing the the speed dial tiles has been something I've been hoping for for a good while. I liked the way @den_po had implemented it, but his works. Thanks

    yeah, sliders for width and spacing of thumbs was extremely good for fine tuning, but current solution is better than none, I can finally have 7x5 speed dial on my 1280x1024 monitor, with no extra mods, and I'm good.

  • Moderator

    I get something clarified about speed dial sizes? If I get it wrong, it'll just annoy me.

    What is the size / ratio of a speed dial?

    The default images in /resources are all 360 by 440, but looking at the actual size in the browser, they are in this ratio

    • Default: 220*183
    • Huge (the maximum size): 320*267

    I recall that over time, the sizes have changed, but what is the now "canonical" size I should be making custom speed dial images at?

  • Moderator

    @LonM I still make them 440 X 360 and everything works out.

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.