BUG? Trackpad zoom in, no zoom out



  • Every so often, when scrolling down a page using two-finger scroll on the track pad, my fingers will accidentally separate and Vivaldi zooms in. In itself that's not a problem, but the opposite gesture doesn't zoom out. I've just discovered the zoom slider, but I'd prefer to be able to use the trackpad gesture as it is less disruptive.



  • Returning to this … the situation has got worse with the latest snapshot — 1.0.219.3 (Developer Build) (64-bit) — as the inadvertent zooming shuts down the tab pane and the status bar at the bottom. The reason I was pleased to find Vivaldi in the first place is that I can have graphic tabs in a pane on the right. As the status bar is not visible, I can't use the zoom slider; Ctrl-minus zooms out the main browser window but doesn't re-instate either the status bar or the tab pane; and although the trackpad will zoom in, the opposite gesture will still not zoom out or restore the missing window elements. I can find no way to recover them other than shutting down Vivaldi and re-opening it.

    All in all, to me a serious PITA.

    Mark


  • Moderator

    Have you tried it with 1.0.219.43?



  • I've just installed 1.0.219.43. I'll report back when I have any news of this.

    Mark

    EDIT: Quick trial, 1.0.219.43 seems not to respond to either zoom in or zoom out gesture on the trackpad, which is good enough by me. I'll be back if anything changes.



  • Sorry to say it's just happened again using 1.0.219.43. I have to say, I'm really not sure exactly what triggered it, except I was using two-fingered scroll on the trackpad.

    This is on a late 2010 MacBook Air (version MacBookAir3,2), Intel Core 2 Duo 1.86 GHz, 2GB RAM, OSX 10.10.4.

    Mark



  • If anything the problem is worse with TP4. I've disabled a number of gestures on the trackpad, like 2-finger tap for secondary click to see if that helps.

    Mark



  • HAH… this is exactly why I came to this forum and why I created an account. I JUST downloaded the latest release this morning (1.0.219.51 (Developer Build) (64-bit)) and this zoom issue is annoying as all heck.

    Would like to at least see a setting to turn that feature off.



  • To elaborate more…. I think it's just when I hit the CMD button and scroll - which evidently I do quite often after closing a tab or new tab or something... idk I've turned off all swipe gestures in the settings and it still happens to me once in a while.

    Very rarely do I ever use zoom in a browser; in which case I'm aware of CMD++ / CMD+-/CMD+0 and I don't see the purpose for an always-on dedicated UI section for "reset" and zoom scale on the bottom right. Just unneeded UI element IMO.



  • Hi,

    I often made accidentally zoomIn/zoomOu in because I often use cmd button with my Magic Mouse in other hand.

    Please, could you deactivate cmd + scrollUp/Down feature or change cmd button by Ctrl button. Or better give us the ability to configure this shortcut/gesture.

    Thank
    jjay



  • I had the same problem as jjay


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.