Saved passwords are not applied because of duplication



  • Assuming that the saved passwords are not applied to the websites because the passwords were duplicated by import. So, disconnected from sync and deleted everything with the delete selection, but the passwords are still listed in Settings\Privacy, duplications et al. How can I get rid of them (not one by one) so that I can import from Firefox a fresh set of settings?



  • @ineuw said in Saved passwords are not applied because of duplication:

    ..... because the passwords were duplicated by import.

    Hello there,

    Did you export the passwords manually?



  • @lamarca, Hi. I forgot how to export the bookmarks from Vivaldi, so the accumulated bookmarks are the result of sync (I sync with Linux Mint), or import from Firefox which currently (and again) fails.

    P.S: vivaldi://flags/#passwordimport is enabled



  • @ineuw said in Saved passwords are not applied because of duplication:

    @lamarca, Hi. I forgot how to export the bookmarks..........

    You mean passwords, confirm?
    Clear the only passwords on Sync. Ever tried to delete just one passwords stored on Vivaldi (write down the one you delete) and login? I never have never seen it before.
    vivaldi://sync-internal can confirm if there are no Synced passwd.



  • Perhaps I clarify the steps I took, and this may help.

    • I've been having trouble to log in, or at least having the login screen show up on sites.
    • I checked my Settings\Privacy list of passwords, and noticed a lot of duplicate entries.
    • The two possibilities of the duplication could have been from sync, or the re-import of passwords from Firefox.
    • I stopped sync and cleared the sync data on the server, and cleared everything using
      /File/Delete browser data. But this did not clear the passwords. They were still listed in Settings/Privacy.
    • So, I removed the Default folder, re-configured everything easily since I know the settings and my preferences.
    • Activated "vivaldi://flags/#password" and enabled the password import.
    • Selected /File/Import Bookmarks and Settings, and set the import source to Mozilla Firefox.
    • Selected Bookmarks and Passwords and this imported the bookmarks but NOT the passwords. - I tried this several times but the passwords were not imported.
    • Now, I found out that Firefox has updated their password files from key3.db to key4.db and cert8.db to cert9.db and this broke the Firefox import.
    • I also have a separate .csv password file configured to Vivaldi import columns, but can't import it.


  • @ineuw
    Hi, the Flag is for import passwords from a .csv file and the import function is reachable from vivaldi://settings/passwords
    There are 3 small dots on top right to open import.
    Check here to import your .cvs.
    The File/Import Bookmarks and Settings is different.

    Cheers, mib



  • @ineuw Understood. Please, open the terminal and issue (copy&paste) the following command:

    /usr/bin/vivaldi-snapshot --user-data-dir="/tmp/VIV-TST" &

    It's a temporary install, in case it works fine, then the issue lies on your profile.



  • @lamarca

    My first post was from Windows after I checked Linux. Windows, deleted my sync data, logged out of sync, closed Vivaldi and removed the Default folder and recreated everything from scratch, imported the bookmarks from FF, and created four password logins. Then I signed into sync and waited for it to upload and exited from V and rebooted into Linux.

    Before I tested your command, removed the Vivaldi Default profile folder and then started Vivaldi. Signed in to sync (this is sometimes demanded by sync), typed my encryption key and it installed everything, but the passwords were the previous list with the duplicates. Your code didn't create anything in /tmp. Ran it twice with sudo perhaps that was wrong.

    This is for Linux:
    /usr/bin/vivaldi-snapshot --user-data-dir="/tmp/VIV-TST" &

    I am willing to start from the beginning with a new profile in both OS.



  • @mib2berlin Hi, I know what you meant by the three dots, having used it before, but they don't exist in my version of Vivaldi. (updated today).



  • @ineuw You are right, the command bellow (please, don't preface with sudo) it's for Linux only.

    Please, add a note to let people know the platform is Windows.
    Thank you



  • @ineuw
    I start with a fresh profile, with profile manager, and there are no 3 dots.
    If you set the flag for import they apere and it should be possible to import your .cvs.
    You wrote you reset sync but all passwords pop up again with a fresh profile?
    I will try to reproduce it tomorrow, getting late here and I need a clean brain to not mess up my system. 🙂

    Cheers, mib



  • @mib2berlin Thank you and sleep well. I will stop the sync, delete the Default folder, and the password file in both OS. (I have everything backed up) Then, will post the results.

    The results:

    Started In Windows 10:
    Cleared the sync data and logged out of sync. Deleted the old Default folder and quit WIndows.

    In Linux Mint 19.1:
    Deleted the old Default folder. Created a new profile and signed in to sync to see if there was any sync data and passwords, but the sync was empty. Set up my preferences, imported my bookmarks from an HTML file, logged into 8 websites and saved the passwords. Waited about 15 minutes to be sure that the sync was completed then, logged out of Linux and returned to Windows.

    In Windows again:
    Created a new profile, and logged in to sync. Syncing restored my Linux bookmarks, the 8 passwords, and most of my settings. I know that not all settings are synced.

    So, the only thing remained is the import password process needs to be upgraded to the latest Firefox requirements and fixing the .csv import file option.



  • @lamarca Thanks for this test. it worked perfectly and that is why I dreplace my old profile.



  • @ineuw You are welcome. I am glad you solved the issue.

    Cheers



  • @ineuw
    Hi, nice it work now so far.
    What I try was to create new profile, enable import flags and import a .csv I export from my standard profile. Work fine.
    The .csv file include many double and tripple entries but after importing all double/tripple entries disapere. No idea how this come from but it work at the end.

    Cheers, mib



  • Let sort things out (Linux)
    The core of the test is trying to repro the issue you are having, in case the temp install doesn't repro, then issue lies on your profile.



  • @mib2berlin, I am using this latest stable version, 2.4.1488.35 (Stable channel) (64-bit)

    The import passwords flag is enabled but there are no controls to activate the process. I know that there used to be three dots visible to activate the import when hovering above active flag setting, but they are no longer there.



  • @ineuw Did you enable:
    vivaldi://flags/#PasswordImport and restart Vivaldi?



  • Everything is solved!

    @lamarca I restarted Vivaldi after enabling the flag. However, I forgot the next step that after enabling the import-export flag, at vivaldi://flags/#PasswordImport page, one has to load the chrome://settings/passwords page to get to the passwords and the 3 dot menu options import-export. I've done this long ago, but using it only twice, forgot about it.

    This forum post explains it clearly:
    [https://forum.vivaldi.net/topic/11872/how-to-export-backup-restore-saved-passwords-in-vivaldi]

    @mib2berlin, I also expected that the import process dumps duplicates, but there were no real "duplicates". They differed by having a different username because some forums changed their login policies, and asked for the email address instead of the username, and I had many of those because forgot to delete the old entry.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.