Vivaldi 2.4 RC 2 – Vivaldi Browser snapshot 1488.29


  • Vivaldi Team

    Today’s snapshot is the second release candidate for 2.4.

    Click here to see the full blog post



  • Først!



  • What I noticed is that the profile icon shows, when UI is hidden and address field is visible. But it should be hidden just like extension container, search field and toolbar buttons.

    0_1553509011315_Screenshot 2019-03-25 11.16.40.png


  • Moderator

    The issues I mentioned in the last blog post are still happening.

    • Tabs and panels taking time to actually show up, or flickering when tiled. VB-50220
    • Stuttering / input lag when moving tabs to new windows VB-50885

    I would really like to see those issues fixed before a release is made.

    Otherwise, [Regression] Extension popup does not close when profile popup is opened (VB-51009) seems to have fixed a number of other related extension button issues, like popups being out of position. Good stuff.



  • Is there any way to see what might be the new features on the next final version?(2.4)



  • Thanks Ruarí. Confirm tab trash menu fix working as expected. Didnt have any other issue.



  • The print/print preview problem is still not fixed in 1488.29, I really hope it is getting fixed before the 2.4 stable release.

    See: https://forum.vivaldi.net/topic/32487/often-cannot-print/18 (over 1,300 views show that a lot of users face this issue)

    @Gwen-Dragon reported it as VB-46572 to the related VB-46547.

    I cannot consider Vivaldi with this error a stable, productive browser since every time I want to print a complex web page (i.e. Amazon, Ebay, etc.) I have to open Chrome or Edge, copy and paste the link, print and go back to Vivaldi and this up to 30 times a day which is very annoying and time consuming.

    I'm wondering more and more about the strategy to incorporate nice-to-have features before making the browser stable to use on a daily basis.


  • Moderator

    @rhk I had completely forgotten about this issue as I ended up re-building my workflow of printing to just download for reading in an external PDF viewer.

    I would certainly like to see it fixed, as its a major annoyance, but I can work around it, so it's not a show-stopper for a release candidate for me.

    Also, this has been going on for longer than 2.4 if I'm remembering correctly. I fear this might end up being one of those bugs that ends up just settling in as being normal. Hopefully next release cycle with 2.5, as I don't see it being fixed at this stage.



  • Since this Snapshot. Browsing in Private Window and "Open Links in New Tab" on: Everytime I also get two new open Sites in the Non-Private-Window with the respective Site, which I think should only be opened once in the Private Window.


  • Moderator

    @Thot That sounds like a bad bug if it might leak private browsing, but I can't reproduce it myself. Do you have any extensions?



  • @LonM Seems to be ok now. Cleared all Cookies and Browserdata.


  • Moderator

    I'm seeing the error message about sync not connecting again. Is there any way to see what actually caused these (i.e. if it was a net issue, sync server issue, or vivaldi itself causing a problem)?

    Right now you can use vivaldi://sync, but that only seems to start logging things after you load the page which isn't super helpful.


  • Vivaldi Team

    @lonm: Are you connected? Because we do have an issue where Sync warns that it has stopped working, but appears to still work anyway. We have a fix internally that we are considering. If there is an RC3, it will almost certainly include it.



  • @lonm: Confirmed

    Win10x64 Vx64



  • @rhk: Confirmed

    Win10x64 Vx64



  • any chance to have VB-49541 and VB-50913 fixed before stable?
    (chr73 caused a lot of regression, I'm aware of that)



  • @ruario I saw that.
    Usually happen when I open both an "old" snasphot (2.4.1468.4) and the last one (2.4.1488.28). But then sync seems to work fine.



  • Not sure when this started happening, but I notice when playing a YT video fullscreen, sometimes I forget to press 'F' to exit before I press Ctrl+W to close the tab. This will lead Vivaldi to 'lose' the tab bar completely.

    I think I can reproduce this consistently. Not sure if it's this snapshot or if it goes a while back.

    Also pressing F11 twice make it reappear, so this is a graphical glitch.

    Anyone else seeing this?

    Reported as VB-51157


  • Moderator

    @ruario: I was connected, but I noticed it after logging in to a computer that was previously locked - I don't know it that would affect anything. In any case, sync seemed to working fine anyway.

    @hadden89 - maybe this is related. I had started my 2nd machine and it was running a snapshot from early last week. But it was only after updating it to the latest RC that it sent the error message.



  • Man, you broke "Show Closed Tabs" again 😆

    Damn, that's weird, after restart it's back again. So not sure how to reproduce. Apparently, also Alt-menu was broken when it happened, so something messed up my Alt-key I think?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.