In latest version 2.3 downloading a file doesn't always show up in list



  • I've noticed in the latest version 2.2 or 2.3 that when a file commences downloading it doesn't always show up in the download panel list even though it will be reliably displayed in vivaldi://downloads, and the panel is automatically opened. It doesn't seem related to the file size.

    Even while the download is in progress you can click the refresh button in the download panel list but it won't be displayed.0_1552274370741_Window 20190311-141815.jpg

    Vivaldi 2.3.1440.41 (Stable channel) (64-bit)
    Revision 3750db4b5bee8761338f5e4af4eb928feb5bddff-refs/branch-heads/3626@{#800}
    OS Windows
    JavaScript V8 7.2.502.24
    Flash (Disabled)
    User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.82 Safari/537.36 Vivaldi/2.3.1440.41
    Command Line "C:\Program Files\Vivaldi\Application\vivaldi.exe" --flag-switches-begin --flag-switches-end --save-page-as-mhtml
    Executable Path C:\Program Files\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\ajh\AppData\Local\Vivaldi\User Data\Default


  • Moderator

    2.3.1440.60 is the latest version of Stable. Please update and retry.

    ❓ And how can we reproduce it? Without any link to such files?



  • @Gwen-Dragon said in In latest version 2.3 downloading a file doesn't always show up in list:

    2.3.1440.60

    I have installed 2.3.1440.60 & not noticed this problem yet with 5 or so test downloads. Maybe fixed. I didn't check the Chromium engine release notes for any mention. As I said I didn't feel it was related to file size. Or file name, file type. In all cases I was right clicking the link & chose Save Link As...

    Will monitor for a week. Thanks for you comment.



  • Now using 2.3.1440.60. I just downloaded two gmail attachments. One showed up in the downloads panel, then second did not, but both were successfully downloaded. I deleted both files. Deleted both items from the downloads panel & downloaded them again. This time both were successful. I don't think I didn't anything different the 2nd time.



  • I now have a public URL to demonstrate the bug:
    https://windows.lbl.gov/system/tdf/software/THERM7_7_01_SetupSmall.exe?file=1&type=node&id=6865&force=

    You can see from the screen capture 0_1553050081387_Window 20190320-134549.jpg
    that the file is downloading in vivaldi://downloads, but isn't listed in the Download panel. I tried showing/ hiding (F4) the panel a few times, but no change.

    As I have said though, I don't think the bug has anything to do with the URL. Once the file had downloaded, I downloaded it a 2nd time. This time the panel automatically opened and the file was listed:0_1553050385334_Window 20190320-135145.jpg

    Vivaldi 2.3.1440.60 (Stable channel) (64-bit)
    Revision e78ac5b2c005af6b8bdcced26e44036559f636b0-refs/branch-heads/3626@{#884}
    OS Windows
    JavaScript V8 7.2.502.28
    Flash (Disabled)
    User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.122 Safari/537.36 Vivaldi/2.3.1440.60
    Command Line "C:\Program Files\Vivaldi\Application\vivaldi.exe" --flag-switches-begin --flag-switches-end --save-page-as-mhtml
    Executable Path C:\Program Files\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\ajh\AppData\Local\Vivaldi\User Data\Default


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.