Video playback problem



  • Hello! I've just joined here to get some help with this new browser. I found it after someone mentioned it over on Overclock.net, so I thought i'd give it a spin, and so far I like it. Now the problem i'm having is related to video playback on some sites. Youtube seems to work fine and as expected, but another site i frequent, News.sky.com, I cannot for the life of me get it to play videos on that site. It doesn't even give me the play button like it normally does. To aid troubleshooting, I decided to try the cnn.com site from the news bookmark, and there, i can get sound, but the video screen is just a black box, no picture. Any help to resolve this would be appreciated. :-) I do get the feeling though, that it may just require me to be patient till more coding has been done! :-)



  • Do News.sky.com videos need plugins like silverlight or flash?
    Maybe you aren't using any of those plugins.
    Youtube works anyway ( html5 ftw :D ).
    There's a bug though with some of those plugins making the UI crash sometimes.

    Don't worry, soon or later we will only have html5 videos anywhere (even porn websites have html5 players nowdays), and the problem will solve itself :D

    Oh and I just noticed this is your first post. Welcome !



  • I don't think they use silverlight or flash, it doesn't even ask for those plugins (i think flash is already in vivaldi? ) from what i can dig out of a video news page, it loads a player from player.sky.com. there's mention of .svg's, looks like some script code of some sort. also up top it said it was made with adobe illustrator, so i dunno if that offers clues (might point to flash or shockwave?). Anyway, the plugin page says i have shockwave, vlc, silverlight already there, i've set them to always allowed, to no avail.

    Thanks for the welcome, and the help. GinoPerta. :-)



  • @latelesley:

    Hello!

    I've just joined here to get some help with this new browser. I found it after someone mentioned it over on Overclock.net, so I thought i'd give it a spin, and so far I like it.

    Now the problem i'm having is related to video playback on some sites. Youtube seems to work fine and as expected, but another site i frequent, News.sky.com, I cannot for the life of me get it to play videos on that site. It doesn't even give me the play button like it normally does. To aid troubleshooting, I decided to try the cnn.com site from the news bookmark, and there, i can get sound, but the video screen is just a black box, no picture.

    Any help to resolve this would be appreciated. :-)

    Pretty simple: Vivaldi has the h264/html5 support yet to be implemented (It's on high priority list anyway)

    So HD videos are usually provided trough the flash player.

    Most of the websites (youtube included) are providing the videos on two (or more) formats.

    Looks like that News.sky.com, unfortunately, does not.

    Anyway I never faced problems on cnn: videos are working fine. So be sure you have the latest Flash player installed on your PC.



  • This is also a problem on the BBC News website and I am sure I have had it on other sites which have not been mentioned.

    At least I now know what the problem is.

    Thanks



  • On bbc news/ bbc sports videos are playable too, if the flash player is installed.

    You need to install it.

    AFAIK only Chrome has the embedded flash player.

    On Chromium and other Chromium based browsers you must install it.



  • Flash is property of Adobe,
    That's why chromium doesn't include it.
    It should be the same for the others browsers I guess.

    If you're struggling with plugins, you can't find out which are or are not enabled take a look at here:
    vivaldi://plugins



  • @GinoPerla:

    Flash is property of Adobe,
    That's why chromium doesn't include it.

    There is nothing that prevents an agreement between a commercial company and an open source organization.
    Obviously that happens more rarely, but happens.



  • @The_Solutor

    You are a genius! I've installed the chromium version of flashplayer on my PC, and videos on both sky, and cnn seem to be working!

    I also tried the BBC.co.uk news site, and also got video to work there. This may solve your problem too, @Thasaidon. :-)

    I've ditched chrome because of the voicesearch thingy, no way to turn it off, at least here, although it is chrome based, the voicesearch thing seems to be off by default.

    I look forward to this browser developing in the coming months/years. I can see things in need of improvement, but I know these things take time. For it to be at least a functional browser just now is great!

    Thank you for the help everyone. :-)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.