Please Fix Temp File Handling on Linux



  • Developers --

    I love everything about Vivaldi except file handling.

    Maybe I am doing it wrong and if so, please forgive my rant ...

    Vivaldi does not have a local mimetype file so I cannot control which application opens specific file types.

    I've already complained about this here.

    I recently found out that Vivaldi copies and LEAVES Files in my Download directory each time I click on a .txt file ( example: ftp://ftp.osuosl.org/pub/slackware/slackware64-current/ChangeLog.txt )

    I just noticed that Vivaldi emulates MS Windows brain-dead convention of appending ' (n)' to the base filename followed by the extent.

    Check it out. This is unacceptable:

    -rw-rw-r-- 1 konrad users 523099 Feb 9 17:55 /home/tmp/ChangeLog.txt
    -rw-rw-r-- 1 konrad users 563399 Feb 9 17:56 /home/tmp/ChangeLog (1).txt
    -rw-rw-r-- 1 konrad users 563652 Feb 11 15:57 /home/tmp/ChangeLog (2).txt
    -rw-rw-r-- 1 konrad users 523099 Feb 11 15:57 /home/tmp/ChangeLog (3).txt
    -rw-rw-r-- 1 konrad users 567536 Feb 16 14:16 /home/tmp/ChangeLog (4).txt
    -rw-rw-r-- 1 konrad users 525452 Feb 16 14:17 /home/tmp/ChangeLog (5).txt
    -rw-rw-r-- 1 konrad users 568180 Feb 17 13:49 /home/tmp/ChangeLog (6).txt
    -rw-rw-r-- 1 konrad users 568180 Feb 17 13:53 /home/tmp/ChangeLog (7).txt

    Each of those files were created when I clicked on the link above.

    I don't know about anyone else, but this is very annoying for anyone trying to perform commandline ops on the folder containing such files.

    The '(n)' suffix is illegal for most command line ops unless I quote the files.

    Please consider creating proper temp files and open them in the browser -- I don't want to execute Kate just to look at a text file and please erase your temp files !

    Or like I said, maybe I am doing it wrong ?

    Is my Vivaldi Config borked ?

    Thanks

    -- kjh


  • Moderator

    @kjhambrick Hello there. Usually, dev's don't reply threads, I can see you are a Slackware users - our Linux Wizard is a big fan of your distro and frequently help us.

    You are right, it's your OS that handles with MIME types. I got the same file as you. The MIME type file should define which application handle that file type.

    Let me know if you got to make it work.



  • @kjhambrick I thought we explained in already in your previous thread.

    If you want to save files with a name of your own choosing, right-click and use Save link as ...

    This will also stop Vivaldi from leaving them in your download directory as you can choose the folder on saving them.


  • Moderator

    @Pesala It's not the case of a simple right-click.



  • @lamarca said in Please Fix Temp File Handling on Linux:

    @kjhambrick Hello there. Usually, dev's don't reply threads, I can see you are a Slackware users - our Linux Wizard is a big fan of your distro and frequently help us.

    You are right, it's your OS that handles with MIME types. I got the same file as you. The MIME type file should define which application handle that file type.

    Let me know if you got to make it work.

    Lamarca --

    Thanks for the quick reply !

    Which mimetype file do I need to edit ?

    Does Vivaldi have a local mimetype file ?

    Thanks again !

    -- kjh


  • Moderator

    @kjhambrick You are welcome. AFAIK, Vivaldi doesn't have his own mimetype file. It's controlled by your OS. I am trying to find out which file type. The link download the file without prompting that dialog.
    I set Vivaldi-Snapshot for plain text document, no luck.
    Try editing the file type above, and see it works for you, otherwise I will ping some.


  • Moderator

    @kjhambrick I found a work around to give the option to download or cancel the file.

    Go to Alt+P >> Downloads ---- it must me exactly the shot below:

    0_1550436962977_mime.png



  • @lamarca said in Please Fix Temp File Handling on Linux:

    @kjhambrick I found a work around to give the option to download or cancel the file.

    Go to Alt+P >> Downloads ---- it must me exactly the shot below:

    0_1550436962977_mime.png

    Shucks ...

    I Changed my settings and tried it ... still got a Clone File in Kate.

    Restarted Vivaldi and tried again and still another Clone File opened in Kate.

    I am now up to (9) clones:

    $ ls -lart $t/ChangeLog*txt

    -rw-rw-r-- 1 konrad users 523099 Feb 9 17:55 /home/tmp/ChangeLog.txt
    -rw-rw-r-- 1 konrad users 563399 Feb 9 17:56 /home/tmp/ChangeLog (1).txt
    -rw-rw-r-- 1 konrad users 563652 Feb 11 15:57 /home/tmp/ChangeLog (2).txt
    -rw-rw-r-- 1 konrad users 523099 Feb 11 15:57 /home/tmp/ChangeLog (3).txt
    -rw-rw-r-- 1 konrad users 567536 Feb 16 14:16 /home/tmp/ChangeLog (4).txt
    -rw-rw-r-- 1 konrad users 525452 Feb 16 14:17 /home/tmp/ChangeLog (5).txt
    -rw-rw-r-- 1 konrad users 568180 Feb 17 13:49 /home/tmp/ChangeLog (6).txt
    -rw-rw-r-- 1 konrad users 568180 Feb 17 13:53 /home/tmp/ChangeLog (7).txt
    -rw-rw-r-- 1 konrad users 568180 Feb 17 14:11 /home/tmp/ChangeLog (8).txt
    -rw-rw-r-- 1 konrad users 568180 Feb 17 14:58 /home/tmp/ChangeLog (9).txt

    I am researching the xdg programs to fiddle with MIME Types now ...

    Will follow up if I find a workaround.

    Thanks again lamarca !

    -- kjh


  • Moderator

    @kjhambrick You are welcome.
    Here are mine clones. I will keep trying as well.

    -rw-r--r-- 1 lamarca lamarca 555K Feb 17 17:29 ChangeLog (1).txt
    -rw-r--r-- 1 lamarca lamarca 555K Feb 17 17:35 ChangeLog (2).txt
    -rw-r--r-- 1 lamarca lamarca 555K Feb 17 17:13 ChangeLog.txt

    Cheers



  • @kjhambrick Disable all options in Settings, Downloads,

    Left-click, Save as, and Choose the folder (which is remembered), then rename the file if it already exists.



  • @Pesala said in Please Fix Temp File Handling on Linux:

    @kjhambrick Disable all options in Settings, Downloads,

    Left-click, Save as, and Choose the folder (which is remembered), then rename the file if it already exists.

    Thanks Pesala but that should not be necessary.

    All the browsers that I've ever used before simply open .txt files in the current tab.

    I just now checked a few other Browsers:

    Firefox - opens the ChangeLog.txt link in the current Tab ; [Back] returns as expected
    PaleMoon - opens the ChangeLog.txt link in the current Tab ; [Back] returns as expected
    Chromium - does the same thing as Vivaldi
    Google Chrome - opens the ChangeLog.txt link in the current Tab ; [Back] returns as expected
    Konquerer - crashed !

    I NEED my browser to work like Firefox, PaleMoon or Google Chrome.

    Thanks again.

    -- kjh


  • Moderator

    @kjhambrick According to Debian, the file type is "text/x-log". Playing to mimetype is possible Vivaldi does what expect, it's not perfect yet. You can do that!



  • This appears to be a chromium decision and not a vivaldi or OS mimetype problem.
    See the same in google-chrome yet firefox will open directly.
    Probably a security over covenience decision.
    https://bugs.chromium.org/p/chromium/issues/detail?id=118204&thanks=118204&ts=1331749873


  • Moderator

    @CantankRus I don't have Chr on my system. Acccording to @kjhambrick the Chromium behavior is the same as Vivaldi, see if it works for you:

    https://forum.vivaldi.net/post/272334



  • @lamarca
    Chromium and firefox will open .txt links directly without saving to ~/Downloads first.

    google-chrome will always download .txt links and give you the option of "Always open files of this type".
    0_1550509862259_188.jpg
    This means that after download it will then open the local file with the application set as default for that mimetype.
    A lot of these files are text/plain and will open with your default text editor.

    To view in google-chrome as you're browsing, you would need to set "Always open files of this type"
    and also set google-chrome as the default handler of text files in your OS.
    It will then open these type of links in a new tab but still downloads the file first
    as the addressbar shows when I click on a .list link from this page.
    0_1550515873609_190.jpg

    Vivaldi behaves the same as google-chrome but doesn't give the option to always open the local file after download
    so your OS mimetypes don't come into play until you click on the downloaded file
    either in the vivaldi download panel or your file manager.

    The fact that chromium behaves differently than google-chrome leads me to believe that google
    may have decided they are a security issue.

    I can understand @kjhambrick issue and if I frequented sites that contain files of this type
    I would switch to chromium or firefox


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.