Opening link from other applications not reliable four you?



  • I have set Vivaldi to my default browser (current MacOS). When I click on links in Mail, Adium and other Applications, Vivaldi is focused, but the link is not opened (neither in a new tab nor in an existing one). I am trying to reliably reproduce this to issue a bugtracker item, but find it difficult. It seems that the first few clicks (in the third party app) don't do anything, then later clicks do in fact open the correct page in Vivaldi. Does anybody have similar experiences and can help me track this down?


  • Moderator

    Yes, the problem exists since Vivaldi TP3, but in other OS, too.

    The bug was reported last month and will be fixed, but i have no schedule yet.



  • It may not be a bug at all - it may be related to the automatic assignment of "spaces" in MacOS. Assign a "Window" to every application you run, and run low on memory, and MacOS will change context from the old application to Vivaldi, but since Vivaldi is unable to obtain memory, it halts here. You have to go back by Alt+TAB activate the old, and then manually activate Vivaldi - or use the "Spaces" key, and change to Vivaldi.
    A simple fix is to buy more memory. Another fix is to tune the "swappiness" of the system. In a way, this is a VMS kind of problem and a suggested solution may be for Vivaldi to make a force memory allocation - to flush file buffers out to the disk and release the space when it takes time to change from the main Vivaldi process to the helper that runs the active window.
    Something is very wrong in the way memory is managed, and it is not just C++ that is the reason.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.