Salesforce (Lightining) page not working using Vivaldi



  • Hello everyone!

    Not sure I'm in the right place to post this, hopefully yes.

    First of all, first day trying out this browser, everything seems to be nice and working as I expected.

    I just met one problem, which is that some pages provided by the Salesforce platform just does not load and stay white.

    Currently, I'm not able to provided pictures to explain myself better, so I'll try to go with words.

    Salesforce settings and admin are managed in a two way column, on the first column you simply have the menu and in the second column the content should be loaded. It simply does not happen and the page remain blank.

    I've just downloaded Vivaldi, without any further extension. (I have created a fresh new profile and only imported bookmarks from old browsers)

    Any suggestion?


  • Moderator

    You could try pressing the "F12" button on your keyboard when the page (doesn't) load.

    Then, in the "console" tab that appears, look for any red error messages. These would be useful in diagnosing potential problems with vivaldi.

    You could also try using a user agent extension and pretending to be chrome, this can sometimes help issues.


  • Moderator

    As it is not easy to run a demo , you have to wait until a Salesforce user comes here and helps.

    But i give you a chance ā€“ i hope this could work:

    • Install extension Chrome User-Agent Switcher
    • Open Options by button's conetxt menu
      • At 'Custom User-Agent List' you can fake a user-agent (browser identification)
      • In field 'New User Agent name' add:
        Chrome 72
      • In field 'New User Agent String' add:
        Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36
      • In field 'Indcator flag' add: C72
      • Hit 'Add'
      • Close the option page

    Now you can select in extension button 'Chrome 72' to fake Vivaldi be identified as Chrome.
    Try a new login at Salesforce



  • This post is deleted!


  • @LonM said in Salesforce (Lightining) page not working using Vivaldi:

    You could try pressing the "F12" button on your keyboard when the page (doesn't) load.

    Then, in the "console" tab that appears, look for any red error messages. These would be useful in diagnosing potential problems with vivaldi.

    You could also try using a user agent extension and pretending to be chrome, this can sometimes help issues.

    Tried in Vivaldi and Chrome, i get the same errors but still Chrome load and Vivaldi not.

    I've also tried setting up the user agent and using it as Default Chrome first, then I used the settings suggested by @Gwen-Dragon, and again nothing changed.

    Any other ideas?

    Thanks for replaying guys!


  • Moderator

    @zenotrevisan said in Salesforce (Lightining) page not working using Vivaldi:

    then I used the settings suggested by @Gwen-Dragon, and again nothing changed.

    I had tested a demo version of Salesforce admin page and it worked. The demo shop worked.

    Did you switch the extension to Chrome 72 before login at Salesforce?

    You should explain what is going wrong on the Salesforce admin page.



  • @Gwen-Dragon

    Now I tried deleting all caches, cookies and stuff, opening vivaldi (with just the user agent extension on), selecting the user agent and opening SF and still the same problem.

    To better explain what my problem is, I'll provide some screenshots:
    0_1549877974900_76440b2b-cd82-43b1-94ad-61f03176eaac-image.png

    here I was trying to change my personal settings, but the page remain blank.

    0_1549878010594_b4266998-a173-483a-bd65-dc1265fc4ea7-image.png

    Here, I was trying to modify one layout, so it should open in that blank space the layout editor


  • Moderator

    @Gwen-Dragon said in Salesforce (Lightining) page not working using Vivaldi:

    Salesforce

    may be i tested the wrong product?
    i can not find a demo page for Lightning.
    //EDIT: Tested with user in chat.
    I can conform the bug with Vivaldi in Salesforce Lightning admin pages!



  • The problem is blocked third party cookies. If you click the lock icon in the address bar for your salesforce page, select Cookies and check the Blocked tab, I think you'll find a number of salesforce domains listed. Allow them and refresh the page and Admin should work again.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.