Update 2.3 failed.



  • Today, when i updated vivaldi to 2.3 i got an error message :
    "Installation failed due to an unspecified error. If Vivaldi is running, close it and try again"

    Vivaldi wan not running during the installation.
    I tried several times (update and manual download+install) but i got the same message.


  • Moderator

    @Lisie Try opening windows task manager (Right click on the start button), and if there are any vivaldi processes running, you can stop them that way.



  • I dit it. I checked if vivaldi was runnig, during installation.
    No vivaldi process was up except the Vivaldi updater one.


  • Moderator

    ℹ Information on your issue is missing:

    1. What is your Windows version and build?
    2. What is your Vivaldi version? (via Vivaldi menu
      Help → About and first line)
    3. What extension to you have installed? (via Vivaldi menu Tools → Extensions)
    4. What security software do you have installed (Firewall, antivirus, malwarekiller, etc)


  • I did the update on my personal computer and it worked good.
    The problem is on my professionnal computer.
    Several Vivaldi update were already installed on this computer.

    Specs :

    Windows version and build? ---> 1703 build 15063.1563
    Vivaldi version? -->2.2.1388.37 (Stable channel) (32 bits)
    What extension to you have installed? Conferencing Plugin, Enpass Password Manager
    What security software do you have installed --> Windows Firewall, Trend Micro OfficeScan 12.0.5294 Pack 1


  • Moderator

    @Lisie Any log in Trend Micro OfficeScan for such a block.
    Or for the installer/updater the file vivaldi_installer.log in %TEMP% folder of your Windows?



  • I got the same bugs.

    So in first I checked the rights on vivaldi.exe and delete the 2 strange users.
    in second I turnoff windows protection
    and I reboot.

    I launched the update with the file that I downloaded on the site and it works fine !



  • @Gwen-Dragon : Thx.

    I checked the vivaldi log installer/updater in my %TEMP% folder.
    There was a permission error. Updater was not able to delete the vilvadi.exe file.
    Something obvious with my professionnal windows user.
    With a reboot and a correct login vivaldi update worked good.

    Sorry for that.


  • Moderator

    @Lisie Hmmm. may be some stricter Windows Defender setting blocking the update. But i do not know.

    Fine, you solved it.



  • Hello,
    have the same problem. Cant update to 2.3.
    Cant solve it. Can anyone exmplain it step by step?


  • Moderator

    @p2000 Restart Windows and delete the content of TEMP folder may help.



  • @Gwen-Dragon

    The TEMP Folder in WINDOWS is clean.

    In VIVALDI theres no TEMP folder. But i've tried to delte the setup File in

    VIVALDI\APPLICATION\2.2.1388.37\INSTALLER but no solution. 😕


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.