Why doesn't Vivaldi play HLS video?



  • I've tried every extension in the store, and none of them work. It just will not play. Is there any way to fix this so I don't have open Edge EVERY time I want to see an HLS video?


  • Moderator

    @fred8615 There are several previous threads on this:

    HLS Video

    I suppose nothing has changed recently.


  • Moderator

    @fred8615 We do not have much information to help you.
    We need from you about:

    • Vivaldi version (see vivaldi://version)
    • extensions in Vivaldi (see vivaldi://extensions)
    • Windows version and build
    • Graphcis hardware
    • output of section Graphics Feature Status in page vivaldi://gpu
    • security software
    • URL of video


  • @fred8615
    Not sure chromium/Vivaldi support (yet) HLS. You may try this



  • @Hadden89 Tried that one. Didn't work.

    Now for some wierdness: I tried this site without a HLS extension installed...

    https://video-dev.github.io/hls.js/demo/

    ...and it worked. But it will not work on Disney or ABC. But both Edge and Firefox will play no problem.

    Vivaldi version - 2.2.1388.37 (Stable channel) (64-bit)

    extensions in Vivaldi - Fatkun Batch Download Image, uBlock Origin, uBlock Origin Extra, Video Downloader professional. I tried disabling all the extensions and then playing the vid, but it still won't play.

    Windows version and build - Win 10 Home, 1809, 17763.253

    Graphcis hardware - Intel HD Graphics 530 (primary), Nvidia GeForce 930MX (secondary)

    output of section Graphics Feature Status in page vivaldi://gpu -

    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Out-of-process Rasterization: Disabled
    Hardware Protected Video Decode: Unavailable
    Rasterization: Hardware accelerated
    Skia Deferred Display List: Disabled
    Skia Renderer: Disabled
    Surface Control: Disabled
    Surface Synchronization: Enabled
    Video Decode: Hardware accelerated
    Viz Service Display Compositor: Disabled
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    security software - Windows Defender

    URL of video - Both Disney.com and ABC.com. They require an account, so no point in giving the exact URL.


  • Moderator

    @fred8615 may be you have some driver problem or the wrong GPU is used for the video. And some Intel and/or NVidia drivers are know as a box of bugs.

    • Do you use the latest chipset drivers from Intel webpage?
    • Do you use the latest drivers from NVidia webpage?
    • Can you disable the Intel HD Graphics or set NVida as primary GPU to see if it works with your NVidia?


  • @Gwen-Dragon

    No
    No
    Tried it, didn't work. May try the web site drivers. I've been using the Win 10 Update drivers.


  • Moderator

    @fred8615 The Windows drivers are not the latest.
    Install the latest from manufacturer.

    And try the video once more in Private Window to run with disabled extensions causing issues.



  • @Gwen-Dragon said in Why doesn't Vivaldi play HLS video?:

    @fred8615 The Windows drivers are not the latest.
    Install the latest from manufacturer.

    And try the video once more in Private Window to run with disabled extensions causing issues.

    Couldn't install the Intel 530 drivers; it kept giving a "not compatible with your OS" error. Did install the latest Nvidia 930MX drivers, set it to primary, did a reboot just to be safe, and then tried both sites again. No joy. 😥 Tried the Private Window thing too. It didn't work either. Given that both FF and Edge worked, I didn't think it was the drivers anyway.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.