Amazon Prime videos Stutter



  • Hello everyone,

    I have a strange issue where Videos on Amazon stutter every 5 to 10 seconds but only the video does not the audio.
    Youtube however works fine.

    I am running a pretty decent pc on a 100Mbit connection so that should be at no point in time any issue.

    So in order to see what the issue is i tried Internet explorer and edge where it works fine.
    Since this means it is related to Vivaldi i have cleared my cookies cache and basically everything the options allowed.
    Unfortunately this did not solve the problem.

    So i updated all drivers to the latest version.
    No improvement.

    I checked if widevine is enabled and up to date.
    That looks fine.

    Then i tried to enable/disable via vivaldi://flags the following
    -Hardware-accelerated video decode
    -Cast Streaming hardware video encoding
    Unfortunately no improvement here as well.

    I disabled all plugins - uninstalled them as well but to no avail.

    So last resort re-install Vivaldi completely.
    Sadly that didn't help either.

    Is there anything else that i could try in order to resolve this issue?

    Kind regards
    Agomy


  • Moderator

    Hi, could you give us an sample for our test.
    Note: reinstalling without deleting the previous folders usually doesn't work.



  • @lamarca Any Amazon prime video shows the exact same behavior.

    I could try and capture it but i think that won't help in finding the root cause.

    Re-installing was done with manually erasing the %appdata% folders as well before the fresh install.


  • Moderator

    @Agomy Not on Vivaldi at the moment. I will try it out as soon as the storm slows down.


  • Moderator

    Back.
    The video plays fine (https://www.amazon.com/Prime-Video/b?ie=UTF8&node=2676882011)

    Can you play the videos on the test bellow?

    https://www.quirksmode.org/html5/tests/video.html



  • Since the issue occurred with a fresh install as well and the fact that i use Vivaldi on a daily basis as wel as for work i have for now restored everything i use.

    In general i haven't noticed stutters on other platforms.
    Only Amazon appears to be having issues.

    I played the videos on https://www.quirksmode.org/html5/tests/video.html
    All videos play just fine. No stutter.
    I recorded that here: https://youtu.be/xElmFYqKhcI

    To show you the behavior on amazon i recorded it, you can see it in this video.
    https://youtu.be/RzetqlSxvDc
    (video played was Lucifer - Season 3 episode 18 which i picked at random)

    I have no idea what is causing it.


  • Moderator

    @Agomy Good one. Searching on the web, I found out some variants of Win10 doesn't come with all necessary Codecs. The user needs to install manually, not being a win user, it's risky to suggest you any package.



  • Yeah i thought of that but i am using:
    Windows 10 Pro
    Version 1809 (Build 17763.195)

    It worked in the past and i did not re-install windows in between. So it would be strange (not impossible though) for windows to remove those media packs in between versions.


  • Moderator

    Here is your best friend. I will tag the topic as resolved.



  • Ah so that is another issue that won't be acknowledged by Vivaldi.
    Just wait, get fed up that Vivaldi doesn't work properly, use a different browser.
    And if you remember that there was Vivaldi in the past and windows might have done something in order to make it work again come back to Vivaldi.

    I guess that is one way to deal with things.


  • Moderator

    @Agomy said in Amazon Prime videos Stutter:

    Ah so that is another issue that won't be acknowledged by Vivaldi.

    You may feel free to report the issue.

    Please read how to Report a bug for Vivaldi carefully and then report the bug to Vivaldi bugtracker.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.