Vivaldi crash on quit when a tab is set to never load images



  • Possible crash on quit bug in Vivaldi

    If you have one tab that is set to load images never Vivaldi will crash on quit (have sent around 7 crash reports to Apple (Vivaldi also has access to them).

    Vivaldi 2.2.1388.37
    macOS 10.14.2

    Has anyone else seen the crash? (want to see if others have more info on the crash before I file a bug report)



  • Sometimes I have ghost processes left after the crash.


  • Moderator

    @Chas4 Ghost processes? On macOS??

    Sometimes I have ghost processes left after the crash.

    If you have a recipe to reproduce this or the crash consistently, especially on a clean/default Vivaldi install, then please file a bug report.



  • @xyzzy Don't know what it is exactly but it seem to have to do with not loading images set via the button in the bottom right and then quitting without changing it back to always load images. After the crash there is not always ghost (leftover) processes. Vivaldi is not running but there are some processes left over.

    Have you tried setting Vivaldi to never load images and then exit Vivaldi?


  • Moderator

    @Chas4 I'll have to retest this. I previously did a quick test with both my usual/working install and a clean/default install in a test account but was not able to trigger a crash on my system. I've also never seen any lingering ghost processes on Mac; past bugs that caused these on Windows would result in Vivaldi remaining running (and not exiting) on macOS.



  • VB-47837
    Attached crash logs & a spindump


  • Moderator

    @Chas4 Thanks. FYI, I still can't reproduce your crash as documented... but I'm also running on an earlier release of macOS, not 10.14.2. Either that or there are other settings/extensions/missing steps-to-reproduce that are contributing factors in addition to setting Load Images to Never. It's also possible that the crash is unrelated to the Load Images setting.



  • I have tested it a few times and it happens when never load images is set when I quit Vivaldi. When I change it back to always and wait a few seconds I do not get a crash on quit.

    Vivaldi's never load images is great for reporting spam & phishing email to a few different AV vendors and governments.


  • Moderator

    @Chas4 Thanks. I'll keep trying. I've also linked this thread to the bug so that the devs and QA can also follow what we're discussing. FYI, one of your crashes (from Dec. 19) stands out in that it has a different signature from the others, and looks like a random crash-on-Quit that I reported as well that, strangely, I'm also unable to reproduce consistently.



  • /Applications/Vivaldi.app/Contents/MacOS/Vivaldi --flag-switches-begin --enable-experimental-web-platform-features --site-per-process --enable-webgl-draft-extensions --ignore-gpu-blacklist --tls13-variant=final --flag-switches-end (that can be seen on vivaldi://about/ )

    I have it set to ignore GPU backlist since for some reason the backlist disables some video & audio codecs (which makes many videos on Facebook and other places not playable).


  • Moderator

    @Chas4 As many know, I'm against changing Chromium flags from their defaults. Many flags enable experimental code that's not ready-enough for release. They also put the underlying Chromium code into a state that has not been tested by the Vivaldi team and many can seriously destabilize Vivaldi.

    I'm generally okay with enabling #ignore-gpu-blacklist to get media playback working again... but beware that you're still enabling code that the Chromium team has deemed to be problematic... and enabling additional graphics-related flags will likely cause even bigger problems.

    That said, even if I enable the flags that you have, I still can't trigger your crash on my system.

    What extensions do you have installed in Vivaldi? Does Vivaldi also crash if you create a test account on your Mac and try to trigger a crash with a default Vivaldi installation?



  • @xyzzy

    I know about the flags (I helped tested a few back in the Opera Presto days in Opera Next and Opera developer (I always keep stable and test versions of browser profiles separate))

    It is an old Chromium bug with one of the GPUs in my system (dates back to before Opera started to using Chromium), there is the integrated Intel GPU and a Nvidia GPU (Chromium has had issues with the Nvidia GPUs).

    The "site-per-process --enable-webgl-draft-extension" are ones set by Vivaldi I did not change those

    Malwarebytes Browser Extension
    Netcraft Extension
    uBlock Origin (not using all of the lists, helps on a lot of sites that have extreme bloat)
    Windows Defender Browser Protection
    WOT Web of Trust

    The constant thing with the crashes has been the use of never load images (when that is left enabled on quit that is when Vivaldi crashes). I opened Vivaldi did not change Vivaldi to never load images and quit Vivaldi and no crash.


  • Moderator

    @Chas4 That's interesting... With a clean default install, Vivaldi 2.2 does not enable any flags on my system. The only switches I have are:

    --flag-switches-begin --flag-switches-end --disable-smooth-scrolling

    (--disable-smooth-scrolling does not do anything on macOS; it's there because "Smooth Scrolling" is unchecked by default in Settings. Smooth Scrolling is always enabled on macOS regardless.)

    I also use uBlock Origin with no issues. So do many others, so this extension is known to work well with Vivaldi. Can't speak for the others. Having multiple security-related extensions and content blockers installed and active has caused issues for many, so beware of this.

    Not sure why some of your other flags are being set... possibly by one of your extensions. In Google Chrome, some flags can be enabled through Field Trials... but I think that this is disabled in Vivaldi... but I'll check to be sure.

    I wouldn't hurt to reset all flags back to their defaults just to be sure and disable all of your extensions, restart Vivaldi, then try to trigger the crash. If all works well, re-enable #ignore-gpu-blacklist and test, then try re-enabling your extensions one-by-one and test.



  • @xyzzy Might be an old Vivaldi bug as I never used the feature much till recently (have cut down on the spam email by about 70% or more and getting some of the spammers arrested with the reporting).

    I was getting the crashes before adding the
    Malwarebytes Browser Extension
    Windows Defender Browser Protection
    extensions

    I can quit Vivaldi without a crash just fine on quit if I have Vivaldi load images, but when I leave it set to never load images it crashes on quit.

    WebGL Draft Extensions & Strict site isolation only have enable or disable for the flag settings

    What macOS version are you using?

    Looks like the bug is in the WebGL Draft Extensions flag disabled that and the crash on exit stoped (tested 3 times in a row and got no crash).

    Chromium is not stable when it is using the NVIDIA GeForce GT 750M GPU (Vivaldi might hang (even the GUI might hang for a few seconds)), when on the Intel GPU it is fine. vivaldi://components Is another spot you can check and manually force an update on some of the components like Widevine, should note the Origin Trials have had a broken check for updates for about a year (Chromium (maybe server) side issue).


  • Moderator

    @Chas4 I'm very glad to hear that you successfully identified the cause of your crash! I hope it's now gone for good.

    Re: Origin Trials, I think the update for that component is intentionally non-functional.

    If Field Trials did get enabled in your installation ages ago, you should be able to clear this state by launching Vivaldi from the command line as follows:

    $ open /Applications/Vivaldi.app --args --reset-variation-state
    

    What macOS version are you using?

    For now, I'm still using El Capitan, and that's partially to make sure Vivaldi gets sufficient real-world testing on older versions of macOS.



  • @xyzzy Did just find out that the never load images does not always work.



  • My Vivaldi crashes on quit quite often too. It has nothing to do with setting a tab to never load images, but since the last stable update, it's pretty consistent.

    What's the tldr version of this thread? Sounds like maybe there is an issue with a flag somewhere?



  • @TwisterMc From what I can tell it may or may not be related to a bug with the setting for loading of images (I found out the never load images does not always work). Vivaldi has around 10 crash reports I have sent to them.


  • Moderator

    @TwisterMc This was a weird crash that I had never seen before. @Chas4 has a Mac with a GPU that was blacklisted in Chromium. He enabled #ignore-gpu-blacklist to get media playback working again in Vivaldi. #enable-webgl-draft-extensions also got enabled and (along with less-than-stable GPU acceleration) seems to have put his system into a rather unstable state and contributed to the crash.

    Not all crashes are the same and the only way to get these diagnosed and fixed is to file a bug report (with reliable steps-to-reproduce) and to attach a crash log to the bug confirmation email so that we can determine exactly where in the code that the crash occurred.



  • My experiences seem to more match another thread so I won't continue tacking my issues onto this one. https://forum.vivaldi.net/topic/32563/vivaldi-2-2-1373-4-bombs-on-every-quit/20


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.