Site settings for Flash not being saved



  • I have several sites for which I've modified the site settings. For one, I "Allow" Flash. On the other, I "Block" sound. But these settings are not saved between sessions. On a new session, they are set back to "Ask" and "Allow", respectively. Shouldn't these be saved?

    I'm running 2.1.1337.51 (Stable channel) (64-bit) on Windows 10.


    modedit added Flash to title


  • Moderator

    @Gwen-Dragon said in Allow flash permanently - preferably for an individual site.:

    Current settings in Chromium code do only save Flash settings for a session. they want to force users to leave Flash Player as such technology will be abandoned in 2020.

    But that can be solved (may chaneg in future!).
    This could work in 2.0 Stable and 2.1 Snapshot:

    • Open Vivaldi internal flags chrome://flags#enable-ephemeral-flash-permission
    • Set to Disabled
    • Restart Vivaldi

    Works in 2.1 Stable.

    Fore the very experienced users:
    @Hadden89 said in Allow flash permanently - preferably for an individual site.:

    Only way is now a policy.

    Not recommended. (messing the registry without knowledge may break the OS)

    1. winkey+R
    2. regedit.exe
    3. Navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\
    4. Create Vivaldi key
    5. Create PluginsAllowedForUrls key (under Vivaldi)
    6. Create string named 1 and use the full url site as value (eg: https://sitewithflash.com).
    7. Others will be 2, 3 ecc ecc
    8. Restart vivaldi
    9. Should be saved as policy, now.
    10. Will survive until chromium keep the policy.


  • Thanks! The internal flags method seems to work.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.