Cannot access Gmail in general


  • Moderator

    @freekarol No chance to do this.



  • Hello,

    Since today, for a reason I don't understand, I cannot connect to my gmail mailbox. I just deleted an email from my mailbox and tried to switch to another account I have logged into with this browser, and since then whenever I try to access my mailbox, I get the "Too many redirects" error :

    Cette page ne fonctionne pas
    accounts.google.com vous a redirigΓ© Γ  de trop nombreuses reprises.
    Essayer de supprimer les cookies..
    ERR_TOO_MANY_REDIRECTS

    As suggested, I deleted all my cookies, logged in again, and got the exact same error once I validated my 2FA...

    Has it happened to anyone ? I really cannot use a browser which does not allow me to check my mail πŸ˜•

    For information, I can log in without any issue on the same computer using Falkon, and I am using vivaldi-stable-2.2.1388.34-1.x86_64 on Fedora rawhide


  • Moderator

    @Moussx Merged with existing thread.

    It seems to affect users on different platforms.



  • Yes, thanks for doing this.

    I can confirm that adding
    [*.]google.fr
    [*.]google.com

    on authorized domains after going to chrome://settings/content/cookies (which got converted to vivaldi://settings/content/cookies in my address bar now) allows me to connect to my mailbox again. No idea why/how it works, I'm just confirming that the workaround works for me.



  • Someone suggested that extensions that block content can cause this, I disabled Ghostery when this happened again and it did NOT fix it; just wanted to put that information out there.



  • How can I fix it? 😞

    0_1545424560071_redirect.png



  • @PardusPars If I understand it's the same as this topic (link redirects to the best solution), as you can read there the easiest is enabling 3rd party cookies (not the best in my opinion).

    Edit: after moving these posts I can say the solution is also in this topic.


  • Moderator

    @potmeklecbohdan I moved the post by @PardusPars and your reply to the relevant topic.

    I have no problem with Gmail, whether I block third-party cookies or not.

    The issue still seems to affect some users. If there are any solutions, this thread is the right place to look for them.



  • Be glad you don't need to access Hotmail on a regular basis 😠

    Good ol' Opera had site settings, and you could choose to accept third-party cookies for a specific site only. You could also set Opera to prompt whenever a site asked to set a cookie, which was a huge help for figuring out redirect stuff like this.

    I have something similar in Firefox with the Cookie Monster addon.

    Back in the Opera days cookies were never such a big privacy invasion as they are today, they were mostly used for logins and shopping carts, which is fair enough. Only the huge sites like Amazon used something like 'tracking' cookies. These days it seems every site you visit wants to sell your information on to third-parties, and it is strange we as users do not have the tools to control it ourselves like we did in Opera.

    Maybe it's because most users don't even know what cookies are, or care what they actually do, they just want stuff to work. But thankfully Vivaldi users are not like that, at least I hope so 😏



  • This is a relatively new issue. It is still occurring on Version 2.2.1388.37 (Stable channel) (64-bit) Running on Windows 10 Pro Version 1809 OS Build 17763.195. I should not be required to enable 3rd party cookies. It does not occur in IE or Chrome.

    When will; this be resolved?



  • I have no trouble to use Gmail with Vivaldi. I only accept cookies from the domains google.com and my country-specific google.no .

    I do no accept third-party cookies. It should not be necessary to do so.

    Are you able to use the other Google services (calendar/docs/drive etc)?

    Using: 2.3.1401.7 (Official Build) (32-bit)
    Also on Windows 10 Pro



  • @HyperPete It's helpful if you mention the OS used when you encountered this issue.

    I often test & track the same issue in both Windows 10Pro and Linux Mint 19. After encountering this issue, I simply gave in. My time is worth more than being spent on hunting down and testing various solutions. There is a point at which resistance becomes futile. So, I allow 3rd party cookies from visited sites and block those that are not.

    I do this because I really don't care whether I end up (or not) in someone's consumer research database for targeted advertising . I like to see and laugh at how inaccurate they are. But then, this is really a personal choice.



  • @ineuw Yes, I updated my post with OS info immediately after posting. I have slapped my wrist for a foolish oversight!



  • @Pathduck said in Cannot access Gmail in general:

    I have no trouble to use Gmail with Vivaldi. I only accept cookies from the domains google.com and my country-specific google.no .

    I do no accept third-party cookies. It should not be necessary to do so.

    Are you able to use the other Google services (calendar/docs/drive etc)?

    Using: 2.3.1401.7 (Official Build) (32-bit)
    Also on Windows 10 Pro

    No, when this occurs I am unable to login to any Google site. Deleting cookies does not fix it, the only solution I have found is to clear history, close Vivaldi, and reopen it. Once I do this I can log in. It really stinks because, other than this issue with Google, I LOVE Vivaldi. I do not want to have to use another browser, but if it's not resolved, I may have to go back to Firefox. 😞


  • Moderator

    @HyperPete It is very hard to fix bugs that cannot be reproduced. I have tried all sorts of combinations of deleting cookies, blocking third-party cookies, or not, and I can still log into my Gmail account every time.

    Tip: A quick way to restart Vivaldi is to type vivaldi://restart in the Address Field, and press Enter. Be aware that any changes to preferences are not saved if you take this quick route. To do that, exit in the usual way from the File menu or the Close button.



  • @Pesala - Thank you for the reply. I will try disabling all extensions to see if it is extension-related. I have removed the third party cookie blocking and now save cookies for a day. I don't like this option, but for now, it appears to be working.



  • Gmail is having authentication problems. Some features may not work. Try logging in to fix the problem.

    Getting this message consistently... Don't know if it's already been reported, but it didn't come up in a search...



  • Turning off Block third party cookies allows Gmail to load. Interestingly enough all other services load just fine including inbox.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.