Can't allow notifications from sites in incognito



  • When trying to allow a webpage to show notifications in an incognito window I keep getting the problem that I can't press okay/yes/allow on the balloon top right. As you can see in the video below, I have all the right links set up for it to work, but it just doesn't.
    When I added the links for 4chan and 4channel myself it started adding a 'Current incognito Session' link that is the same as the 4chan links I have inserted myself. And it starts that one out as blocked, even though the same link is already in the allowed list.
    link to gifv on imgur

    I see multiple solutions

    • Make the balloon work
    • When there is a link in the allowed section, don't insert a identical link to the blocked section
    • When the user set's the link from 'Current incognito Session' to allowed, remember/don't delete.

    ow yeah: version screen:

    Vivaldi 2.1.1337.51 (Stable channel) (64-bit)
    Revision 73e8a741402d9589f3249582d24e5c2da63f1880-refs/branch-heads/3538@{#1097}
    OS Windows
    JavaScript V8 7.0.276.42
    Flash (Disabled)
    User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.113 Safari/537.36 Vivaldi/2.1.1337.51
    Command Line "C:\Program Files\Vivaldi\Application\vivaldi.exe" --flag-switches-begin --flag-switches-end --disable-smooth-scrolling
    Executable Path C:\Program Files\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\User\AppData\Local\Vivaldi\User Data\Default


  • Moderator

    That was a known issue in older Vivaldi.



  • Good and bad to hear. Do you mind linking me to a bug tracker or something like that that this is on? I couldn't find any.


  • Moderator

    @matjojo Bugtracker is internal.

    But you can report your issue.
    Please read how to Report a bug for Vivaldi carefully and then report the bug to Vivaldi bugtracker.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.