Memory hog



  • I recently stopped using Vivaldi because of memory issues.

    I have 16gb of RAM and with Vivaldi and Word open my PC was using 85%+ of memory. And programs kept going unresponsive.

    I'm now back to using Chrome and it is using less than 30% memory in the same situation and my programs don't become unresponsive anymore.

    I really like Vivaldi but unless they fix their memory issue it is useless.


  • Moderator

    @ieuanw Not much anyone can do with such a report.

    See this earlier thread and provide more information if you want to try to diagnose the cause of your problem.



  • @ieuanw
    Hi and welcome (hoping you still read this and your post was not a goodbye post), as pesala already mentioned to fix the problem we need more information, otherwise it will be impossible to fix this as this is not a too common problem.
    For instance atm I use 19 tabs and two extensions while Vivaldi is consuming only about 30% of my 4gb ram, so there really is a need to get to know your system and your setup a bit better.

    1.) What windows version do you use?
    2.) What Graphic card do you use?
    3.) What Vivaldi version do you use? (you can look this up at vivladi://about) [I hope you didn't already uninstalled it^^]
    4.) What extensions do you use?
    5.) Please open up vivaldis own taskmanager and provide a screenshot of it while the ram consumption is spiking.

    • you can find the taskmanager via "Shift+Esc" or Menu --> Tools --> Taskmanager

    Especially the last point should help to have a better insight what is eating up your ram

    EDIT: In addition I like to say that I appreciate that you created an account and let us know about the problem - but it would've been easier for us and probably less nerve-wrecking for you if you did this earlier before you lost your patience with vivaldi. Of course we can't guarantee you that we'll find a solution but together there is a way bigger chance for this ; )



  • @ieuanw

    1. Are you using the "Hibernate Background Tabs" function? Can reduce memory usage.
      Right click on a tab and you'll see.
      BTW - I have found that most browsers have memory creep which can be exacerbated by certain websites and/or having too many tabs loaded into memory.
    2. When the creep is too great, try closing Vivaldi and then re-opening. You'll get a memory reset.
    3. You can save Vivaldi sessions (File -- Save ...) May be helpful at times.
    4. Eliminate your running processes to free-up RAM.
      I have half the memory that you have and can run Vivaldi with many other programs open, and I rarely get to 50% RAM usage. Typically, I have ~73 base processes running on a Win7 Pro machine with no programs open. I use autoruns to control my base start-up processes. Be careful in using this.

    Hope this helps.



  • @zaibon said in Memory hog:

    @ieuanw
    Hi and welcome (hoping you still read this and your post was not a goodbye post), as pesala already mentioned to fix the problem we need more information, otherwise it will be impossible to fix this as this is not a too common problem.
    For instance atm I use 19 tabs and two extensions while Vivaldi is consuming only about 30% of my 4gb ram, so there really is a need to get to know your system and your setup a bit better.

    1.) What windows version do you use?

    Windows 10 Professional

    2.) What Graphic card do you use?

    AMD Radeon R5

    3.) What Vivaldi version do you use? (you can look this up at vivladi://about) [I hope you didn't already uninstalled it^^]

    Version 2.1.1337.51 (Stable channel) (64-bit)

    4.) What extensions do you use?

    None, yet.

    5.) Please open up vivaldis own taskmanager and provide a screenshot of it while the ram consumption is spiking.

    • you can find the taskmanager via "Shift+Esc" or Menu --> Tools --> Taskmanager

    Especially the last point should help to have a better insight what is eating up your ram

    EDIT: In addition I like to say that I appreciate that you created an account and let us know about the problem - but it would've been easier for us and probably less nerve-wrecking for you if you did this earlier before you lost your patience with vivaldi. Of course we can't guarantee you that we'll find a solution but together there is a way bigger chance for this ; )

    0_1544216999732_2018-12-07.0001.png

    To give you a screenshot of Vivaldi's task manager will take more than one screenshot, but I'd be happy to.

    5_1544217764753_2018-12-07.0007.png 4_1544217764753_2018-12-07.0006.png 3_1544217764752_2018-12-07.0005.png 2_1544217764752_2018-12-07.0004.png 1_1544217764752_2018-12-07.0003.png 0_1544217764750_2018-12-07.0002.png

    I'm not the original poster, but I came upon this thread searching for a way to tame memory useage, and thought I'd chime in with the information you're asking for. I'm on a fresh install, I just installed it last night.



  • @beansandfranks said in Memory hog:

    @ieuanw

    1. Are you using the "Hibernate Background Tabs" function? Can reduce memory usage.
      Right click on a tab and you'll see.
      BTW - I have found that most browsers have memory creep which can be exacerbated by certain websites and/or having too many tabs loaded into memory.
    2. When the creep is too great, try closing Vivaldi and then re-opening. You'll get a memory reset.
    3. You can save Vivaldi sessions (File -- Save ...) May be helpful at times.
    4. Eliminate your running processes to free-up RAM.
      I have half the memory that you have and can run Vivaldi with many other programs open, and I rarely get to 50% RAM usage. Typically, I have ~73 base processes running on a Win7 Pro machine with no programs open. I use autoruns to control my base start-up processes. Be careful in using this.

    Hope this helps.

    Thanks for the tip! I'm going to try the setting you suggested.



  • @beansandfranks said in Memory hog:

    @ieuanw

    1. Are you using the "Hibernate Background Tabs" function? Can reduce memory usage.
      Right click on a tab and you'll see.
      BTW - I have found that most browsers have memory creep which can be exacerbated by certain websites and/or having too many tabs loaded into memory.
    2. When the creep is too great, try closing Vivaldi and then re-opening. You'll get a memory reset.
    3. You can save Vivaldi sessions (File -- Save ...) May be helpful at times.
    4. Eliminate your running processes to free-up RAM.
      I have half the memory that you have and can run Vivaldi with many other programs open, and I rarely get to 50% RAM usage. Typically, I have ~73 base processes running on a Win7 Pro machine with no programs open. I use autoruns to control my base start-up processes. Be careful in using this.

    Hope this helps.

    Hibernating background tabs looks like it made a huge difference! It cut my memory useage by nearly half. Thanks!


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.