Disable Forward/Back nagivation by mouse clicking gesture



  • It took me a while to realize what was going on, but it seems there is a feature in Vivaldi that allows you to go back and forth between pages in the history stack by doing a fast right-left or left-right click of the mouse. I have a bad habit of flapping my context menu on and off by doing this same type of gesture. Is there a way to disable that feature? I couldn't find it in settings. I should also mention: [code] [~] vivaldi --version Vivaldi 41.0.2272.106 [/code]


  • Moderator

    "I should also mention:
    [~] vivaldi –version
    Vivaldi 41.0.2272.106"

    That's the Chrome version on which vivaldi is built, rather than the Vivaldi version. Your Vivaldi version is available at the Help/About window, and will start with 1.0.xxx with the value for xxx being between 140 and 180 or so.



  • Ah, I see. Here is the correct version in the event that it is useful: 1.0.162.9


  • Moderator

    @woodsatchel:

    Ah, I see. Here is the correct version in the event that it is useful: 1.0.162.9

    OK. More shortcut options are available in the latest version, 1.0.178.2, which is available at the Vivaldi Team Blog:

    https://vivaldi.net/en-US/blogs/teamblog

    Other than that, I could not say HOW it might be possible to disable the "flip" shortcut for forward and back.



  • I've looked about as far as my looker can look in 1.0.178.2, but I can't find what I'm looking for. Lots of keyboard shortcuts (nice!!) but no rebindable mouse gestures.

    There are several more unexpected features I've found as well, such as "right click and drag down" opens up a new tab. I am not opposed to these rather unique and interesting mouse gestures, so it would be great if they were rebindable the same way all of the keyboard shortcuts are.

    I really like the way this browser is coming along.

     yum remove firefox 
    

  • Moderator

    Next version will probably come with option to disable rocker gestures, which is the name of the feature you're trying to disable.



  • Cool, good to hear!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.