Annoying bug inherited from Chrome(ium)



  • Here's hoping Vivaldi is more receptive to fixing this highly annoying bug than Google... (https://code.google.com/p/chromium/issues/detail?id=12106) Basically for some reason the browser (when maximized) will appear over the taskbar, as if it's window has set the 'always on top' flag. If one has the taskbar set to auto-hide, this makes it impossible to invoke the taskbar with the mouse. In older versions of Windows, one could open the taskbar via other means, then toggle the 'show taskbar on top of other windows' setting off and back on, but this was removed with Windows 8. It seems to happen when a new tab is created, but it's somewhat inconsistent. It always ends up happening somewhat quickly however, and it extremely annoying. You can tell for sure that it has happened, by using the winkey + T combo to summon the taskbar, then click back on the Vivaldi window. Instead of the taskbar sinking back down to it's hidden state like normal, it instantly disappears when Vivaldi takes focus. On Chrome or Chromium Opera, you can unmaximize the browser window and remaximize it and that will usually fix it, but on Vivaldi it doesn't seem to help.



  • And this is what I get for posting this before fully digging through Vivaldi's settings. Apparently disabling the 'Native Window' setting fixes it.

    Yaay!



  • Behavior already discussed that affects mainly win 10.

    In win 10 there's a working workaround

    Just open regedit to the key

    HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics\PaddedBorderWidth

    and set it to 0 (zero), and reboot. (The stock value for win 10 is -60)

    So just look at what you have in win 8.1 and try this fix.


  • Moderator

    Mine is set to zero, but I never changed it. Would like to know SuperSpy's value.



  • @An_dz:

    Mine is set to zero, but I never changed it. Would like to know SuperSpy's value.

    Just checked my 8.1 and was set to -60 like win 10.

    Likely it depends if it's a clean install or an upgrade.

    Whatever… setting it to 0 solves the problem, which isn't limited just to Vivaldi.

    Even windows itself shows some glitches with -60 (for example look carefully at the mouse cursor while resize a windows)



  • According to guys over at Chromium's bug tracker, it's fixed in 10122. Can't tell though since I changed it to 0 manually before like I was used to do… ^^



  • [mod edit] Don't hijack posts, please!



  • @Christoph142:

    According to guys over at Chromium's bug tracker, it's fixed in 10122. Can't tell though since I changed it to 0 manually before like I was used to do… ^^

    I confirm.

    In 10122 the registry value is set to -60 but Vivaldi works as expected. (and the other affected apps too)


  • Moderator

    @The_Solutor:

    Likely it depends if it's a clean install or an upgrade.

    It's a clean install. Show me where's your God now. :silly:

    Maybe I changed it a long time ago for another reason.



  • @An_dz:

    @The_Solutor:

    Likely it depends if it's a clean install or an upgrade.

    It's a clean install. Show me where's your God now. :silly:

    Maybe I changed it a long time ago for another reason.

    There is another variable the ISO level.

    There isn't just an ISO of win 8.1, there are many,as MS started to release a new ISO every few months to keep them updated and reduce the traffic from WU servers.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.