Allow flash permanently - preferably for an individual site.



  • Hey guys. I have been finding lots of documentation for this issue, but it appears to be outdated as menu options that are shown in screenshots are missing, and I don't seem to see anything saying why my settings are being lost after restart of the application.

    What I'm trying to do is to permanently allow flash for a site that I have load in a web panel. Each day, I have to copy the web panel address, paste it in a new tab, load the site, click the secure connection emblem, and change the Flash Plugin from Ask (default) to Allow, then re-open the web panel, and hit the home button once more.

    Obviously, I would like to reduce the time this task takes each day, so I have been looking into allowing this setting permanently. One site I have found describes a Plugin Setting for Vivaldi 1.8 under Webpages > Plugins > Flash Plugin, but I do not appear to have this setting, which I am assuming is to do with the version difference, since I am on the current release of Vivaldi 2.0. Also, this solution appears to be for browser-wide, which I would not prefer.

    Another site refers me to visit vivaldi://settings/content/flash , which I have done. Here, I am met with the following screen. 0_1539760894781_2018-10-17 03_19_38-Settings - Vivaldi.png
    Here, I can see a clear indication to change settings that will/may not be kept after browser restart. I do not thing this is ideal, but perhaps the "Block" and "Allow" sections are not impacted by this rule. However, I do not see any way to add sites to this field. When I change the toggle on Ask first (recommended), nothing changes on the UI to allow me to add the exceptions here.

    Lastly, I have tried (in my original attempt) to modify the setting for what appears to be the site-specific configuration page. To be clear, navigated to the url I wish to modify, click the secure connection emblem, Site Settings, locate the Flash plugin, and change the setting from Ask (default) to Allow. Again, the problem after making this change is that the setting is reverted after rebooting the application.

    Finally, I will note that when I make the last change mentioned, I do see the change show up on the secure connection emblem, as well as in the vivaldi://settings/content/flash page, which I'll apologize I cannot show you a screenshot due to the domain being a company resource.

    Hopefully I'm just doing something wrong, but can anyone help me along with this issue?


  • Moderator

    Current settings in Chromium code do only save Flash settings for a session. they want to force users to leave Flash Player as such technology will be abandoned in 2020.

    But that can be solved (may chaneg in future!).
    This could work in 2.0 Stable and 2.1 Snapshot:

    • Open Vivaldi internal flags chrome://flags#enable-ephemeral-flash-permission
    • Set to Disabled
    • Restart Vivaldi


  • @gwen-dragon

    Thank you for the quick reply.

    the url did not take me directly to the appropriate setting, but I have located the setting labeled "Enable Ephemeral Flash Permissions" and set it to Disabled. Per the description, this will allow permanence for flash settings between active browser/application settings. I restarted my browser to apply the setting, then allowed flash for only 1 site, then restarted the browser again to test, and this appears to be the fix. I have uploaded a screenshot as well to assist others in finding and setting this setting appropriately in the future.

    0_1539763328078_2018-10-17 03_57_35-vivaldi___flags_#enable-ephemeral-flash-permission - Vivaldi.png

    Again, thank you so much for your assistance. I believe this thread can be resolved.

    P.S. I do also hope that my company can migrate this tool off of a flash-based architecture sooner than later, but I'll keep my fingers crossed that the browser continues to fulfill my needs in the meantime.

    To add some additional meta to the thread:
    Vivaldi version 2.0.1309.37 (Stable channel) (32-bit)
    Adobe Flash Player 31 PPAPI


  • Moderator

    @penguinairlines said in Allow flash permanently - preferably for an individual site.:

    the url did not take me directly to the appropriate setting

    I think the internal link in flags page was wrong, i removed a slash and now the link should work. I edited my post.

    Again, thank you so much for your assistance.

    Ah, it works for you? Fine.

    I believe this thread can be resolved

    You can tag it as Resolved
    Go to your first post
    Hit the 3-dot-button below post
    Select Edit
    In tag field below textarea enter resolved
    Submit edited post



  • @gwen-dragon

    Thank you once again to assist me with the functions of this forum. I truly appreciate your assistance.



  • Hi,

    does anybody have an idea where to find the aforementioned flag

    chrome://flags#enable-ephemeral-flash-permission

    in Vivaldi's lastest snapshot 2.2.1360.4 (Official Build) (64-Bit), running on Win7/64 ?

    Thanks 🙂



  • @rogerwilco it's gone, removed from Chromium. Learn to live without Flash, it's gone already and they don't want you to have anything to do with it anymore.
    We already commented about it in the snapshot comments 🙂
    https://forum.vivaldi.net/topic/32022/better-widevine-eme-support-for-linux-vivaldi-browser-snapshot-1360-4/23?page=2


  • Moderator

    @rogerwilco said in Allow flash permanently - preferably for an individual site.:

    chrome://flags#enable-ephemeral-flash-permission

    It is in Chromium 71.0.3576.0 and 72.0.3608.0, but not in Vivaldi 2.2.1360.4 (=Chrome 71.0.3578.27)



  • @gwen-dragon said in Allow flash permanently - preferably for an individual site.:

    It is in Chromium 71.0.3576.0 and 72.0.3608.0, but not in Vivaldi 2.2.1360.4 (=Chrome 71.0.3578.27)

    Awkard. Well, will disappear soon however.
    My - probably old - canary (72.0.3607.0) hasn't -- and neither 71.0.3578.44 (beta).



  • @rogerwilco Is gone (in vivaldi at least)
    Only way is now a policy.

    Not recommended. (messing the registry without knowledge may break the OS)

    1. winkey+R
    2. regedit.exe
    3. Navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\
    4. Create Vivaldi key
    5. Create PluginsAllowedForUrls key (under Vivaldi)
    6. Create string named 1 and use the full url site as value (eg: https://sitewithflash.com).
    7. Others will be 2, 3 ecc ecc
    8. Restart vivaldi
    9. Should be saved as policy, now.
    10. Will survive until chromium keep the policy.


  • @iAN-CooG: that fatalistic approach may be working for you but I guess you will have to accept that this does not work for all users. I am no particular fan of Adobe Flash either but the reality out there is that in some cases it is in fact necessary. However, thanks for your invested time and sharing your personal view.

    @Gwen-Dragon: Thank you for confirming that it had been removed in this latest update. <dang>

    @Hadden89: Thanks a bunch for the regkey - which are no mistery to me. Either through regedit directly or via reg-file to be installed/extend those keys; I assume the latter will win in the long run, being more convenient, although that is most likely - as everything - subjective.

    You don't happen to know how this would be done on Linux as well?

    P.S.: Yes, iAN-CooG, I will use the forum's search function more thoroughly ;-). No offence.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.