Minor update (2) for Vivaldi 2.0

  • @xyzzy Thanks for the fast response. I do NOT use Sync... so that cannot be a factor. As i said, i manually delete those damn google ones, i also add them to the blocked cookies list. Yet after relaunching either of my V's, per my pics above, they have returned.

  • @steffie
    This screenshot was taken after I have closed all tabs that use google services and restarted the browser with the setting "empty cookies (apart from some whitelisted) on exit":


    As you can see there is no more google-ish stuff inside.

    Works for me if I:

    • close all pages that use e.g. the google services such as fonts or analytics or adwords or apis and empty the cookies.
    • block all google related cookies.
    • empty all cookies on exit as long as I don't have a page open that uses google services (if I don't block them, that is)

    Every measure from above works on its own. For me it is fixed.

    Of course it can't work if you:

    • still have pages from the last session that use any google services - which are almost all bigger sites ITW nowadays
    • don't block the scripts on pages that insert google IFRAMES, which of course set their cookies again as soon as the tab is activated
    • have a panel that contains such stuff
    • use extensions that load google fonts or apis, or connect to anylytics.

  • @quhno Many thanks for testing, then posting your results. I can confirm that if i disable all my extensions, explicitly block all those google cookies, manually clear all current non-whitelisted cookies, then restart Stable, initially there's no google cookies show up in the filtered list. However, within a minute max of browsing my regular sites then rechecking, several of the google cookies have returned. So much for blocking.

    Given that i do not shutdown my pc each night but merely suspend/sleep it, & V [+ my other daily pgms] remain open prior to sleep, the practical upshot is that several days easily elapse where these re-re-re-reborn google cookies exist.

    Given that i rely heavily on my suite of extensions, & given the practical ineffectiveness re google cookies per above even with all extensions disabled anyway, i re-enabled them all but one by one, having first [again] manually cleared all google cookies, & carefully rechecked the cookies status after each extension was re-enabled. I found the following strong associations; take note of the 2nd one, which IMO is deeply deeply ironic:



    I've now replaced VCM with Cookie AutoDelete, but it also is unable to control those rotten google cookies. It has a benefit though of being able to intelligently do what its name says, at intervals i specify [42"], apart from those i whitelist. So that keeps all other cookies under control wrt my as-mentioned uptimes typically of many many days but the google ones are hopeless still.

    I wrote above of tonight's testing with Stable, but the same applies to my Snapshot. I've pretty much given up...

  • @steffie Guess which extension will be the first to set a cookie for either analytics or the extension updater again 😉
    The reason why mine don't is because I have either written my own, or removed that crap, or got mine from people (not companies) I know and trust.

    Other than that: I have those 2 domains in my HOSTS since ages. is such a nice address for them to resolve ( of course too, but I have something listening on that) because I really don't need them, I am not planning to visit them in the next 10 years or so 😃

  • @ruario I cannot open Vivaldi at all now after yesterday's update. Even with a full shutdown and restart. Back to Chrome?

  • Moderator

    @atozstamps Did you try uninstalling and going back to the previous Vivaldi 2.0 build? The Vivaldi team has suspended updates and has now made the previous version (2.0.1309.37) available again on the main download page: https://vivaldi.com/download/

    Edit: A new Vivaldi 2.0 update has now been released: https://vivaldi.com/blog/minor-update-3-for-vivaldi-2-0/

  • Moderator

    If you have issues with a crahsing 2.0......40, please uninstall it, download the previous 2.0.......37 from archive at vivaldi.com/download/archive/ and install it.

    Please feel free to ask in case of answers or trouble while installing.

  • @xyzzy: New to Vivaldi and just found this answer. Thank you for the clear and thorough explanation! I'd read quite a few pages before finding your response and finally feel like I understand what's happening. Cheers!


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.