Snapshot 1.0.174.8-1 Startup settings and tab-switching performance Featured


  • Vivaldi Team

    Hey, One of the popular requests we have focused a bit on in this build is Startup settings. You now have 3 options for startup: Continue from last time, start with Homepage and start with Speed Dial. More option will be added later in coming builds. Another activity that is going on speed optimization. We are rewriting some code to optimize UI performance. Tabs have gotten some attention this week. Switching between tabs should be faster in some cases. Please look out for bugs here as this is still work in progress. https://vivaldi.net/en-US/blogs/teamblog/item/29-snapshot-1-0-174-8-1-startup-settings-and-tab-switching-performance //Christian - Vivaldi Technologies



  • I set it to startup with the speed dial

    I maximized the browser, then relaunched it from my Opera menu shortcut to open the current page in Vivaldi. It opened the page and the speed dial as expected, but it was not maximized, but in a half sized window.

    I get the same result if launching it from Windows Explorer by double-clicking in Vivaldi.exe.

    If I change the settings back to what they were, start from last time, it starts maximised, but the current page is not opened in Vivaldi. So two (new?) bugs here I think.

    Start with Home Page also opens in half a window.



  • I still seem unabel to add a New folder to the bookmarks;
    Is there a Trick? ;)


  • Moderator

    @Mercant:

    I still seem unabel to add a New folder to the bookmarks;
    Is there a Trick? ;)

    Works for me (most of the time). How are you trying to do it? When I want a new folder, I open the folder I want it in, in the side panel, then click on the "new folder" icon, then fill in the name I want the folder to have (in the edit dialog that opens automatically), and then I click on the little blue "edit" pen at the top to turn of editing, and there is my new folder with its new title at the top of the folder I created it in.



  • @Mercant:

    I still seem unabel to add a New folder to the bookmarks;
    Is there a Trick? ;)

    It's possible, but very buggy.

    1. Select a folder in which you wish to add a subfolder
    2. Click the new folder button and type the name slowly as letters sometimes get eaten otherwise.
    3. Drag the new folder to the root if that's where you want it.



  • I am losing tabs here. Happens with both vertical and horizontal tabs. Everything is OK in the beginning, but after a few minutes the tabs start disappearing. If I select a "lost tab" from the Window menu, it will be displayed, but another tab disappears instead! Thumbs for remaining tabs will also be wrong.
    However, after a while all(!) tabs are gone.

    Example (vertical tabs):

    [attachment=1227]VivaldiMissingTab.png[/attachment]

    Win7x64 Vivaldi 32bit

    Sorry, I will go back to previous snapshot.
    EDIT: Couldn't. Uninstall does not work …

    EDIT2: So I ended up doing a clean install (wiped out all the old stuff …), and everything seems to work fine :)
    Attachments:



  • Win7x64 Vivaldi 32bit
    Many bugs with tabs d&d again.

    !



  • The "Neuer Ordner" ( new folder using german loclisation" click does NOT open an box i could slowly type in,..?

    i have a rather large Bookmark collection rescued From opera maybe Thats why?



  • I like the fact that I can now have Vivaldi start from where it left off, with a home page or with the speed dials but in the case of the latter two options I don't like that my pinned tabs are deleted. Can a "Keep pinned tabs" option please be provided.



  • I downloaded 1.0.174.8 a couple of days ago (as soon as it was ready!). So far, it is an improvement over 1.0.167.2. I complained a lot about that one in its release thread, and some of the problems I reported there are solved.

    A couple of things.

    First, if I have two or more tabs open and close all but the first one. the first tab gives me a blank screen, and I cannot refresh it. I have found that if I go back to the first tab and open it, then close the second tab by clicking on the X, it works okay. But if I close the second tab and have only the first tab open, I see nothing. I have to open a "new" second tab, then go back to the first tab. Then the first tab is OK, and I can see the page. This isn't a show-stopper, but it's strange.

    Second, if I go between tabs, sometimes a cursor ends up in the address bar. And I think, if I press the arrow key or some other keys (maybe even some shortcut keys; I don't have them memorized yet!), that causes the "ghost search field" that I was complaining about in the other thread (and two or three other people also reported). I can't find a pattern to when the cursor goes to the address bar and when it doesn't. Maybe somewhere in the code, Vivaldi is getting different messages about where to put the cursor? I don't know.

    Anyway, 1.0.174.8 is still not very fast on some pages, and there are still bugs. But I am loving the design, and I think you are on the way to having a good beta! Also, thank you for letting us set Speed Dial as home page if we want :) .



  • @Pesala:

    I set it to startup with the speed dial

    I maximized the browser, then relaunched it from my Opera menu shortcut to open the current page in Vivaldi. It opened the page and the speed dial as expected, but it was not maximized, but in a half sized window.

    I get the same result if launching it from Windows Explorer by double-clicking in Vivaldi.exe.

    If I change the settings back to what they were, start from last time, it starts maximised, but the current page is not opened in Vivaldi. So two (new?) bugs here I think.

    Start with Home Page also opens in half a window.

    I can confirm this. Not only the window that starts small and not maximized, but the left panel starts opened and I have it to be closed. So it seems like the browser is not recording the exact state we left it if we set it to start from the Speed Dial or Home Page.


  • Moderator

    Confirm this.



  • I mostly open websites in Vivaldi from Opera(12) with a right-click and open with. With the newest snapshot I have to do it twice: first Vivaldi opens (with the set of old tabs) but not with the new website. Second time opens the website. Is this a known bug?


  • Moderator

    Yes, it is. :)



  • Appear to be a bug with the installer, since not allow me to install for all users, only per user. Also uninstall not works, I'm need to reinstall the TP3 on top of this snapshot to fix it.



  • i think theres some problem in tab switching with CTRL+2 for example it switches on first tab not second



  • Fix the tabs hiding or implement a tab list like NEW Opera has


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.