Open URL in full screen?



  • As the subject line indicates. Can one or not? Ctrl-l does not work. One certainly should be able to however :)



  • F11?



  • @gdveggie:

    F11?

    Brings you back in windowed mode where you will then have to press Ctrl-l. Works, of course, but still a bit inconvenient.



  • Sorry, I guess I don't understand your point about Ctrl+I. I never really use full-screen, but F11 is the standard default toggle shortcut in many Windows applications, as it is in Vivaldi (F11 to full-screen, then F11 back to normal).

    You can set Ctrl+I in Vivaldi shortcut settings if that is what you prefer.



  • OK, more in detail. I create new tabs a lot. Usually I'll simply start typing a search which will then be handled by google (which is the standard action when typing stuff into the URL bar). In windowed mode the URL bar gets the input focus if I type either Ctrl-t (create new tab) or Ctrl-l (focus URL bar in current tab). So I can start typing my search or an URL right away.

    As I understand, this is now only possible in windowed mode. In full screen mode, Ctrl-l does nothing, Ctrl-t opens a new tab, but I have no way to enter anything into the URL bar unless I switch back to windowed mode.

    This Ctrl-l/Ctrl-t thing allows you to be really fast once you've got used to it. It would be nice being able to work like this in full screen mode, too.



  • Ahh. OK, gotcha! And I take it that feature is available in some other browsers?

    …Although trying it right now, I don't seem to be able to get the "Ctrl+I (focus URL bar in current tab)" behavior you're describing even in windowed Vivaldi TP3 or Opera 12.16.

    I know there have been numerous requests for other shortcut/address bar functions, most notably "paste and go" (Ctrl+Shift+V IIRC), that are not yet available in Vivaldi.


  • Moderator

    In Presto Opera F8 is the key to send focus to URL field. Never heard about Ctrl+I before, which browser has that shortcut?

    You may try using the Quick Commands (F2) to enter an address. I can't test because the Quick Commands doesn't work here.



  • Ctrl-l is the shortcut that chrome and firefox use on Linux and Windows. On Mac it's Cmd-l (it's a lower-case 'L' by the way!).



  • @mbert:

    (it's a lower-case 'L' by the way!).

    Ah-hah! That's it. Yes that works to focus address bar for me now (but like you said, not in full-screen.).

    But if the other tabs are already open, F2 (Show Quick Commands) does allow selection of a different tab while in full screen. And (as An_dz suggested) if I hit F2 and just start typing, the filtering quickly eliminates most items in the F2 Quick Commands list and Google Search (or other default provider) for the typed word/phrase is at or near the top of the remaining list. If it is a new search term it will usually be highlighted at the top of the list and I can just hit Return and the Google search is initiated. If I have previously searched for the same or similar terms, it may stay at number 2 or 3 in the list and need to be selected to initiate the search.

    How does that work at your end?



  • @gdveggie:

    If it is a new search term it will usually be highlighted at the top of the list and I can just hit Return and the Google search is initiated. If I have previously searched for the same or similar terms, it may stay at number 2 or 3 in the list and need to be selected to initiate the search.

    How does that work at your end?

    That looks very nice, thank you. I had not noticed that I can do something like this.

    I'll have to see if it can replace my good old Ctrl-l shortcut. So far I would have used it for either searching or entering an URL which the browser than would autocomplete. As I see this does not seem work with F2, it will just trigger a google search if my input does not match an already open page.



  • @mbert:

    …this does not seem work with F2, it will just trigger a google search if my input does not match an already open page.

    For me, as soon as I hit F2 and start typing a drop-down list appears, filtered by what I'm typing, with all matching items in up to 4 categories: Tabs, Bookmarks, History, and Google (or other default) Search… ...So it isn't just open tabs in the list, but Google search is always last in the list. As I type more letters, most or all of the items above Google search disappear (I'm sure as the Bookmarks and History lists get longer with more Vivaldi use, there will be more items above Google search).



  • @gdveggie:

    For me, as soon as I hit F2 and start typing a drop-down list appears, filtered by what I'm typing, with all matching items in up to 4 categories: Tabs, Bookmarks, History, and Google (or other default) Search… ...So it isn't just open tabs in the list, but Google search is always last in the list. As I type more letters, most or all of the items above Google search disappear (I'm sure as the Bookmarks and History lists get longer with more Vivaldi use, there will be more items above Google search).

    Confirmed. For some reason it did not work the first time I tried it.
    It is not quite as fast as using Ctrl-l in chrome or Firefox or Vivaldi in windowed mode, but it's at least a solution, thank you!



  • @mbert:

    It is not quite as fast as using Ctrl-l in chrome or Firefox or Vivaldi in windowed mode, but it's at least a solution, thank you!

    You're welcome. Now that I'm familiar with it, I've gotta say it's pretty nifty, and I may start using it myself! ;)


  • Moderator

    I got a clean profile and F2 is working now, I'll have to check which flag/setting is killing it.

    Here as soon as I type the last option is Address and it works kind like the address bar.

    I believe it should be over search since when I type a space address disappear, which is obvious since addresses do not contain spaces. Ctrl+Enter should also autocomplete.

    @mbert:

    (it's a lower-case 'L' by the way!).

    Dude, that's why people write shortcut letters in uppercase, to avoid this confusion, everybody was thinking about "i" and not "L".


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.