Colourmanagement when playing back videos



  • Hi!

    When watching some YT-content I noticed some weird issue with the colours of the video: The dark tones are crushed to a green/black tone, losing all the details in the shadows. It looks awful!
    I tested, whether I could replicate this in Mozilla Firefox or Chromium, but in both browsers the video seems fine and the shadows are as detailed as they should be.

    For comparison: on the left Vivaldi and on the right side Firefox respectively Chromium:
    1_1534459626969_Bildschirmfoto von 2018-08-17 00-32-33.jpg 0_1534459626969_Bildschirmfoto von 2018-08-17 00-31-34.jpg

    Are there any options for colourmanagement in vivaldi that I am not aware of or is this a bug?

    With best regards

    HeroD0t

    P.S.: I am using Linux Mint 19 with the nouveau graphics driver.



  • Have you tried changing the current Theme?

    @herod0t said in Colourmanagement when playing back videos:

    Are there any options for colourmanagement in vivaldi

    There are two settings for colors:

    Alt + P >> Appearance - I never tried it.
    The second is Themes



  • @herod0t multiple other possibilities:

    • Different codecs (vp09, h264) see right click on videostatistics for nerds
    • active/disabled video acceleration or GPU-assisted decode
    • usage of bundled libffmpeg (or only partly compatible variant from Chromium)


  • @becm said in Colourmanagement when playing back videos:

    Different codecs (vp09, h264) see right click on video → statistics for nerds

    Vivaldi: VP09
    Chromium: VP09
    Firefox: VP09

    So that can be ruled out. But I should test, if the problem is still occuring when using h.264.

    Edit: https://www.quirksmode.org/html5/tests/video.html

    If the testvideos work correctly, the problem occurs only in the webm (which is a VP9 Container) video. However the shadows are definitely rendered worse than in the other codecs (in Firefox the shadows are black):

    0_1534466406105_Bildschirmfoto von 2018-08-17 02-37-57.jpg

    @becm said in Colourmanagement when playing back videos:

    active/disabled video acceleration or GPU-assisted decode

    Chromium: Hardware acceleration enabled
    In Firefox and Vivaldi there seems to be no option.
    (At least not at the surface)

    Edit: Used vivaldi://flags and disabled "Accelerated 2D Canvas" - didn't solve the problem.

    @becm said in Colourmanagement when playing back videos:

    usage of bundled libffmpeg (or only partly compatible variant from Chromium)

    Any way to check that?

    @lamarca
    The interface options shouldn't change anything. I changed the theme to the default light theme and as expected it didn't change the video.
    Also there is a contrast option in the settings, but that behaves as expected and only affects the theme. (I am using the default setting).



  • @herod0t said in Colourmanagement when playing back videos:

    The interface options shouldn't change anything. I changed the theme to the default light theme and as expected

    All the Themes can be edited




    Codecs & DRM

    1 https://help.vivaldi.com/article/html5-audio-video-on-linux/ and for other distros

    2 https://help.vivaldi.com/article/netflix-on-linux/


  • Moderator

    Please try to set a color profile:
    Open internal page chrome://flags/#force-color-profile
    Change to sRGB
    Restart Vivaldi

    Please try to override driver/GPU specific patches:
    Open chrome://flags/#ignore-gpu-blacklist
    Set to Enable
    Restart Vivaldi



  • @gwen-dragon said in Colourmanagement when playing back videos:

    Please try to set a color profile:
    Open internal page chrome://flags/#force-color-profile
    Change to sRGB
    Restart Vivaldi

    That solved the clipping-issue. Thank you!
    But why? My display settings are set to the RGB colourspace (I don't know if it is sRGB (according to the representation of the gamut in the CIE-1931 Diagram it is sRGB) or Adobe RGB, but it's nothing non-standard like the DCI-P3-Gamut or ProPhoto-RGB)

    @gwen-dragon said in Colourmanagement when playing back videos:

    Please try to override driver/GPU specific patches:
    Open chrome://flags/#ignore-gpu-blacklist
    Set to Enable
    Restart Vivaldi

    This does not change the image. (when sRGB is not forced)

    ========================================================

    Also I tried to replicate the problem on a windows machine. But there the videos had no clipping issues.

    ========================================================
    Note:
    When using the test videos on quirkmode.org/html5/tests/video.html the webm video buffered in 2sec chunks without showing the complete duration of the video (as it does in other browsers) .



  • @herod0t h264 is playing, so it's definitely not Vivaldi's bundled libffmpeg. ☺

    In the Bunny videos the luminance and/or color profile seems to be off for me as well (even in external player).
    Same psychadelic grass tones in webm/vp8 and barely vissible bunny at 0m42s.
    But luckily no greenish blobs on black level cutoff (maybe graphics hardware/driver dependent).

    Enforcing colour profiles does not change things for me.
    Maybe in your case the responsible part of the video pipeline this way just gets the message: "out of color space, paint it black"
    But it for now at least, it seems to be somebody else's problem. ☺


  • Moderator

    @herod0t said in Colourmanagement when playing back videos:

    That solved the clipping-issue. Thank you!

    Fine.

    But why? My display settings are set to the RGB colourspace (I don't know if it is sRGB (according to the representation of the gamut in the CIE-1931 Diagram it is sRGB) or Adobe RGB, but it's nothing non-standard like the DCI-P3-Gamut or ProPhoto-RGB)

    I do not know why the color space is not correctly rendered. Perhaps the Chromium core does not read the default color profile of OS correctly.



Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.