No video on some sites



  • Re: Widevine and Flash for Vivaldi on ARM (Spotify and Tidal access)
    Vimeo and Real video use flash. After following steps above, still no video. Brightcove player uses flash. Vimeo worked for a short while by adding chromium ffmpeg extra. I got updated version of Raspbian and, adding chromium ffmpeg extra did nothing. YouTube is the only sight I can watch videos from (for over a year now, Firefox had the same issue). Is there a way to fix this? Also at the end of the above Widvine directions,I got this "rm: remove regular file 'chromeos_10575.58.0_elm_recovery_stable-channel_mp.bin'? " I entered n since it was not the zip file. Hope that was the right choice. Thanks for any help!!

    Update I retried ffmpeg (maybe I had the wrong version?) I get this error dpkg: error: cannot access archive 'chromium-codecs-ffmpeg-extra_67.0.3396.62-Oubuntu1_armhf.deb': No such file or directory I cd /home/pi/Downloads still same error. Tried double clicking on it and I get this error after confirming install "a package could not be found that allows action to complete. More information is available in the detailed report" How do I access this report?


  • Moderator

    Chromium ffmpeg must match the version with Vivaldi Chromium version. If you are using stable you need v65 and v67 for the snapshots. No idea about Flash.



  • Thank you. I guess the problem is I uninstalled Chrome right after installing OS. Used ls and copied file name to solve terminal issue. Don't understand were I goofed there but, 1 hurdle jumped. I'll try to match versions now.


  • Moderator

    Please type vivaldi://version on the address bar.
    Check the User Agent string, is Chrome 67 present?
    If so, download and run the script below:

    https://gist.github.com/ruario/4eecac838ebfd3a7a164b4f4ee850f30

    You will get INSTALLED_VERSION=68.0.3440.42



  • @lamarca Pi cannot find the version. Tried running script anyway got this
    This script installs the Chromium beta libffmpeg.so from the Saikrishna
    Arcot PPA (saiarcot895). You only need to do this if you are running
    a Vivaldi Snapshot with a newer Chromium engine that the current
    Chromium stable. If this is not the case you should use
    "latest-proprietary-media.sh" instead.

    Could not work out the latest version; exiting

    Here is result of vivaldi://version
    bash: vivaldi://version: No such file or directory

    Got the June version of Raspbian and put it on a new SD card. I'll try it on the new OS right after installing Vivaldi without removing Chromium. Also won,t run Github remove bloat script. Maybe it broke some paths?


  • Moderator

    @jjl The current Snapshot is using Chrome 67, according to the post description (very clear), I suspect your engine is 67. The error message is from the terminal.
    Type vivaldi://version on Vivaldi address bar. Under unknown circumstances, just vivaldi://about works.
    Here is the command output. In fact is a dump
    We are looking for the string in bold

    Vivaldi 1.16.1230.1 (Developer Build) snapshot (64-bit)
    Revision 9692f1b5efe9718f1ededb9a89f025be92848312-refs/branch-heads/3440@{#132}
    OS Linux
    JavaScript V8 6.7.288.46
    Flash (Disabled)

    User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.102 Safari/537.36 Vivaldi/1.97.1230.1

    Command Line /var/tmp/vivaldi-snapshot-1.16.1230.1-x64-lamarca/opt/vivaldi-snapshot/vivaldi-snapshot --user-data-dir=/var/tmp/vivaldi-snapshot-1.16.1230.1-x64-lamarca-user-data --flag-switches-begin --flag-switches-end
    Executable Path /var/tmp/vivaldi-snapshot-1.16.1230.1-x64-lamarca/opt/vivaldi-snapshot/vivaldi-snapshot
    Profile Path /var/tmp/vivaldi-snapshot-1.16.1230.1-x64-lamarca-user-data/Default

    If you have any doubt, which I don't believe, just ask. Could you do me a favor? Your feedback



  • @lamarca said in No video on some sites:

    vivaldi://version

    Vivaldi 1.15.1147.52 (Stable channel) (32-bit)
    Revision 6f366dbb9172720708b4db54fba0e304861fbd42-
    OS Linux
    JavaScript V8 6.5.254.41
    Flash (Disabled)
    User Agent Mozilla/5.0 (X11; Linux armv7l) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.183 Safari/537.36 Vivaldi/1.96.1147.52
    Command Line /usr/bin/vivaldi-stable --flag-switches-begin --flag-switches-end
    Executable Path /opt/vivaldi/vivaldi
    Profile Path /home/pi/.config/vivaldi/Default

    Sorry I'm a bit of a noob.I failed to follow directions correctly after rereading. From other posts I was looking for version version 65 or 67. I found the Vivaldi version yesterday by clicking Vivaldi menu/Help/About. The version is nowhere near 65 or 67 so I was confused and, still am. I always use the latest stable version avail in upgrade. Chromium is the same now, it was uninstalled. I always "sudo apt-get upgrade && sudo apt-get dist-upgrade" weekly or when having problems. I'm on Raspbian 2018-06-27-rasbian-stretch. Thanks for the help. Also the github link for read this for stable is broke from https://gist.github.com/ruario/4eecac838ebfd3a7a164b4f4ee850f30


  • Moderator

    @jjl Part of the issue is solved, Vivaldi-Stable updated. The version is 1.15.1147.52 on 32-bit, which uses the engine of Chrome 65
    Never mind for the link on your post. It's for Chrome 67
    Could you please open the terminal and issue the following command line:
    apt-cache policy chromium-codecs-ffmpeg-extra
    Just to be sure you don't have the package installed, the output should be: Installed: (none)

    Now just follow the instructions on the link below
    https://help.vivaldi.com/article/html5-mp4-h-264-aac-support-under-linux/

    sudo apt update && sudo apt install chromium-codecs-ffmpeg-extra
    

    In 5 minutes and you are done:)



  • @lamarca said in No video on some sites:

    apt-cache policy chromium-codecs-ffmpeg-extra

    It must be a paert of the New Raspbian here is the result
    chromium-codecs-ffmpeg-extra:
    Installed: 65.0.3325.181-0+rpt4
    Candidate: 65.0.3325.181-0+rpt4
    Version table:
    *** 65.0.3325.181-0+rpt4 500
    500 http://archive.raspberrypi.org/debian stretch/main armhf Packages
    100 /var/lib/dpkg/status
    Still no video on vimeo same for real video. Sorry about the slow response I was working today. I'm holding off on your link, since it was installed by chromium upgrade. I may just have to point Vivaldi to them???


  • Moderator

    Hi, I read the command output and searched for the last version. All the search results are not reliable.
    The stable are using 65.0.3325.183
    I will ping a Linux specialist and tell him about your issue.


  • Moderator

    Hi, I found the man, he asked to report a Bug, and post the number here.


  • Moderator

    Here is the Bug Number: VB-41717


  • Vivaldi Team

    Which videos play on this website:

    https://www.quirksmode.org/html5/tests/video.html

    I presume that H.264/MP4 fails and WebM and Ogg/Theora work fine but would appreciate the confirmation.

    It would also help if you started Vivaldi like so from the terminal

    bash -x /opt/vivaldi/vivaldi
    

    As soon as it has started, quit and copy and paste everything that was printed in the terminal window as it started up.


  • Vivaldi Team

    P.S. I suspect all you need is:

    wget http://ports.ubuntu.com/ubuntu-ports/pool/universe/c/chromium-browser/chromium-codecs-ffmpeg-extra_65.0.3325.181-0ubuntu0.14.04.1_armhf.deb
    ar p chromium-codecs-ffmpeg-extra_65.0.3325.181-0ubuntu0.14.04.1_armhf.deb data.tar.xz | tar Jx ./usr/lib/chromium-browser/libffmpeg.so --strip 4
    install -Dm644 libffmpeg.so ~/.local/lib/vivaldi/libffmpeg.so
    

  • Vivaldi Team

    @an_dz said in No video on some sites:

    Chromium ffmpeg must match the version with Vivaldi Chromium version. If you are using stable you need v65 and v67 for the snapshots. No idea about Flash.

    The version they are mentioning is for ChromeOS because they are installing Widevine, via these directions.

    Though without getting proprietary media working first, that will be of zero help



  • @lamarca Thanks, it did work on an older version of Raspbian a 2017 or older version. I started from scratch on a new SD card with the latest version yesterday. Looks like the codecs are a Raspbian package now. It works for Chrome but not Vivaldi. This is what I used before and it worked on the old Raspbian version. It failed on the 2018-04-19 version. 2018-06-29 has them already or, gets them in the auto upgrade on first boot. Looks like a Raspbian package issue now
    https://gist.github.com/ruario/bec42d156d30affef655



  • @lamarca I think the answer may lie in the last half of this second command. I just need to point Vivaldi to it but, don't know how. If I understand correctly, it is creating a new library for Vivaldi, something I never did. The Raspbian package is for chromium
    ar p chromium-codecs-ffmpeg-extra_66.0.3359.181*.deb data.tar.xz | tar Jx ./usr/lib/chromium-browser/libffmpeg.so --strip 4
    install -Dm644 libffmpeg.so "$HOME/.local/lib/vivaldi/libffmpeg.so"
    Since they are already installed elsewhere would this correct it? It did not work on the 2018-04 version. Should I remove Chromium and follow the install after confirming they got removed with chromium? Can I just install without removing Chromium, since it would be a new library? I'm going to try the latter. I can start over again if need be.



  • @ruario Thanks that did it! Should have tried it sooner



  • @lamarca Problem solved with Ruario's comand line

    You can tell them to cancel the bug report. I just needed to install them for vivaldi via ruario's script.


  • Moderator


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.