Cannot install on old intel Core Duo Macbook



  • Hi, I was looking for a fast lightweight browser for this mac as the others are all stopping support. I cannot install Vivaldi on this machine. is this an OS issue, it is running snow leopard and won't go any higher. thanks in advance Frank



  • only the first release is working for me otherwise the other are for newer device pity …


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.