Is this how private window should work (with --incognito switch)?



  • I'm logged in to some Website in my normal window.

    I open a private window to log in with a different account, but the private window knows my session and opens my account right away. This is not how this is supposed to happen Oo. What is so private about a private window?

    I suppose the private window knows about all the cookies from the normal window. Which to me is a big no no and a breach of privacy

    [modedit] added information about used command line switch to title


  • Moderator

    @m-e Which version number are you using, so that I may test it?


  • Moderator

    I tested it here on Vivaldi forum with Vivaldi Stable and Snapshot.
    Private Windows did not know session from my login in regular window.

    Tell me where this happens. Perhaps the site you visit uses Supercookies or tracks you by browser user-agent and IP.



  • 1.15.1147.42 (Stable channel) (32-bit)

    Was tested with paypal.

    I tested it with different browsers just to be sure they don't do it by IP if I use a different browser it works I'm not logged in.

    Vivaldi normal session 1
    Firefox private session 2
    works


  • Moderator

    @m-e Thanks. I'll test.


  • Moderator

    @m-e I cannot reproduce that. PayPal wants me to sign in newly to a private window, though I am already signed in to the normal window.



  • Ok, thank you. I'll try to investigate whats wrong on my side then.


  • Moderator

    @m-e Do you have PayPal set to remember you?



  • I open my private window with --incognito

    Which seem to not work all the time. Maybe I just didn't catch it when it opened a normal window this time.

    At the moment private window works as intended I can't reproduce it myself. :|

    Sorry for the trouble I'll keep an eye on it and come back when it happens again.


  • Moderator

    @m-e said in Is this how private window should work?:

    I open my private window with --incognito
    Which seem to not work all the time.

    May be this issue is a bug.
    Please read How to Report a bug for Vivaldi carefully and then report the bug to Vivaldi bugtracker.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.