youtube not working



  • This happened a while ago and when I googled it people said it was a chrome issue and would be patched. I figured when that patch happened vivaldi would get it too. Today I updated vivaldi and still the issue persists and since I have seen no mention of it in the forums I suspect now maybe it's an issue I'm having alone. Anyone any ideas how to make it stop?

    0_1527172882890_Capture.PNG



  • Hm, youtube never stopped working for me, neither in the stable channel, nor in the snapshot channel, nor in the internal test versions.

    The XSS part in the console makes me wonder if there is something that wants to alter the page without permission, one of the suspicious things that can do it are extensions and userscripts.

    Do you have extensions installed that change the behavior of webpages? (Adblocker, Scriptblocker, stuff like better Youtube etc. pp)
    If yes, please disable them one by one and check again.
    If it works after disabling one of the extensions, that extension is the culprit which breaks it.

    If this doesn't fix it:
    Can you please check if it happens with a clean profile?

    To do so, look up the Profile path of your vivaldi install by either typing vivaldi:about in the address bar and pressing enter or V-Icon-> Help -> About.
    Then close vivaldi and just rename the "User Data" folder to e.g. "User Data (Old)" and start Vivaldi again.

    If that does not fix it:
    Some more info might be needed like: Which Vivaldi and which Windows version are you using right now?
    See vivaldi:about or V-Icon-> Help -> About
    Just copy and paste the "user agent" part here, it contains most of the necessary information.



  • @daemon_byte the displayed and many more error messages are normal for YouTube.
    To only have the error message (and view) you get is having JavaScript disabled, but it's needed for YouTube to work.

    My guess would be you disabled it globally, via chrome://settings/content/javascript or a content blocker extension.



  • @becm Checking if JS is OFF or ON is a good idea too, but then there should be 2 errors, the second one saying:

    Refused to display 'https://accounts.google.com/ServiceLogin?uilel=3&continue=https%3A%2F%2Fwww.youtube.com%2Fsignin%3Fhl%3Den%26app%3Ddesktop%26next%3D%252Fsignin_passive%26action_handle_signin%3Dtrue%26feature%3Dpassive&service=youtube&passive=true&hl=en' in a frame because it set 'X-Frame-Options' to 'deny'.

    Therefore my guess would be something like uMatrix or similar in default settings, but of course checking never hurts 🙂



  • @quhno may be an overblocking issue as well, but something prevents JavaScript form loading.
    There should at be numerous event-related complaints. ☺


  • Moderator

    @quhno Strangely, I got 2 errors (like you did) if I blocked JavaScript globally but only the single error (as shown in the original post) when I blocked JS on www.youtube.com.

    In Chrome 66, I only saw a single Refused to display... error when I blocked JS on the site and when I blocked JS globally.



  • @xyzzy could not reproduce behaviour depending on JS block state in a stable way.

    I somtimes however get a page version without the google account iframe on about every 20th request (different main page source).
    Or a version without placeholders…
    The frame (error) difference might be some A/B-testing on google's end, not blocker related at all…


  • Moderator

    @becm Okay, thanks. I noticed some inconsistencies as well but also didn't do as many test runs as you did. When I saw an unexpected variance, I thought that perhaps I had made a mistake and not been exact in my methods across tests. (e.g. clearing private data, etc.)

    That said, if I didn't block JavaScript or use a content blocker like uMatrix, YouTube seems to work fine for me.



  • Not sure if this is a Vivaldi issue or the spring Win10 upgrade. As I watch YouTube videos the volume goes down.
    The volume is just right, then goes down. The only way to increase the volume as I desire is to either rewind/fast forward or
    reload the page completely. Also the video view screen began taking up more real estate. The screen is as big as it is in (yuck) Chrome.


  • Moderator

    @para-noid
    I am not the allmighty allknowing dragon, dear.
    Please tell us so we can check the video:
    Which Vivaldi version?
    Which Windows 10?
    Which URL?



  • @gwen-dragon Every single YouTube video. Since yesterday the video screen has been back to normal.
    The volume issue seems to come and go. I do mean every single video. Like I said, "not sue if this is a Vivaldi or a Win10 spring upgrade issue."


  • Moderator

    @para-noid said in youtube not working:

    spring Win10 upgrade. As I watch YouTube videos the volume goes down.

    Cant reproduce it on my Windows 10 Pro (1803) x64 and Vivaldi 1.15.1147.42 or 1.16.1183.3 x64.



  • @gwen-dragon Must be my system. It's a "hit or miss" situation. Even if I clear every cache I can find. On second thought it's exactly like the OP above. I'm thinking along the lines it is a Chromium thing.


  • Moderator

    Have you tried to clean YT cookies? I had problems with some sites that were solved/improved cleaning them



  • @gwen-dragon Sorry for not replying earlier to everyone. I didn't get any notifications that there were replies here. So on my windows 10 machine with the latest vivaldi there are no problems. However on my work pc with the latest version you see the error above. That runs windows 7. There are no ad blockers or disabled javascript options turned on but I guess it must be a config issue specific to my work setup.



  • For me, it works perfectly if i sign into my computer with a different account, but on my main account, even if I delete the Vivaldi configs, it doesn't work, however, it works in incognito mode even though I have no extensions and Vivaldi is in the same config as the other account were it works.



  • @turbowafflz said in youtube not working:

    it works in incognito mode even though I have no extensions

    That strongly suggests a problem with cookies or cache.
    Did you try clearing both?



  • @QuHno > Can you please check if it happens with a clean profile?


    YouTube did work at first, but when I started installing extensions, it broke. After that, it would not work even in Private mode with all extensions disabled. I tried to clear cookies and cache, but nothing helped. So I let Vivaldi create a new profile as you suggested and went through the setup wizard. And YouTube works. But I did not want to lose my open tabs, so I restored the original profile. Now YouTube is suddenly working again on the original profile, with all of my extensions enabled !

    I hope this will help someone find the bug and fix it soon. Remember, it is a statistical fact that most people do not complain, they simply switch to another product. So I suspect that many others have abandoned Vivaldi because of this bug. I dont like Google, but lack of YouTube support is a deal breaker.

    2.0.1309.40 (Stable Win64)



  • YouTube was down earlier.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.