Simplify Setting the Default Search Engine



  • When on the page for adding/removing/defaulting your search engine, there is a tick box to the right to select or deselect the default search engine that appears to do nothing.

    I just now realized when starting to make this post that you have to click "save".

    Before making this post, I figured out I can right-click the search engine I want as default and set it there.

    I'm probably not the only one that has made this mistake or (had to) stumble upon the right-click menu option. There might be a better way to make this apparent (set default outside of the individual search engine settings since it also doesn't work to untick default and save). At minimum, there should maybe be a prompt to save changes, but I think that is a kludge as well since only 1 can be set and none can be unset by themselves.

    Maybe just make that tick box save immediately on it's own without clicking "save" and also make the current default grey out since unticking does nothing anyways.

    Edit: being a tick box is confusing. It would make much more sense to have a button that is greyed when it is already default and raised/active when not default and upon clicking instantly sets default by itself (does not save current edits, only the default). Just needs to call the same function the right-click option does.


  • Moderator

    Moved to the Feature Requests forum.

    Since this can be done with the Right-click Menu in Settings, I don't see why it cannot be done without the Save button. The dialogue text says Set as Default Search so that is what it should do at once, just like the right-click menu.

    It is not possible to have no default search engine, nor is it possible to have two or more, but the dialogue does allow users to deselect the default search engine, which makes no sense.



  • @pesala Thanks for upvote/move. I started making the post as a bug but half way through it was a "suggestion"


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.