Fix for Reddit video freeze – Vivaldi Browser snapshot 1.16.1177.5



  • Please check the wheel-button behavior to scroll the page. It behaves strange... I am not sure what the correct behavior is, but not this one.

    Edit: Ah I see now. What is the correct behaviour by holding pressed the wheel-button and moving up / down? It selects some paragraph of text, but not all. The Indicator disappears ... I compared the behavior with Firefox, Chrome and Vivaldi stable. Vivaldi stable release behaves the same strange way.

    Qunho explaned me now, how this edit thing works. ...


  • Vivaldi Team

    @yamiryuuzero said:

    I have been having this issue since one or two snapshots ago. Whenever I press the volume control keys on my keyboard (volume up, down or mute), Vivaldi opens a new tab with Crunchyroll. I have no idea why this happens, or even why it opens Crunchyroll in specific, but it's annoying me to no end, since I have to change the focus from Vivaldi to anything else to be able to adjust the volume.

    Already reported, but is there anyone else having the same issue?

    Bizarre behavior indeed. I assume whenever you open a new tab manually you get the speed dial? Do you have the crunchyroll url bookmarked?


  • Vivaldi Ambassador

    @sjudenim: I tested my overlay panels on both vivaldi 1.15 and 1.16 and they seem to work normally (hover to show, leave and they hide). Both my overlay on click and my overlay on hover are working for me. Maybe try my code on the overlay panels post, perhaps it fixes it for you


  • Vivaldi Team

    @carlonike: We are working on a fix 🙂 Hang tight!



  • @luetage Just to follow up on this… I tried around a bit more and it turns out the icons for browser action are being ignored by Vivaldi. I have one for 16 24 and 38px defined for browser action, and for general icons 16, 48 and 128px. Vivaldi just takes the 48px from the general section. Before that I had a 19px one in there (for old address bar setup), which was ignored too, but I thought that's normal since no extension is written specifically for Vivaldi. But 16px is the Google Chrome standard, therefore I thought it would have to work.



  • @masterleo29

    Your code is javascript, not css. So it's not about working around Vivaldi's issue with hover events, it's about pointing out the fact that it's having them. It's a regression that effects other aspects of the browser's UI too. The focus is a problem when it is working between web pages and the UI but not from UI to UI. For example, hover over any toolbar button or the control buttons and remove the cursor quickly and stop abruptly. Doing this from element to the start page works as expected because that's a UI element, but doing the same thing when a web page is loaded often times results in the hover effect remaining on the button. EDIT: It seems the longer I drag the cursor the more responsive the focus becomes, it's as if the hover is acting like a timed event.

    Also, I'm using my overlay on side tabs, not the side panel, but thanks


  • Vivaldi Ambassador

    @sjudenim Thanks for clarifing. (Btw, I can't reproduce that example, maybe i'm lucky)



  • @masterleo29

    Upon further testing I am seeing that my example only works with custom svg paths that I have set and not the default ones, which makes no sense to me since paths have nothing to do with the state. Oh well, as I said this only became a problem fro me with the 1.15 branch, so something has changed on Vivaldi's end as my code hasn't.

    EDIT. Nope, having the issue with standard paths as well


  • Vivaldi Ambassador

    @sjudenim cough I also have custom svg paths cough - I still use the 'old' home button and tested the hover effect on it multiple times



  • @masterleo29

    well consider yourself lucky then

    I can reproduce this behaviour easily every time. As you can see in this example, the hover state of the close button is still active in spite of the cursor location

    0_1525880006757_2018-05-09_570.png

    It's that lack of responsiveness with focus that I believe is causing the issues with my overlays, I think


  • Vivaldi Ambassador

    @sjudenim Yay, i'm lucky! Would help Vivaldi's team posting my specs here or any kind of log? for debug purposes



  • @masterleo29

    maybe, I'm not really sure but I do know that this was something that they did address in the previous snapshot cycle as others had their own issue with hanging focus for other elements.



  • I get font scaling/blurring in text areas when scrollbar gets added:
    Without:
    0_1525881982516_shot_nobar.jpg
    and with:
    0_1525882012673_shot_bar.jpg
    Was also in the previous snapshot (1170), but I didn't notice/see it before.

    Edit: Seems less obvious in those screenshots, but is very well so on my 200dpi screen here.....

    PS: In case it's important, this is from the (opensuse) bugzilla page



  • can't play videos on facebook anymore 😞
    anyone confirms?


  • Moderator

    @newscpq said in Fix for Reddit video freeze – Vivaldi Browser snapshot 1.16.1177.5:

    can't play videos on facebook anymore 😞

    Cant guess here this video is. Any hints and link to see it for us?



  • @sjudenim said in Fix for Reddit video freeze – Vivaldi Browser snapshot 1.16.1177.5:

    @masterleo29

    maybe, I'm not really sure but I do know that this was something that they did address in the previous snapshot cycle as others had their own issue with hanging focus for other elements.

    Indeed this issue was sorted a few snapshots ago, only to resurface and stay with us since then, any and all scripts do not behave as they should because the mouse cursor fails to be released from its last position.
    Regards
    raed


  • Moderator

    @aerogems Did you ever have the grey window bug? It might be related.



  • @an_dz said in Fix for Reddit video freeze – Vivaldi Browser snapshot 1.16.1177.5:

    @aerogems Did you ever have the grey window bug? It might be related.

    If by "grey window bug" you mean the entire browser window was gray and not responding... to the best of my recollection... I think so the first time, when I force quit the browser, but the second time I could definitely interact with the Settings window without any issue, it just was page loads that wouldn't work. Keep in mind I'm a little fuzzy on some of the specifics, since I wasn't making an effort to note certain things at the time.



  • youtube still loses sound after a while ...



  • No new features? Is there a set time when we'll see the lost features of Opera 12 coming on vivaldi? I'm still stuck with Opera 12.18 till i see those features on it.


Locked
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.