Option to Disable Sticky Scrollbars



  • The new sticky scrollbar handles are great, as in, in the latest version, if I keep mouse button down on the scrollbar handle and then let go, it keeps it for me so I can scroll up and down without holding the mouse button down...

    ...it's great but I think it needs to make the scrollbar move up/down even when the mouse pointer is not on the scrollbar.

    As it is now, when I move my mouse away, it stops scrolling and then I need to aim the mouse and the scroll jumps randomly up and down depending on where my mouse pointer enters it again.

    I can imagine this is good for a maximized window but I have my Windows taskbar to the right side and never have the Vivaldi window maximized because there are stock tickers behind the window I need to keep an eye on.

    This starts to be very annoying and all the time, I need to keep one eye to the right side of the screen now to make sure my mouse pointer "enters correctly". It is very tiring.

    So unless this can scroll even when the mouse is not hovering on the scrollbar, there needs to be an option to turn this feature off.

    I'm sorry if I did not manage to explain it in a good way. Ideally, this needs a video to show what I mean but hopefully my point came across anyway.

    Thank you.

    Addendum: I mean, it should behave just like when you middle click on the scrollbar. When activated, it should always keep following the mouse.

    ...or perhaps, I need to alter my workflow again? πŸ˜‰ joking


  • Moderator

    I don't think it is new behaviour. Have you just upgraded from 1.14 to 1.15? Maybe it was introduced months ago in the 1.15 Snapshots.

    I find that I have to move the mouse pointer a long way from the scrollbar (about 50 pixels) before the page jumps.

    0_1524893886448_Sticky Scrollbar.png

    BTW: You can edit your own posts by using the blue vertical dots icon at bottom right of the post.

    0_1524894029613_Edit Post.png



  • Odd, I didn't noticed this until now.

    Thank you for the Edit help. I couldn't find it! πŸ˜ƒ



  • Hm, maybe it's just me. It won't let me edit my post.

    So there is no option to disable this!? I have stopped using scrollbars at all because of this. Scrollbars are unusable for me this way. I have to use up/down arrows on keyboard now. 😞

    Edit: I found it! The design of most Web sites these days are definitely not user friendly. I did not see the almost invisible gray bar... so I clicked on the menu for the previous post. Imho, the tools should be on top of each post, not the bottom, specially if the post is very long.

    0_1524958520361_invisible.png


  • Vivaldi Ambassador

    What are sticky scrollbars? How do they work? What do they do?



  • @joelyoung said in Option to Disable Sticky Scrollbars:

    What are sticky scrollbars? How do they work? What do they do?

    When you scroll in a Web site, keep holding the mouse down for 1-2 seconds and move it off the scroll... the scroll handle then keeps "down" and if you hover mouse into the scrollbar, the scroll jumps up or down depending on where your mouse moves into it.

    It has made me not be able to use scrolls AT ALL. Very frustrating. It is so bad that I am close to switch back to FireFox just because of this. It has made Vivaldi unusuable, scrollbars are very important for me personally.


  • Vivaldi Ambassador

    @fne Strange, I can't get it to work for me.



  • @joelyoung said in Option to Disable Sticky Scrollbars:

    @fne Strange, I can't get it to work for me.

    Strange. This thing is driving me crazy!!! I can't believe no one else noticed this or maybe peolpe think their mouse is broken.

    I'm curently looking at FireFox again, I might need to switch back to it. Every darn scrollbar sticks to my mouse, inside textboxes, everything. I'm a developer and this is absolutely messing with my mind.



  • I'm confused! This is not feature, this is a bug!??! ---> https://forum.vivaldi.net/topic/26480/scrollbar-bug/


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.