Black Screen

  • Hello and a huge thanks for all your efforts so far on this really promising browser. I'm on linux Mint 17.1 xfce 64bit. I tried to use both the easter snapshot and the TP2 versions, but when I try to load a youtube video the screen goes black, I can here the video playing but have no control over my laptop. I read some post saying about hitting F11, but nothing happens. I have to restart the laptop to gain control. The laptop is not frozen as I can also listen the background music from Clementine playing at the same time while I was browsing for instance. Any ideas ? Thanks in advance.

  • First question … do you have pepper-flash installed on your machine?

  • Yes. apt-cache search gives me pepperflashplugin-nonfree, which I have installed.

  • Before posting here, and when trying the Easter snapshot version, I had tried the solution suggested here , to delete the Current Tabs file at ~/.config/vivaldi/Default, without any success.

    Now with the TP2 version this seems to work..

    I'll keep testing to make sure it is permanent.

    Is it possible to have both TP2 and Easter snapshot versions installed at the same time in order to test Easter snaphsot as well ?


  • Another black screen just happened when opening Vivaldi's Settings menu… 😞

    Edit: This only happens when I press on any sub-section on the left side of the Settings window, e.g the Appearance, Navigation, Privacy menus.

  • And another one… when visiting the chrome extension page..

    Does anyone have an idea why this happens? I only get this problem with Vivaldi. Opera 12 and Firefox never gave my any black screens.

  • Finall I found what was causing it!

    I started searching the net for similar chromium behaviou. The exact same behaviour happens in chromium too.

    And the workaround is to disable hardware acceleration:

    Now there are no freezes or black screens on any of the above cases!

  • On Beta 2, my settings window is entirely black right away after bringing it up. I will try the latest snapshot and see how that does. I am using Linux Mint 17.3 64 bit Cinnamon. In the past when I tried Vivaldi, I never had this problem. I have also never experienced anything like this in Chrome, Chromium, Firefox, or any other web browser. My graphics card is an AMD Radeo 7500 M series. I am using the open source drivers that come pre-installed with my OS. According to the Driver Manager, this is my driver: xserver-xorg-video-ati Version 1:7.3.0-1ubuntu3.1. In the past when I did not have this problem, I think I was using AMD's proprietary driver, but that driver has limitations that I can't live with. The following are the reasons why I prefer the open source driver, and the reasons why I think Vivaldi should support that driver well. The proprietary driver does not allow me to use more than two monitors at once, and it is reported by DisplayLink to not be compatible with their Ubuntu video driver, which I have tried to get to work for me, and plan to try again in the future. I want to use the DisplayLink driver in conjunction with the open source AMD driver because I want to use both the graphics card in my computer, and the graphics card in my Anker USB dock, so I can have lots of monitors going at once.

    The following is supplementary information. Don't read it if you are only interested in helping me with my problem. I really like the concept for Vivaldi, but currently it is unusable for me. I think all browsers currently in existence could work much better than they do, and I think Vivaldi could be on the path to becoming my favorite browser because of their vision and continued development. In the past I tried both betas and snapshots and they were both too buggy for me. I thought I would give it another try since I haven't used it for a while and several releases have come out and they keep talking about bug fixes. I figured the beta would be less buggy than the snapshots, so I started with that. If anything, it seems to have gone backwards. I can't even bring up the settings screen now.

  • I installed the latest snapshot 1.0.390.3, and now this is not happening in either the snapshot version or the beta version. Even though I no longer have any known issues at this time, this was enough to convince me to uninstall Vivaldi and leave it alone for a time before trying it again. But I did want to at least give the team a chance to see what kind of issues I have had so they can hopefully improve things.

  • Moderator

    This may be a problem with GPU and rendering.
    Try to start Vivaldi with shell parameters: –disable-gpu --disable-software-rasterizer


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.