Some issues with numbers and spaces in font



  • Since some Days, some Homepages like ebay look like this.
    With Firefox, it looks fine. Both Browser use uBlock.
    0_1524250082258_Bildschirmfoto.png

    Got someone a hint or a solution?



  • @usernotwo I take a look right now (eBay.it and .de) and it's work fine for me. I'm with Mint 18.2 (64bit) but still Vivaldi 1.14 version.
    Maybe you would give some information about you're system/software then more people can help you by tryng reproducing issue.


  • Moderator

    May be:
    Broken fonts
    Update of font rendering engine in Linux
    hardware acceleration in graphics card



  • Sry, i forgot..
    Linux Mint 18.3 (64bit)
    Vivaldi 1.14.1077.60 (Stable channel) (64-Bit)

    I turned off the Hardware Acceleration in the Vivaldi Settings (vivaldi://settings/search). With no Effect.

    I changed the fonts, in the Vivaldi font Setting, with no Effect.
    Sry, how to update the font rendering engine?
    I'm new to Linux.



  • @usernotwo hey, while waiting for @Gwen-Dragon response (i'm noob with Linux šŸ˜› ) you would try this command that "erase and rescan font engine"

    • fc-cache -rv

    Maybe can fix...



  • Hi @marko-indaco i tried the command and it says at the end fc-cache: succeeded

    But it did not solve the problem.



  • @usernotwo unlucky then, i cannot help more with my few knoledge with Linux, sorry...



  • @marko-indaco thx anyway


  • Moderator

    @UserNoTwo Did you change in vivaldi://settings/webpages/ some settings for fonts?

    Please give me the URL where this happens. I like to check it on my Mint.
    OK, found it: https://www.ebay.de/b/TV-Video-Audio/293/bn_1845125


    I can not reproduce it on my 18.3 Mint with latest Vivaldi 1.14 Stable and 1.15 Snapshot.

    I advise you to reset the browser profile (result in loss of some settings):

    1. close Vivaldi
    2. start the file manager
    3. open your Personal Folder
    4. Hit Ctrl+L to show the path
    5. add .config/vivaldi/ at ed of shown path and open
    6. navigate to folder Default
    7. delete all files in folder !!!! except these !!!!:
      • Login Data
      • Bookmarks
      • Notes
      • Top Sites
      • Favicons
    8. start Vivaldi


  • @gwen-dragon
    Sry, this did not solve the Problem.


  • Moderator

    You tried to start in Private Window? Does the issue happen then? If not a extension causes your problem.

    Can you please tell me which standard fonts are set in Vivaldi at vivaldi://settings/webpages/



  • Same Issue in Normal and in Private Window.
    If i turn off the only Extension installed (uBlock), the Problem is still there.
    The standard font at this moment is "Ubuntu". I already changed this to "Ubuntu" for testing. Formerly the standard fonts where "Abyssinical SIL" and some others.


  • Moderator

    The Website at ebay uses fonts in teh following order:
    Helvetica Neue, Helvetica, Arial, Roboto, sans-serif.

    Perhaps on your Mint the font substitution is wrong.
    in shell what is the output of following lines?

    fc-match Helvetica
    fc-match "Helvetica Neue"
    fc-match Arial
    fc-match Roboto
    fc-match sans-serif

    Mine:

    test@minna ~ $ fc-match Helvetica
    n019003l.pfb: "Nimbus Sans L" "Regular"
    test@minna ~ $ fc-match "Helvetica Neue"
    DejaVuSans.ttf: "DejaVu Sans" "Book"
    test@minna ~ $ fc-match Roboto
    DejaVuSans.ttf: "DejaVu Sans" "Book"
    test@minna ~ $ fc-match Arial
    LiberationSans-Regular.ttf: "Liberation Sans" "Regular"
    test@minna ~ $ fc-match sans-serif
    DejaVuSans.ttf: "DejaVu Sans" "Book"
    


  • I got exactly the same output.


  • Moderator

    Hmm, i do not know what may be wrong on your Mint.

    Can you please check your font versions:

    dpkg -l fonts* | grep ii | egrep -i 'nim|dejavu|liberation'
    

    Mine:

    ii  fonts-dejavu                2.35-1                                 all          metapackage to pull in fonts-dejavu-core and fonts-dejavu-extra
    ii  fonts-dejavu-core           2.35-1                                 all          Vera font family derivate with additional characters
    ii  fonts-dejavu-extra          2.35-1                                 all          Vera font family derivate with additional characters (extra variants)
    ii  fonts-liberation            1.07.4-1                               all          Fonts with the same metrics as Times, Arial and Courier
    test@minna ~ $ 
    

    Perhaps you have broken font files.
    You should reinstall them with

    sudo -i
    apt reinstall `dpkg -l fonts* | grep ii | egrep -i 'nim|dejavu|liberation' | cut -d" " -f3`
    


  • My Output:
    0_1524482374702_Bildschirmfoto.png

    I did reinstall the fonts. But the problem is still there.


  • Moderator

    I guess it is something related to graphics card. But i do not know what it could be.



  • guys, cuold be something related to ISO character encodings?
    @UserNoTwo did you try to change fonts within Fonts section in Webapages Settings menu?
    Also in Mint Language Settings, in System Localisation --> Apply to all system (sorry, maybe the names of settings is slightly different... i'm with italian Mint language settings...). Also look at Language Support if maybe there's some updates.



  • @marko-indaco said in Some Issues with Numbers and Spaces:

    @UserNoTwo did you try to change fonts within Fonts section in Webapages Settings menu?

    Yes i did, but with no effect.

    Also in Mint Language Settings, in System Localisation --> Apply to all system (sorry, maybe the names of settings is slightly different... i'm with italian Mint language settings...).

    I add some Languages (like Germany ISO..) Changed the selected Language und "Apply to all system".
    But with no Effect.

    So i changed it back to German UTF-8.
    No Effect

    Also look at Language Support if maybe there's some updates.

    It says "Some Language Pakets are missing." So i installed them. Two Pakets for Libre Office where installed.
    But this had no Effect to the problem with Vivaldi.


  • Moderator

    Please check, would be interesting if you have the same display issue with Chromium 64 and 65.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.