More HTML5 audio fixes – Vivaldi Browser snapshot 1.15.1147.23



  • It seems that the resize cursor to resize the Dev Tools tab is missing.

    Dev tools tab is still resizeable, but the cursor doesn't change when hovering over to the border between the page and the Dev Tools tab.

    This happened with the earlier version(s) too, I reckon this came after updating to version 1.15.1146.5 or 1.15.1147.19.


  • Vivaldi Team

    @fred8615: It is on the todo-list. But there are many other items on that list as well. When we (I) do this, it will most likely only be done on Windows and Linux.


  • Moderator

    @espen Interesting. Does Mac present special problems for that bar?



  • @steffie: Good Steffie: You must remember, I'm a lowly aging male, and whilst you may multitask 9 VDs with aplomb, I cannot. I have a 27 inch monitor, and I enjoy one large maximized, too big, in my face visual assault! 😉 I attribute this to farsightedness, and my reluctance to wear my bifocals. I've also been describing the maximized issue incorrectly: Vivaldi maximizes, but it seems that about fifty percent of the time, upon launch, the tabs fail to fill the titlebar area. It's as though the option to remove the space between the leading edge of the tab, and the top of the screen has been unticked. As Pesla noted, ""Remove space above tabs" setting is not honoured on restarting." . It's been broken since development of 1.14x started. Version 1.13 was fine in this regard.

    This is crazy OCD on my part, I know! I realize that this is a mere 'cosmetic' issue. I'll be back - Vivaldi is just so RIGHT in practically every regard. Cheers.



  • @steffie Five hours later & still not broken.

    Yet...



  • @gigzama I am extremely grateful that you replied, & gave me such a nice explanation... that totally makes sense. Thank you.



  • @kurre: confirmed on Win7-x64, Viv-x64


  • Moderator

    @kenedz That is i known issue since a few Snapshot versions.


  • Vivaldi Team

    @ayespy: We use the standard system menu. Poor support in cocoa for that functionality. At least last time I checked.



  • @dicks: @gwen-dragon: @pesala: same problem here since last snapshot. Opening links from any other programs in Vivaldi crashes it, or you can even run vivaldi.exe while it's opened already, and it crashes. Very annoying. I hope it's officially reported.


  • Vivaldi Team

    @ochi: Fyi, VB-35892 still could be reproduced. Reopened & fixin’.



  • I immediately see two regressions:

    1. Opening links from outside Vivaldi open properly in a new tab, but now that tab is in the background. Accourding to my settings, before this update, vivaldi switched to the new tab.
    2. Opening a new empty tab now does not have the focus in the address bar.


  • @braykov said in More HTML5 audio fixes – Vivaldi Browser snapshot 1.15.1147.23:

    I immediately see two regressions:

    1. Opening links from outside Vivaldi open properly in a new tab, but now that tab is in the background. Accourding to my settings, before this update, vivaldi switched to the new tab.

    yes I think it's already known regression, even if I can see an usefulness, maybe if this behaviour could be configurable would be the best 🙂

    1. Opening a new empty tab now does not have the focus in the address bar.

    I can't reproduce it here, ctrl-t or clicking the [+] opens a new tab and focuses on address bar as set in settings/tab handling/focus page on new tab (unchecked)


  • Moderator

    @braykov Any extension in use or special startpage/tab setting?



  • @gwen-dragon: Yes, I have extensions, but I tested in a new private window as well. The behaviour for the new tab focus is the same. And regarding start page, I do not have, I have set it to open an empty tab.
    One thing I notice now, the address bar would be focused in the new tab ONLY if the address bar was in focus before that.



  • The runaway scrollbar problem is still happening in 1.15.1147.23.



  • @ian-coog Thanks for the advice but nothing has been changed. I discovered different behaviors in video buffering between Vivaldi, Chrome and Firefox. I took a few screenshots of the video stats.

    Vivaldi:
    0_1524063830034_vivaldi_yt_stats.jpg

    Chrome Canary:
    0_1524063843258_chrome_yt_stats.jpg

    Firefox Nightly:
    0_1524063857268_firefox_yt_stats.jpg

    May the buffering break the hardware acceleration in Vivaldi? And keep in mind that this issue only appears at 60fps! No problems with 30fps (up to 4K) videos.



  • @halleandert for me Vivaldi works better in Youtube with UI animations off and HW accelerated video decode disabled, I get less frame drops (not 0 but less than 100 every 10000 frames, unless I explicitly pause/restart or do anything else leaving the video playing) and also happens that with HW decode enabled some video suddenly stops playing randomly, buffering, resume playing for some seconds, buffer again... very annoying; my ADSL 7mbit is more than enough for 720@60fps videos so it's not that data are not being sent fast enough, infact they just play fine with HW decode off, and the full file gets loaded completely way before being played to the end.



  • "switching tabs by scolling" doesnt works anymore. -.-



  • @wudini Are you referring to scrollwheel over the tabs, or RMB Tab Cycling? Both are working fine for me.


    Specs: AMD A10-6800K, 8 Gb on Win 10 64-bit •Snapshot 1.15.1147.23 (64-bit)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.