Stop changing the start page



  • I really want to start using the browser, but please stop overriding me when I change it to something like about:blank. That was annoying about Opera v12 and I don't need it from Vivaldi.


  • Moderator

    @dib_:

    I really want to start using the browser, but if you don't stop changing my motherf-ing start page to vivaldi.com I am going to uninstall this and never look back.

    I set it to about:blank for a reason. Stop overriding me. That's the same bullshit I get with Chrome and Opera.

    This has never happened to me. What sort of install do you have?



  • Just updated this morning to check the latest. Figured out what's happening is it's actually just not saving the default page if I enter about:blank and will reset to whatever previously. Just happened to be vivaldi.com because that was the browser default.



  • It isn't the same as an empty about:blank page, but you can set Speed Dial as your homepage with vivaldi://startpage


  • Moderator

    @dib_:

    Just updated this morning to check the latest. Figured out what's happening is it's actually just not saving the default page if I enter about:blank and will reset to whatever previously. Just happened to be vivaldi.com because that was the browser default.

    For now, until it's a bit more mature, the home page textbox will not save any page unless the address starts with a "valid" web protocol notation such as http://, vivald://. https://, etc.


  • Moderator

    I entered about:blank in the homepage field and after a restart it has shown up as http://about:blank but it works exactly like about:blank.



  • @An_dz:

    I entered about:blank in the homepage field and after a restart it has shown up as http://about:blank but it works exactly like about:blank.

    When I enter about:blank directly in the address bar, it shows a blank page indeed.

    When I enter about:blank in the settings' homepage, it converts to http://about:blank when I launch settings again, and when I create a new window, it shows an address like chrome-extension://mpognobbkildjkofajifpdfhcoklimli/http://about:blank, and an error message "This webpage is not found" with a red face is displayed below.

    So I can display a blank page manually, but I can't set a blank page as my homepage. :-(

    Windows 7, Vivaldi 1.0.162.9


  • Moderator

    Use about://about:blank It worked here as well as test://about:blank



  • @An_dz:

    Use about://about:blank It worked here as well as test://about:blank

    Many thanks! about://about:blank works indeed. Quite unobvious, isn't it? :-)

    P.S. Though, when I create a new tab, it shows the speed dial instead of a blank page.


  • Moderator

    Well, it's only a workaround I had the guess it could work. If you have not yet sent a bug report with this problem, do so now.

    Right now Vivaldi doesn't have settings to set behaviour of new tabs, so it's always SD.



  • @GoblinAlchemist:

    I can't set a blank page as my homepage

    Filed a bugreport VB-7653. Yes, there is a strange workaround, but it should be simpler.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.