Googlemaps - how to disable hardware acceleration??



  • Has anyone tried to use googlemaps on Vivaldi?? It's horrendously slow and drags my entire system down! I know there was an issue with Chrome and the fix was to uncheck 'enable hardware acceleration' in the settings - I don't see the option with Vivaldi? Interestingly Maxthon (using chrome engine) doesn't have the issue?!? Anyone know how to get around it?


  • Moderator

    Don't know for sure. You could try "disable accelerated 2D Canvas" in vivaldi://flags and see if that does anything. I personally have never seen the issue.



  • I am affected by this myself and I just found the following link and am about to try it.
    https://vivaldi.net/en-US/forum/vivaldi-browser/1342-hardware-acceleration



  • Tried it and it did not work. Vivaldi is still trying to use the GPU. I even went through the flags settings and searched for all instances of "GPU" and turned off those that looked relevant. All other Chromium based browsers including Opera have a single option to disable hardware acceleration which works across the board in these browsers. Firefox also has a setting as well which also works across the board.

    I ran vivaldi://gpu and found (see Graphics Feature Status immediately below) that I still have hardware acceleration enabled for many processes, with no easy way to turn them all off!

    Graphics Feature Status
    Canvas: Software only. Hardware acceleration disabled
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Disabled
    Rasterization: Software only, hardware acceleration unavailable
    Threaded Rasterization: Enabled
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated

    Vivaldi needs to address this and have a single settings so that those users who experience GPU and directly resulting memory and CPU issues can turn it off for all processes where the browser may attempt to use the GPU directly.


  • Moderator

    see if it works: uncheck the box vivaldi://chrome/settings/search#hardware



  • Thanks. This appears to have done the trick. Shame its buried deep in Settings and you have to search for it as it's not visible when accessing Settings from the Tools menu.

    This setting needs to be visible from the Tools > Settings menu.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.