The way Vivaldi handles Flash



  • For a time I thought that Flash hadn't been properly installed in Vivaldi. Then I find out that websites tell me Flash have not been installed, but I have to press the lock/globe icon on the address bar, and change the Flash setting from "ask (standard)" to "allow on this website" (paraphrasing).

    No website I've visited with Flash, have Vivaldi asked if I want to activate flash. It seems to pretend like Flash isn't even installed.

    Is this intended behaviour?



  • I have used Flash in Vivaldi for years and never faced such problems. Recently I've uninstalled Flash and I have to say I don't miss it. It's technology that has reached its end of life cycle and will be discontinued completely in due time. Adobe is abandoning Flash and so should all of us.

    Anyway, you should still get it to work. I can't really comprehend your problem.



  • @nebu said in The way Vivaldi handles Flash:

    For a time I thought that Flash hadn't been properly installed in Vivaldi.

    For correctness, no flash is installed "in" Vivaldi, it's installed on the Windows directory and it's available system-wise to whatever program that can make use of it, unless that program specifically ignores the system flash dlls and use its own ones (as Chrome does).

    No website I've visited with Flash, have Vivaldi asked if I want to activate flash. It seems to pretend like Flash isn't even installed.

    If flash is not exactly the latest version it probably won't start even if activated, but once updated (current version for me is 29.0.0.113) and set to allow, it works here in the few sites using flash I know.

    Is this intended behaviour?

    I tend to believe it is, as Google Chrome (and by consequence all Chromium based browsers) wants to phase out Flash usage as soon as possible.


  • Moderator

    You have to enable Flash for the visited site in its Site Settings (can be opened with the padlock/globe in address field).
    That behavior was introduced in Chromium browser many months ago.

    Unfortunately some sites handle Flash Player detection in a wrong way and misreport that you have no Flash.

    If you want to know if Flash is detected by Vivaldi, open vivaldi://flash in address field.



  • @luetage said:

    I have used Flash in Vivaldi for years and never faced such problems. Recently I've uninstalled Flash and I have to say I don't miss it. It's technology that has reached its end of life cycle and will be discontinued completely in due time. Adobe is abandoning Flash and so should all of us.

    Ok.

    Anyway, you should still get it to work. I can't really comprehend your problem.

    Yeah, I got it working all right. It's just sites reporting it as not being installed and Vivaldi says missing plug-in or whatever – nothing that prompted me to go to the site settings and choosing "enable Flash".

    @iAN-CooG Thanks for your reply :)

    @gwen-dragon said:

    Unfortunately some sites handle Flash Player detection in a wrong way and misreport that you have no Flash.

    That's probably it. I haven't visited a lot of sites, just the odd one. It usually seems HTML5 is everywhere these days (woohoo).



  • @nebu said in The way Vivaldi handles Flash:

    It's just sites reporting it as not being installed and Vivaldi says missing plug-in or whatever – nothing that prompted me to go to the site settings and choosing "enable Flash".

    When I visit a site requiring flash where I have the setting at default ("ask"), Vivaldi will prompt for Flash to be allowed only after I click a link requiring it.

    Open adobe.co.uk (or .com etc) with setting at default "ask"- no request for Flash
    Click on Flashplayer link near bottom of page - now Vivaldi asks to allow Flash ( blocked plug-in).



  • Opera has opera://flags/#flash-detection-through-navigator-plugins

    Enable improved Flash player detecion by always adding it to the Javascript navigator.plugins object. – Mac, Windows, Linux

    Opera also added back the "Allow sites to run Flash" option that Chromium removed. That settings accepts Flash on all sites without asking. There's also my extension on this page that does that. I don't remember if I tested in in Vivaldi though.

    Chromium also blocks tiny Flash objects by default. See https://cs.chromium.org/chromium/src/chrome/renderer/plugins/chrome_plugin_placeholder.cc?rcl=176be8aebe56239c9cb8d678ce64df88930c2c97&l=356 for the rules (it's actually less than 6 x 6 and not less than or equal). In Chrome, when these are blocked, there's a notfication in the address field telling you that a plug-in was blocked. You can then click it to run those objects. You have to repeat each time the page loads though, but that's Chromium's rules. Opera didn't have the UI to detect and run these blocked objects and it broke some pages, so Opera implemented it like Chrome. I'm not sure if Vivaldi supports it or not.

    On the linked Reddit page, you can see that you can also accept Flash from all sites by adding https://*, http://* and file:///* to the Flash exceptions. I don't remember if Vivaldi exposes those settings though in its settings page, so you might have to goto chrome://settings/content/flash in Vivaldi to work around it. Also on that Reddit page, there's user css that you can use (with a user css extension) to override Chromium's tiny Flash object blocking.

    So, there's some things you and Vivaldi can do to work around Flash issues.

    But yes, the expected behavior of Chromium browsers is to have to add sites to the Flash exceptions list if you want Flash to load for the site. You only get asked to add the site as an exception if the site tries to embed a Flash object with the object or embed element. You don't get asked if the site tries to check for Flash support via JS and decides to do nothing if it's not detected.



  • I can only confirm that if Flash is not up to date, it doesn't start anymore even if clicked, the "right click to run this plugin" always stays there and no flash content is played.
    https://get.adobe.com/flashplayer/ just shows the new version is 29.0.0.140 and nothing works anymore.
    Installed the update, restarted Vivaldi, flash works again.



  • @tbgbe said:

    Open adobe.co.uk (or .com etc) with setting at default "ask"- no request for Flash
    Click on Flashplayer link near bottom of page - now Vivaldi asks to allow Flash ( blocked plug-in).

    Whaddya know, you're right. Never seen that pop up before.



  • @Nebu Where is the link on that page for Flash to click on? I see no link there and I want to see what happens.



  • @gwen-dragon

    You don't have to enable Flash in its site settings for https://helpx.adobe.com/flash-player/kb/installation-problems-flash-player-windows.html#. If you click on Check Now button on that page that enables Flash. You do not need to do anything to change from Ask to Enable within Flash settings for the page. So, Flash implementation is erratic and not the same on various websites now on Vivaldi.

    I like Vivaldi, but Basilisk will remain my default browser with Firefox 52 ESR my second choice because it is much easier to check to make sure the latest Flash installed on those browsers and much easier to use Flash on those browsers. It's too bad Vivaldi has to inherit Google's extreme attitude of hatred toward Flash. Flash is going away but not for about two more years and I still prefer it to html5.



  • The link is at the bottom of https://www.adobe.com/, in my region I get a different page.
    Popup does not show up for me if I hit the link, setup is "Ask first", on Linux with latest snapshot.

    Cheers, mib



  • @desiree said in The way Vivaldi handles Flash:

    @Nebu Where is the link on that page for Flash to click on? I see no link there and I want to see what happens.

    Near the bottom, there are four links:

    Acrobat Reader DC | Adobe Flash Player | Adobe Air | Adobe Shockwave Player

    Press the one that says Adobe Flash Player, Vivaldi should prompt you to allow flash now.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.