Active update notification pop-up vs passive TaskBar notification?



  • I'm not sure when this behavior started on my system, but for quite some time now (months?) I haven't received a pop up window advising a Vivaldi Snapshot update is available.

    Only when I happen to click on the up-caret to the left of the Windows Task Bar (for hidden icons) do I see a Vivaldi icon, which when I click on it notifies me of an available update.

    Scrolling through Tools > Settings I only see a single check box for Notify About Updates, which is checked on my system.

    Is there some way to resume the notification pop-ups when a Vivaldi Snapshot is made available?



  • @wpcoe For me it worked out by simply disable and re-enable said option.



  • Well, duh. That is so simple. I'll try it. Thanks!



  • Too good to be true? I did as @zaibon indicated, and today just noticed the passive (hidden) icon in the Windows Taskbar indicating a new Vivaldi snapshot was available.

    So, to repeat: Is there some way to re-instate the pop-up I used to get to notify me that a new snapshot is available?


  • Moderator

    @wpcoe It will show up when there is an update and when none has been checked for within the last 24 hours.



  • Not sure I understand that reply, @Ayespy.

    In the past, whenever Vivaldi found an update it would pop-up a window alerting me to the fact. I liked that.

    Now, it just silently places a hidden icon in the Windows Taskbar. I don't like that.

    How can I return to having a pop-up window every time there's a new snapshot?


  • Moderator

    @wpcoe I get the popup - but it's temporary. If you don't react with it in time, it goes to the taskbar.



  • Like, how temporary is the pop-up? When I'm using Vivaldi I rarely minimize it so am looking at it full time while it's open and I haven't seen the pop-up for quite some time -- maybe months?

    No longer than three or four days ago I checked the System Tray for the icon, and just now I found one. I can't think of a period in the past few days where I left Vivaldi un-attended.

    Beyond that, why structure the pop-up behavior that way? Make the pop-up remain until I dismiss it, or at least give me the option to set it up that way. Oh, wait, what am I dreaming? This is the Age of The Millennial where We know what's best for You. </sarcasm off>

    BTW, I just used the Check for Update feature from the Help menu item, and up pops the old familiar "A new version of Vivaldi is available!" And, that pop-up stays open until I click the X to close it. Why can't/doesn't an automatic Check for Update feature no longer do that?


  • Moderator

    @wpcoe I suppose because the devs don't want a popup obscuring the workspace forever. But I don't know. I know how it's supposed to work, but I've not explored the logic.

    I think the popup is good for a couple minutes. I've never left it there long enough to see how long it takes to expire.


  • Moderator

    @wpcoe said:

    This is the Age of The Millennial where We know what's best for You

    Or, from another point of view, the era when users think that they know better than the developers who designed the software based on decades of user feedback and experience.

    Being forced to dismiss popups before they can continue working annoys some people so much that they install ad-blocking extensions. I don't, but I do avoid web sites that stop me reading the page until I jump through some hoops.



  • @wpcoe might be the popup time got reduced to make it better integrate with the way Windows 10 handles notifications (conspiracy theory ☺).

    The taskbar icons can be configured (Windows setting) to

    • always show all icons (classic behaviour from ye oldy times)
    • select different ones to not be hidden.

    Since the updater icon is there but not visible in the collapse tray icons view (as I take it from your description), changing this setting should help to incur your attention when new versions are available.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.