Fixes for recent problems with extensions – Vivaldi Browser snapshot 1.15.1146.5



  • @jimtdi Hi Jim. Yes, that's what i meant, & that's what my SS used to do [& Stable still does]. Thanks for letting me know... it seems thus i have a local problem, groan; this'll be fun to track down. 😉



  • @paulhow Cool, for you. Bummer, for me. Teehee.



  • @steffie Yep, definitely a local profile fault here. I quickly made a temporary virgin profile, & the pointer works correctly. Sigh. Still, i'm not going to do the work of cleaning my real profile until/unless i discern other V misbehaviours... oh wait, maybe the image non-D&D is one such? Oops, better go test that now too in another virgin profile.



  • @steffie Posting this from temporary virgin SS profile... image D&D pasting works fine... so that's now two known "bugs" that it transpires are not 1.15x bugs after all, but some damage in my local profile. Sigh, so that's another unplanned job needs doing today, build a new profile. Sheesh, in the >3 years i've been using V, i have lost count of the number of times i have had to make a clean profile. Such fun.

    0_1522977819577_20180406_002.png


  • Moderator

    I am having problem with extensions still.


  • Moderator

    @ozoratsubasa That is a report that cannot be acted upon, as it contains no specifics.


  • Moderator

    @dicks: good, here I can't use it yet 😕



  • @steffie I use the same profile since 1.3? without any problems.



  • @burbuja Now you're just rubbing my nose into the mud, teehee. Others [eg Ayespy] have also remarked historically that they've rarely or never needed to rebuild their profiles.

    It's me, clearly it's me. I am radioactively toxic to Vivaldi. I love it, but it intermittently reciprocates inversely with tough love for me.

    I break things, inadvertently... all my life.

    1. Car breaks down -- mechanic / electrician remarks "wow, haven't seen a failure like this before".
    2. Washing machine breaks down -- technician remarks "wow, haven't seen a failure like this before".
    3. Linux distro breaks down -- other [insert relevant distro] online forum users remark "wow, haven't seen a failure like this before".
    4. I break down -- doctor remarks "wow, haven't seen a failure like this before; what the hell is wrong with you Steffie, why do you go through life breaking everything?".


  • @steffie I would like to have a woman like you in my house 😃



  • Not quite fixed yet. This is what it should look like when clicking the Lastpass icon:
    0_1523023182473_expectation.png

    And this is what I get sometimes:
    0_1523023212008_reality.png

    Note: Address bar is at the bottom.



  • @jacekn: You can always find me beneath Performance comments and agreeing with them!

    Anyway, could you please try disabling Hardware Acceleration and reporting back? It doesn't do anything noticeable for me and the whole UI experience is not snappy and sluggish...



  • @steffie Ha. It's taken hours of trial & error testing as usual, but now my SS seems back to normal, good as gold, hunkydory, okydokey, bleedinripper etc. I am a dope though, coz the root cause seems to have been the Preferences &/or Login Data files became corrupted, & so "all" i needed to do was delete them, then manually recreate the couple of Settings that reverted to default, recreate my desired Passwords & Accepted Cookies, then reinstall all my Extensions. Given the number of times in the past i've trod this same road i dunno why this time i bothered sequentially testing many of the other files & directories first, rather than just immediately target these two files.



  • @steffie said in Fixes for recent problems with extensions – Vivaldi Browser snapshot 1.15.1146.5:

    @steffie Ha. It's taken hours of trial & error testing as usual, but now my SS seems back to normal, good as gold, hunkydory, okydokey, bleedinripper etc. I am a dope though, coz the root cause seems to have been the Preferences &/or Login Data files became corrupted, & so "all" i needed to do was delete them, then manually recreate the couple of Settings that reverted to default, recreate my desired Passwords & Accepted Cookies, then reinstall all my Extensions. Given the number of times in the past i've trod this same road i dunno why this time i bothered sequentially testing many of the other files & directories first, rather than just immediately target these two files.

    Awesome! 🙂



  • This is the 5th Snapshot in a row. Every time I just cover over any icons with a pop-up description, it sticks wherever my mouse is and doesn't disappear until I click on the page. Sometimes I'm reading something and it's in the way. Other times I can't click on the page. https://i.imgur.com/ZYsmJgr.jpg

    Also, can anyone confirm if this is a feature or not. This is the 3rd Snapshot in a row to my knowledge that clicking and dragging on the scrollbar and moving the mouse outside of the scrollbar while releasing the mouse button behaves as it's still dragging. So all I have to do is move the mouse without any button pressed and it drags the page no matter where my mouse is.



  • @vividal said in Fixes for recent problems with extensions – Vivaldi Browser snapshot 1.15.1146.5:

    pop-up description, it sticks wherever my mouse is

    I think several posters have mentioned this. It was also happening to me until late today, when i refreshed my Profile. Since then it seems good.

    clicking and dragging on the scrollbar and moving the mouse outside of the scrollbar while releasing the mouse button behaves as it's still dragging

    --> https://forum.vivaldi.net/topic/26480/scrollbar-bug/7



  • I found a bug,sorting the bookmarks cannot stay the setting.



  • @steffie said in Fixes for recent problems with extensions – Vivaldi Browser snapshot 1.15.1146.5:

    when i refreshed my Profile. Since then it seems good.

    Correction -- nope, it just happened again, so the clean Profile was not a solution after all.



  • Very minor cosmetic issue with this snapshot: Window controls do not lose focus when the mouse leaves them. For example, if you take the side panel, and put the mouse over the "+" for example, and then move the mouse cursor to the right (using the default placement) it will still show as highlighted until you click somewhere. The tooltip for that control will also show up after you move the mouse off the control, then stop.

    The screenshot below should help demonstrate what I am talking about.

    0_1523044802218_vivaldi bug example 1.jpg


  • Moderator

    @aerogems Known issue. Being worked on.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.